Jump to content

XBox Original Ram Upgrade


Recommended Posts

Hello everyone! I want to perform RAM upgrade on my Xbox but I don't know which RAM I should buy. Here is the picture of the RAM from my Xbox:

IMG-20191111-140303.jpg

SAMSUNG K4D263238F-QC50

So my question is which RAM should I buy? I found a couple of RAM chips on ebay and AliExpress but I don't know are they going to work on my Xbox. Here is the list:

https://www.aliexpress.com/item/32890729020.html?spm=a2g0s.8937460.0.0.7efb2e0eCU8Qyr

https://www.ebay.com/itm/BRAND-NEW-Samsung-K4D263238M-QC50-128M-DDR-SDRAM-1PCS-NEW/123866715285

And, thanks in advance!

Edited by antonic901
Link to post
Share on other sites

I prefer this one:

https://www.aliexpress.com/item/1906140912.html?spm=a2g0o.detail.1000014.25.66e632cfFQP2LZ&gps-id=pcDetailBottomMoreOtherSeller&scm=1007.13338.128125.0&scm_id=1007.13338.128125.0&scm-url=1007.13338.128125.0&pvid=5487a0b6-ae82-4a31-8626-31c3d3e5c292

bye

 

Link to post
Share on other sites

Hello, 

When you will start, check that are quiet, no coffee, some classes, small Iron tip.

Take you Time, and Always check with xblast lite After each module, because your onboard bios will only boot 64 or 128Mb, but not with 81, 97, 112 Mb. If you are not in IND5006.XX onboard, do this first, if you are 1.6 version, flash first xblast OS. 

If you are in Europe, I Can send you Aladin XBLAST lite, with 1 Mb chip. This is a low cost Aladin xt plus, with a bigger chip and a New CPLD.

Bye

Link to post
Share on other sites
  • 3 months later...

Hi antonic901

Here it my 50 cents worth.

When I do ram upgrades I use a Modchip fitted with Xblast on it as you can then boot a main board without a DVD or Hard drive connected. As you fit each chip boot to the Xblast mod chip and test the ram chip and if it fails go over your work and test again DO NOT  fit the next chip until the current chip passes.

If you have not used a SMD rework station before  you are better off using a soldering iron and DO NOT forget Flux is a better friend than your Wife/Girlfriend/Lover when it comes to soldering 100 pin IC's

And if you have not soldered a 100 pin ic before go and find a old PC to practice on 1st

 

Cheers

SS Dave


Soft modding is like masturbating, It get's the job done but it's nothing like the real thing.

 

  • Like 1
Link to post
Share on other sites
  • 1 year later...

When doing the 128 mb mod i first place the chips in place the using smd rework hot air i get them tacked down. Then i go over each pin with a soldering iron. then i clean it up by going over them with hot air again to make the solder look nice and clean.  Im sure you can get it correct with just the hot air , but so far i have not had luck with that.  I need to get better it seems. but that works for me.

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

Hello to all. Chips arrived a long time ago, but first try wasnt succesfull and I give up on it. Last few days I had some spare time and I tried it again, and on my luck I made it! So I will first say what was I doing wrong first time. When it comes to soldering iron you don't need some high quality like Hakko, I have used some chinease Baku shit. :) The key to succesfull upgrade is high quality flux. First time I used sam garbage from eBay. This time I used some high-end flux (bought it in my country for 10$ and it's from Poland) and that makes things a lot easier. Allign chip on board, put flux, on your iron put just a little solder and easily slide through pins. If some pins gets connected just put more flux on that spot, put iron in rosing soldering flux, clean it, and try to remove connection. Sometimes it will need a few attempts, but with patience it will get removed.

Now, on internet I see comments that you can mix all types of Samsung chips, but that's not true. I bought chips from AliExpress (you have link in second post of this topic) and they won't work on motherboard V1.0. Chips on my V1.0 were Samsung with last letter being M. Chips from AliExprees are ending with F letter. On V1.6 boards chips are ending with letter F. I have't tried to to remove all chips from my board and put all chips from Ali on it maybe that way F chips will work on V1.0. In the end I bought working Xbox V1.0 for under 5$ (they are really inexpensive in my country) take ram chips from it and put it on my board.

Now, I have question for you. Which BIOS do you recommend for Xboxes with 128MBRAM? Xecuter X2.5035 or iND-BiOS.5003? Before this mod I was using EvoX M8+ but after flashin it back from XBlast OS I see that EvoX doesnt support 128MB RAM mod.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By calebTree
      I wonder if it's a RAM compatibility issue or indicating definitely damaged RAM IC? Does anyone know the max temp the RAM ICs are rated for?
      I am working with a 1.4 revision board and an OpenXenium which should be booting straight to XBlast. I haven't seen much info anywhere about a solid green LED in the process of a RAM upgrade.
      However when I've got a chip installed it power cycles twice then goes to solid green LED but no video and the OpenXenium LED is yellow whereas if XBlast were to have booted the OpenXenium LED would be green.
      The board has default K4D263238D-QC50 and I have tested adding K4D263238M-QC50 (salvaged from a 1.0 revision board) and K4D263238F-QC50 (bought new on eBay but I used them).
      No additional RAM boots and works fine.
      Does the yellow LED on the OpenXenium indicate anything useful? What about the solid green LED on the console?
      Thanks
    • By bot_1
      Hey folks
       
      It has been some time since I last posted. Hope you're doing well...
      What have you been up to? 😉
      I recently preordered the new version of the HDMI+ mod from MakeMhz which will arrive in july and i wanted to upgrade one of my my existing xboxes with it.
      Since I'm going to solder anyway and i got some RAM chips laying around, i thought about upgrading the RAM as well. In this regard, i was wondering if there is a BIOS that supports both (HDMI and 128MB RAM). Is the MakeMHz-BIOS taking advantage of 128MB RAM? Does somebody have some experince with this? 
       
      Thanks in advance for you thoughts!
       
      Greetings
      Bot
    • By Doom87
      Hello everyone!
      Something very strange is happening with my softmodded xbox and I really can’t figure what’s wrong.
      I recently got a used xbox in very good condition, cleaned thoroughly, clock capacitor removed, top notch condition overall.
      So, I installed a new 1TB WD hard drive (WD10EZEX) and everything went great.
      In the Hexen options I selected to make a big partition so I can put the games in there.
      So, long story short, I transferred a whole lot of games with FTP using a crossover cable, directly from my laptop to my xbox, since the Ethernet method gave me low transfer speeds.
      Everything was going great and at last I had a big library to choose and enjoy, even downloaded a big coinops pack! So, as you can tell I spent countless hours just transferring every day.
      I played daily for 1-2 weeks with no problems at all.
      Then one day, all of a sudden I saw that coinops was missing and some of the games also.
      To my surprise, they were magically deleted, and it messed up the games folders, for example there was just an empty folder with the game name and nothing in it.
      I couldn’t find any info online, so I decided to start transferring again and see if it will do this again.
      And at that point I started getting errors in Filezilla, half of the files were transferring and the others failed. The ones that fail are always the same files, everytime in every game.
      I even tried a different cable, but the result was the same.
      Another weird thing is that the later partitions (X,Y,Z) sometimes have weird files in them and other times are empty, for example at one point there was a 500MB file called gta3image.iso or something like that, and at other times, just random assorted files that it creates and deletes by itself. I never mess with those partitions, it does this by itself. The only partition I access is F which is the main ~900GB partition with my “Games” folder.
      So now, I’m with a half-broken xbox and can’t really tell what’s wrong.
      Any advice or info what may be wrong (maybe something similar has happened to someone here), will be greatly appreciated!
      I’m attaching a Filezilla report with a game I just tried transferring (25 to Life is the game), maybe someone could figure something from the report:
      https://pastebin.com/cCgfgpvf
      Please help me out fellas!
      Thanks!

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.