Jump to content
Eridyne

General Flashing and Modding Questions On XEcuter2.6 1.1&1.0

Recommended Posts

So there are some things I'm trying to figure out and having a hard time with, due to old, contradictory, or lack of info out there, and I'd greatly appreciate any thoughts. For reference, I have one each of v1.0 and v1.1, both with Xecuter 2.6 Lite chips.

If caps require replacement (not the clock cap), are there any known to have special requirements for ripple or ESR? I'm thinking regular polymer electrolytic caps from Rubycon or Nichicon would be fine?

Is there any reason to use FlashBIOS instead of XBlast? Assuming they're both stable, it looks like XBlast outright has more features.
Are the FlashBIOS/XBlast web flashing interfaces reasonably safe to use?
Without exploitable games or an Xbox/USB adapter, would the best way to TSOP flash a modchipped Xbox involve FTP backup of C&E, mod the backup with ndure, FTP it back to the Xbox, and turn off the modchip, then flash TSOP from the softmod dash?
Can Xblast be flashed to TSOP safely? I've seen posts arguing both ways.
If it can, could Xblast on TSOP be used to flash a modchip, if the chip is turned on after booting?

Share this post


Link to post
Share on other sites
4 hours ago, Eridyne said:

If it can, could Xblast on TSOP be used to flash a modchip, if the chip is turned on after booting?

No, booting from the TSOP disables access to the LPC connected flash and vice versa.

Share this post


Link to post
Share on other sites
4 minutes ago, KaosEngineer said:

No, booting from the TSOP disables access to the LPC connected flash and vice versa.

Thanks! I thought that, but I recall seeing something involving disconnecting a line like a half second after boot somewhere allowing the other way round, so... was unsure. Not something I'll try regardless.

Share this post


Link to post
Share on other sites
4 hours ago, Eridyne said:

Without exploitable games or an Xbox/USB adapter, would the best way to TSOP flash a modchipped Xbox involve FTP backup of C&E, mod the backup with ndure, FTP it back to the Xbox, and turn off the modchip, then flash TSOP from the softmod dash?

Maybe.  That's one way but there's another. FTP the Please login or register to see this link. 's Build v1.1.7 / Installer Variants / Please login or register to see this link. extracted C folder files to the root of the C drive.  This set of files contains a no-original-game-disc-required bootable Xbox Softmodding Tool installer. 

Share this post


Link to post
Share on other sites
6 minutes ago, Eridyne said:

Thanks! I thought that, but I recall seeing something involving disconnecting a line like a half second after boot somewhere allowing the other way round, so... was unsure. Not something I'll try regardless.

With a special BIOS file, you are may be able to flash the TSOP after booting from a modchip by controlling the A15 line (???) to gain access to the TSOP. However, I don't think after the Xbox boots from the TSOP, access to the LPC debug port connected flash is possible.

Share this post


Link to post
Share on other sites
2 hours ago, Eridyne said:

Thanks! I thought that, but I recall seeing something involving disconnecting a line like a half second after boot somewhere allowing the other way round, so... was unsure. Not something I'll try regardless.

Use a Xblast lite modchip with a modded M7 bios as that can recover a TSOP from a bad flash or just flash the TSOP.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites
3 hours ago, KaosEngineer said:

With a special BIOS file, you are may be able to flash the TSOP after booting from a modchip by controlling the A15 line (???) to gain access to the TSOP. However, I don't think after the Xbox boots from the TSOP, access to the LPC debug port connected flash is possible.

Yeeeah that sounds familiar. I have no idea how that actually works, as far as the D0 and A15 lines. It's all interesting, but hard to find anything about beyond the basics in the xblast lite manual and some scattered posts.

 

1 hour ago, SS_Dave said:

Use a Xblast lite modchip with a modded M7 bios as that can recover a TSOP from a bad flash or just flash the TSOP.

I wasn't aware any of the A15/D0 controlling hardware was still available. That might be a nice thing to keep around, even though (as far as I understand) that method relies on the TSOP being flashed with at least a partly-working, near-stock type BIOS.

I think a quick softmod by one or the other method sounds like the most reliable option... which I might well do, though I'm not sure what exactly I'd load on the TSOP.

Share this post


Link to post
Share on other sites
8 hours ago, Eridyne said:

Are the FlashBIOS/XBlast web flashing interfaces reasonably safe to use?

Yes  99.9% of the time there is always a really small chance something can go wrong at the wrong time and kill the chip.

8 hours ago, Eridyne said:

Is there any reason to use FlashBIOS instead of XBlast? Assuming they're both stable, it looks like XBlast outright has more features.

 have a preference for Xblast but It would not flash a Atmel TSOP chip in a version 1.4 but the raincoat flash program would.

8 hours ago, Eridyne said:

Can Xblast be flashed to TSOP safely? I've seen posts arguing both ways

Yes and No I have seen posts where it not reflash the TSOP probably because it was a Atmel AT49F002A TSOP.

8 hours ago, Eridyne said:

If it can, could Xblast on TSOP be used to flash a modchip, if the chip is turned on after booting?

No the Xbox as a rule will only look at the boot BIOS location eg TSOP or LPC port.

 

8 hours ago, Eridyne said:

Without exploitable games or an Xbox/USB adapter, would the best way to TSOP flash a mod chipped Xbox involve FTP backup of C&E, mod the backup with ndure, FTP it back to the Xbox, and turn off the modchip, then flash TSOP from the softmod dash?

Yep.

8 hours ago, Eridyne said:

If caps require replacement (not the clock cap), are there any known to have special requirements for ripple or ESR? I'm thinking regular polymer electrolytic caps from Rubycon or Nichicon would be fine?

Any low ESR brand name capacitor will be fine, and the 2 brands you mentioned are good to use.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

Thanks much for all the answers, that confirms a lot of what I suspected, and suggests that maybe the boxes would be better with a decent regular sort of BIOS that'll handle an unlocked HDD stuffed in TSOP, given that I now know that's a viable route to flash.

And a minor update to progress:

Both boxes have their clock caps removed, and neither leaked meaningfully, or did any board damage whatsoever, so I got lucky there. Inspected all the other caps while I was at it, and there are no visible signs of issues.

Tried out XBlast and FlashBIOS and prefer XBlast, so both Xecuter chips now have 5035 in bank 1 and XBlast in bank 2.

Mostly have the basic set of apps I want loaded onto the working box, though I'm still debating which dash to use. UIX looks super nice, I've always liked the OEM dash, but the FTP... basically doesn't work, and it's kinda weird in how it lists some apps and not others (still haven't figured that out). UnleashX seems to do everything you could reasonably want, and well, but I really don't like its look-and-feel nearly as much... Choices, choices.

Share this post


Link to post
Share on other sites

Here is a pic of XBMC4Gamers as a dashboard

 

Please login or register to see this link.

 

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

 

Share this post


Link to post
Share on other sites
13 hours ago, SS_Dave said:

have a preference for Xblast but It would not flash a Atmel TSOP chip in a version 1.4 but the raincoat flash program would.

What's the part number of the Atmel TSOP chip?

 

Edit: I see you later stated the part number: Atmel AT49F002A TSOP.

Share this post


Link to post
Share on other sites

Hmm, I didn't know that there were Atmel flash chips used in the Xbox.  From the flash device list I saw, there were only:

Hynix, Hyundai, ST, Winbond and Sharp.

Share this post


Link to post
Share on other sites
15 hours ago, SS_Dave said:

Here is a pic of XBMC4Gamers as a dashboard

Okay, I can't deny that XBMC4Gamers does look pretty good. I'm still just awfully fond of the original MS dash look. Nostalgia, maybe? I do genuinely think the MS dash was very nicely done, as weird as it was, and it functioned perfectly well.

And now I've found out that UIX Lite exists in public beta, and shall have to chase that down somehow-or-other. It looks amazing from what I've found.

Share this post


Link to post
Share on other sites
7 hours ago, KaosEngineer said:

Hmm, I didn't know that there were Atmel flash chips used in the Xbox.  From the flash device list I saw, there were only:

Hynix, Hyundai, ST, Winbond and Sharp.

I have seen the Atmel chip once before and both times in 1.4"s and both times it caught me out because Xblast wont flash them.

Please login or register to see this link.

 

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites
19 hours ago, Eridyne said:

Mostly have the basic set of apps I want loaded onto the working box, though I'm still debating which dash to use. UIX looks super nice, I've always liked the OEM dash, but the FTP... basically doesn't work, and it's kinda weird in how it lists some apps and not others (still haven't figured that out)

Have you tried FATXplorer. 

When the drive has been basically setup in the Xbox the remove and connect to a PC, I filled a 1tb G drive in about 12 hours on a old Del I5 desktop.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

I did use FATXplorer briefly, it was fast enough and suffered 100% fewer crashes than xplorer360~ I'm not a fan of how it can mount only a single partition at a time, but that's more a mild inconvenience. I don't really like having to take apart the Xbox to get at the drive more than necessary though, and some dashboards have decently fast FTP, which is way more convenient overall.

Also, I got ahold of the download for UIX Lite and it is kinda entirely beautiful, even without operable FTP (yet). It instantly replaced UIX as my dashboard of choice, and that's with Avalaunch, XBMC, and UnleashX all set up with nice skins for comparing. (Now I can't decide which ones to get rid of but I suppose it doesn't matter, they're not that big and I could just keep them all...)

It's weirdly neo-nostalgic, sitting there with something that keeps to the MS dash style and feel so well, but is obviously newer and prettier and does far more, while still hearing all the little dash background sounds.

Share this post


Link to post
Share on other sites
6 hours ago, SS_Dave said:

I have seen the Atmel chip once before and both times in 1.4"s and both times it caught me out because Xblast wont flash them.

Please login or register to see this link.

 

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

I've never seen an Atmel flash chip in an Xbox.  

Version 0.11 of raincoat doesn't look like it has support for that flash chip.

Which version of it does?

Edit:

I see that raincoat knows how to flash the chip - the algorithm used to do so - the same method as a lot of other flash memory chips use; however, the manufacturer and part IDs are different. 0x1F is the manufacturer ID and 0x07 or 0x08 are product IDs for the specific parts AT49F002A or AT49F002AT.  Without these lines in raincoat.conf, it's lost:

  • Flash = 0x1f07,"Atmel AT49F002A",0x40000
  • Flash = 0x1f08,"Atmel AT49F002AT",0x40000

Share this post


Link to post
Share on other sites
1 hour ago, KaosEngineer said:

I have seen the Atmel chip once before and both times in 1.4"s and both times it caught me out because Xblast wont flash them.

Maybe that will get fixed by psyko_chewbacca (BennyDiamond) - lpcmod_os @ bitbucket.com

Please login or register to see this link.

Posted an enhancement issue there with the information to add them to flashtypes.h so XBlastOS can recognize/ID the Atmel flash chips.

Share this post


Link to post
Share on other sites

That pic was 6 months ago and I might have used Slayers to reflash and the Atmel chip is listed in the ini file on a slayers installed HDD as well.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Bryang
      Softmod.  64mb xbox.  I originally thought it was cheap component cables. Replaced, didn't work.  Thought bad component connectors, switched televisions.  Still didn't work.
       
      I haven't found any pattern yet.  Has this happened to anyone else?    The blockiness/stuttering will start happening in a game or emulator, then keep happening even upon restart on the menu. Any tips?  Thanks!
    • By dirtykash
      Does anyone have a working link for Xmugen and Openbor that I can ftp to my box?
       
      thanks
    • By madmon
      I have a xbox 1.0 here that fragged the day I got it. I thought "oh HDD probably died I'll just install a modchip". Well after installing said modchip I'm still met with 3 power cycles and the red and green lights with no error codes. Ive checked my soldering, checked that D0 is grounded, checked all caps, I cleaned the board after removing the clock cap, inspected traces for any signs of trace rot. Are there any caps that could go that just wouldn't show any sign of swelling or leaking that could cause issues?  

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.