Jump to content
Sign in to follow this  
Craiguk

Painted My XBox (First Attemp)

Recommended Posts

So i decided to paint my Xbox today,  Used 2 coats of Plastic Priimer followed by 3 coast of Ignition Red.  I thought i had some clear coat but turns out i didnt.  I dont think it's turned out to bad to be honest 😃

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

Looks very nice and the leds would look good as long as they are not to bright.

 

Cheers

SS Dave


Soft modding is like masturbating, It get's the job done but it's nothing like the real thing.
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By AljeljaTheHakenzi
      Hello!I am trying to softmod my original xbox.I tried to do it using this clip:Please login or register to see this link.
      I did everything in the video correctly.So the problem is:I dont have ide ports on my motherboard so i tried using ide to sata adapter and when i plug it in my pc and turn it on,it shows in disk management as not initalized,but when i tried to use xplorer 360 it says could not find fatx drive.I tried with 2 hot swap techincs,setting compatibility to win xp sp3,running it as administrator,tried different programs.But nothing works.I dont have xbox friendly usb drive and i also dont have any game that has save game exploits.Sorry for bad english.
    • By Dnoble2989
      Hi, I've managed to do all of the steps to install the unleashedx softmod via usb and splinter cell, the ftp settings, placing the snes9x X folder in the correct location, and getting the emulator to show up on the console.
       
      All i had left to do is simply hit the A button on any one one of the Roms to start them up, and yet nothing happens when i do that? The A button works fine for literally everything else except starting the Roms. I'm hoping it's because i have an off brand madcatz controller, and not an original xbox controller. Or maybe it's something more simple than that? Corrupted Roms maybe?
    • By 65c102
      Hi guys, I've just joined. Great forum
      I have an original xbox softmodded with unleashx
      I have found an issue when setting the clock to year 2020, after a reboot the clock goes back to 2006. Setting the clock to year 2019 works correctly
      Im guessing the problem is some form of bug with the 2 digit year value in the RTC
      Do you guys know if anyone has worked on a patch for this ?
       
      Thanks

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.