Jump to content

Recommended Posts

That's just an USB to Xbox port adapter, of course very necessary but it is far from the whole story.

Getting the original Xbox controller working on a PC is more than a bit of a faff mainly because of driver issues. The old XBCD (Xbox Controller Driver) was unsigned and so there were problems because of that and it only supported up WinXP. I think people had it working with Win7 but beyond that I do not know.

I gave up on it.




The second solution I've not tried but would be the way to go for Win10 users. I note from one of the link pages that Win7 users actually have to have the MS XB360 Accessories driver on their PC for it to work which is why I wouldn't bother with it either. You're better off using a genuine wired XB360/X360 For Windows controller which has specific MS driver support and apparently will actually download/install the driver directly.

BTW if you want to download the XB360 controller driver and install it manually it now appears to be impossible to do it via MS downloads. The links to the driver I had are all dead and searching the MS web site just sends you round the houses. So it looks as if you would need to use a third party web site/download instead.

Link to post
Share on other sites

You might be able to get it working by disabling driver signing in Win 10 but I agree a 360 controller is a much easier proposition.

I think this is the driver (win 7 32 and 64 bit available but may work on win 10):

https://www.microsoft.com/accessories/en-au/d/xbox-360-controller-for-windows or you could try xpadder https://xpadder.xyz/windows/

Personally I use a wired x360 controller which works perfectly on Win 10 x64

Edited by ShinGoutetsu
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Edge
      So I recently learned a valuable lesson about TSOP flashing when I flashed my 1.0 with iND-BiOS.Beta.Feb-11-05.67.bfm.bin rather than the non-BFM version of the bios. I was wondering what the practical purpose of the BFM (Boot from Media) bios is, and how one would even use it?
      I'm assuming it is a BIOS that something can load AFTER the Xbox as already booted and initialized all hardware?
    • By Chungaloid
      Hey all.  Sorry if this has been posted, but I searched and couldn't really find anything.  I have a 1.0 Xbox that was handed to me by a friend.  He said he couldn't remember much about it, but that him and his kid tried to mod it a long time ago, and now it isn't working.  Upon opening it, I found a pin header, no modchip, tsop points soldered, and the underside D0 pad ripped off.  When I try to start the xbox, it cycles power 3 times then frags out.  I'm assuming this is due mainly to the ripped D0 trace.  I've tried repairing the trace, and bridging the two pads connected by the green line, but I can't seem to get the solder to stick.  Is there any other way to repair this, or is this the only way?  Relatively new to xbox modding so any tips would be appreciated.  Thank you!  

    • By Skrumpkin
      I have a hard modded OpenXenium chip with a 1 TB WD Blue HDD.  I have everything set up and I am trying to get more than 200 GB - with more than  > 200 GB left on a partition.  Filezilla is not letting me do that.  I am just trying to transfer the titles.  They are all HDD ready for transfer but they do not go through at a certain point.  They  all become failed transfers.  The bios I am using is unleashed x from the OGXBOX installer.  It was not flashed by the program but was transferred by my network.  It is a CEE bios.   I switch dashboard sometimes.  The only one that I have on there that is not preinstalled is Emulation Station. I had used the DVDmulleter to get the bios necessary.  The HDD has been partitioned correctly having being split from F to G the remaining left.  I am fairly new to this and any advice to help would be beneficial.

Board Life Status

Board startup date: April 23, 2017 12:45:48
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.