Jump to content

Struggling with X3 re-install (possible dead chip?)


Recommended Posts

I've spent some time kicking around the forums, but appear to be running in circles, so hoping for an assist.

Last month I grounded out the power supply on my 1.1 while doing a 2TB SATA upgrade. The SATA/IDE board touched  the power supply as I was re-assempling the box (I left the power live like a bozo).

I purchased a new power supply to find that the board was dead (non-stop frag). Purchased a previously soft modded 1.0 box, removed and cleaned up the clock cap and was able to boot to UnleashX.

I'm now in day 4 of trying to install my old, previously fully functional, X3CE onto this new board.

  • de-soldered d0, LAN, HDD wire no problem
  • de-soldered pin header
  • cleaned up solder in 1.0 header
  • Installed old header back in 1.0
  • Connected everything up
  • LAN/HDD lights on X3CP work great
  • FRAG

I'm running out of ideas. So far I've tried:

  • Booting into flasbios via eject/power: FRAG
  • Booting to softmod using power long press: works
  • Re-soldering the pin header thrice
  • using a continuity tester to check each header pin against this post from livefast1989: all but pin 7 check out (i think the point may be wrong)
  • Tried booting into softmod and flashing w/ Hexen: Mfc ID 18 / Flash not writeable
  • Booted xblastOS from softmod: Sees X3 as the chip, wont write to it via HDD or LAN

I have loads of pictures of the install and all errors. Is there something I could be missing? Could I have nuked the chip when I murdered the power supply?

Is there a tool to rebuilt the factory state of the x3CE?

Link to post
Share on other sites

Yu could try this 

https://www.dropbox.com/sh/wpaq5gccv7f6d76/AACSuSj23bpeueBAV_stzGa6a?dl=0

ftp the file to your Xbox then with the X3 chip fitted and the D0 grounded run this file and it erases the X3 chip,You may then be able to then get to the main config screen and flash a new BIOS.

I would be surprised if it comes good as by the sound of it you sent 200+ volt though the board.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

  • Thanks 1
Link to post
Share on other sites

Thanks Dave. I'll give that a go.

I'm vaguely heartened by the fact that the LEDs on the chip all appear to be working right, and the power button logic seems to be operating as expected.

I'm hoping the power surge just wiped the entire thing, but definitely could be toasted. Would be super disappointing if so, but such is life.

Link to post
Share on other sites
11 hours ago, bolofski said:

have you checked the front panel switch positions to make sure you havent accidently moved any?

Yup. No problems there. It's connected to an X3 Control Panel, so the switch positions are super obvious.

I've tried every combination of switches I can think of.

Link to post
Share on other sites
5 hours ago, Supa said:

Yup. No problems there. It's connected to an X3 Control Panel, so the switch positions are super obvious.

I've tried every combination of switches I can think of.

Does the X3 logo backlight color look purple (mixed color of the red and blue lit LEDs) when you press power and eject when trying to boot into FlashBIOS?

 

What's up with the pin 7 signal?

Link to post
Share on other sites
Posted (edited)
3 hours ago, KaosEngineer said:

Does the X3 logo backlight color look purple (mixed color of the red and blue lit LEDs) when you press power and eject when trying to boot into FlashBIOS?

 

What's up with the pin 7 signal?

No purple, but you were spot on with pin 7. The diagram in the linked post was wrong as far as a test point, but I hunted the right one down via the LPC rebuild thread. It turns out there was a broken trace on the board. Legitimately no idea how that happened given that the board had not been modes before, but here we are.

Successfully back in business. Now I just need to figure out how to to install a x3CP with a 1.0 board. The controller port board is in the absolutely worst spot.

IMG_20210102_200914.jpg

Edited by Supa
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By empyreal96
      Newbie here! 
      So glad to see some kind of OG Xbox community still exists! I'm not the most social bean but I will try!
      Hopefully I can bring a new level to the community with my tool I am working on to help build Xbox OG source code super easy, called Easy-Build Xbox 😁
      EDIT: I am not sure on the rules yet of posting about and linking my tool, as the nature of it is source code, as long as there's no direct links on the forum is it okay? 
      But for now I'm saying hi and learning about the forum! 😅
    • By Naokhan
      hello,
      i received recently the xblast chip, was intended to use it mainly for ram upgrade but i have a xbox with tsop bad flash.
      so the xblast has ind bios on bank 512 and x2 on bank 256, i flashed via menu the bank 256 with c:\tsop_m7.bin, went ok.
      but when i load it from xblast os with a hexen dvd in drive, screen freeze at logo like no dvd was read...
      tested with samsung and thomson drive.
       
      what's going on ?
       
      thanks
    • By KylJoy
      My OG XBOX is a version 1.4 and has been TSOP modded and is running INDBIOS 5003 with F & G support.  I am using Rocky5's ISO BIOS patcher as the first thing that runs at bootup (DASH1 in IND0BIOS.CFG) to get ISO loading working and that is fine (I used to run UnleashX and needed it, not sure I still need it with XBMC4Gamers but assumed so since I'm using INDBIOS 5003).  I assembled the patcher.xbe (named it "XISO Loader.xbe") with it pointing to the dashloader.xbe at C:\DashLoader (renamed from C:\evoxdash.xbe) which, in turn, defaults to my XBMC4Gamers default.xbe at E:\XBMC4Gamers\ directory.  I edited the "A" .cfg that resides within the C:\dashloader directory to point to the Enigmah PAL/NTSC app in my E:\Apps\ directory in case I want to switch video modes.  All of that works great.  I can boot to XBMC4Gamers by default or hold "A" and get to the Enigmah video switcher to select PAL or NTSC.  Fantastic stuff!  But, now, I am trying to get the dashloader configurator GUI to work for configuring the dashloader button settings and I can't get it to work.  I installed the dashboard configurator from the URLDowloader within XBMC4Gamers into my E:\Apps\ directory and that seems to work fine as I am able to run the configurator which loads the settings from somewhere and will save settings somewhere BUT it does NOT really impact the A,B,X,Y, etc. .cfg files within the C:\cashloader\ directory.  What am I missing?
       
      Thanks in advance for any assistance.

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.