Jump to content
sh0rtlife

New Profile Caused an Error, Need Some Help

Recommended Posts

everything's been solid for some time now save for a couple of games that simply refuse to work and im ignoring them....., so my wife created a new profile to use instead of using mine so she could set faves and such...seemed like a good idea....but now, no profile works...so im stumped

"script error"script failed xbmc4gamers"

then it pops up a message on the bottom left of the screen

"error script is missing or taking to long to finish, please send me a copy of your xbmc.log file "

 

i assume the log file thats needed is the /E/xbmc/system..if so..its attached.

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

im trying my best to understand the log file, but it "looks" to me like the issue is

E:\xbmc\system\scripts\XBMC4Gamers\default.py"
if thats the case can i just copy it from another location and replace it?

Share this post


Link to post
Share on other sites

ok...im clearly in over my head and cant make heads or tales out of it,..ive got ZERO desire to re-do a full 2tb drive

 

someones gotta know something...here is a view of the log so it doesnt need to be d/l'd

Quote

3:44:04 M: 56459264  NOTICE: -----------------------------------------------------------------------
13:44:04 M: 56459264  NOTICE: Starting XBMC4Xbox 3.5.3-r33026 (SVN:33026, compiler 1310). Built on Mar 31 2020
13:44:04 M: 56459264  NOTICE: special://xbmc/ is mapped to: Q:\
13:44:04 M: 56459264  NOTICE: special://masterprofile/ is mapped to: Q:\system\UserData
13:44:04 M: 56459264  NOTICE: special://home/ is mapped to: Q:\
13:44:04 M: 56459264  NOTICE: special://root/ is mapped to: E:\xbmc
13:44:04 M: 56459264  NOTICE: special://urldownloader/ is mapped to: Q:\system\scripts\urldownloader\
13:44:04 M: 56459264  NOTICE: special://scripts/ is mapped to: Q:\system\scripts\
13:44:04 M: 56459264  NOTICE: special://temp/ is mapped to: Z:\
13:44:04 M: 56459264  NOTICE: The executable running is: E:\xbmc\default.xbe
13:44:04 M: 56459264  NOTICE: Log File is located: Q:\system\xbmc.log
13:44:04 M: 56459264  NOTICE: -----------------------------------------------------------------------
13:44:04 M: 56459264  NOTICE: Unmapped drive T
13:44:04 M: 56459264  NOTICE: Mapping drive T to Harddisk0\Partition1\xbmc\system\UserData\
13:44:04 M: 56459264  NOTICE: Setup DirectX
13:44:05 M: 56434688  NOTICE: Mapping drive C to Harddisk0\Partition2
13:44:05 M: 56434688  NOTICE: Mapping drive E to Harddisk0\Partition1
13:44:05 M: 56434688  NOTICE: Unmapped drive D
13:44:05 M: 56434688  NOTICE: Mapping drive D to Cdrom0
13:44:05 M: 56434688  NOTICE:   map extended drive F:
13:44:05 M: 56434688  NOTICE: Mapping drive F to Harddisk0\Partition6
13:44:08 M: 56430592  NOTICE:   map extended drive G:
13:44:08 M: 56430592  NOTICE: Mapping drive G to Harddisk0\Partition7
13:44:08 M: 56430592  NOTICE: Mapping drive X to Harddisk0\Partition3
13:44:08 M: 56430592  NOTICE: Mapping drive Y to Harddisk0\Partition4
13:44:08 M: 56430592  NOTICE: Unmapped drive Z
13:44:08 M: 56430592  NOTICE: Mapping drive Z to Harddisk0\Partition5
13:44:08 M: 56430592  NOTICE: load settings...
13:44:08 M: 56430592  NOTICE: Mapping drive P to Harddisk0\Partition1\xbmc\system\UserData\
13:44:08 M: 56430592  NOTICE: special://profile/ is mapped to: special://masterprofile/
13:44:08 M: 56430592  NOTICE: loading special://masterprofile/guisettings.xml
13:44:08 M: 56274944  NOTICE: Getting hardware information now...
13:44:08 M: 56274944  NOTICE: Checking resolution 10
13:44:08 M: 56274944  NOTICE: Setting autoresolution mode 1
13:44:08 M: 56274944  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
13:44:08 M: 56274944  NOTICE: Loaded playercorefactory configuration
13:44:08 M: 56254464  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
13:44:08 M: 56254464  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
13:44:08 M: 56254464  NOTICE: Loaded advancedsettings.xml from special://profile/advancedsettings.xml
13:44:08 M: 56254464  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <powersave>false</powersave>
                                              <nodvdrom>false</nodvdrom>
                                              <enableintro>false</enableintro>
                                              <splash>true</splash>
                                              <pictures>
                                                <screenshotpath>Q:\system\Screenshots\</screenshotpath>
                                              </pictures>
                                            </advancedsettings>
13:44:08 M: 56254464  NOTICE: Getting hardware information now...
13:44:08 M: 56254464  NOTICE: Checking resolution 10
13:44:08 M: 56254464  NOTICE: Setting autoresolution mode 1
13:44:08 M: 56254464  NOTICE: Default Video Player: dvdplayer
13:44:08 M: 56254464  NOTICE: Default Audio Player: paplayer
13:44:08 M: 56254464  NOTICE: Per AV pack settings are off
13:44:08 M: 56385536  NOTICE: special://masterprofile/sources.xml
13:44:08 M: 56111104   ERROR: Keymapping error: no such action '-' defined
13:44:08 M: 37482496   ERROR: CGUITextureManager::Load - Texture manager unable to load file: Q:\custom_splash.png
13:44:11 M: 45850624  NOTICE: Network: Using DHCP IP settings
13:44:11 M: 45535232  NOTICE: Not using idle thread with HLT (no power saving)
13:44:11 M: 45535232  NOTICE: Checking the Date!
13:44:11 M: 45535232  NOTICE: start dvd mediatype detection
13:44:11 M: 45469696  NOTICE: initializing playlistplayer
13:44:11 M: 45469696  NOTICE: DONE initializing playlistplayer
13:44:11 M: 45461504  NOTICE: load default skin:[Manage Profiles Skin]
13:44:13 M: 37924864  NOTICE: initialize done
13:44:13 M: 37924864  NOTICE: Running the application...
13:44:15 M: 29421568  NOTICE: -->Python Initialized<--
13:44:15 M: 28921856  NOTICE: start timeserver client
13:44:15 M: 28856320  NOTICE: XBFileZilla: Starting...
13:44:15 M: 30392320 WARNING: old getenv from python.lib called, library check needed
Previous line repeats 3 times.
13:44:16 M: 34770944 WARNING: XBFileZilla: Started
13:44:23 M: 31830016  NOTICE: -->Python Initialized<--
13:44:23 M: 31023104  NOTICE: | Scripts\XBMC4Gamers\default.py loaded.
13:44:43 M: 37175296 WARNING: CGUITextureManager::Cleanup: Having to cleanup texture windows\login\button_no_focus.png
13:44:43 M: 37179392 WARNING: CGUITextureManager::Cleanup: Having to cleanup texture unknown-user.png
13:44:43 M: 37249024 WARNING: CGUITextureManager::Cleanup: Having to cleanup texture windows\login\button_focus.png
13:44:57 M: 32591872  NOTICE: -->Python Initialized<--
13:44:57 M: 31772672  NOTICE: | Scripts\XBMC4Gamers\default.py loaded.
13:45:19 M: 36470784   ERROR: convert_checked failed
Previous line repeats 7 times.
13:45:28 M: 37597184   ERROR:   Local Source Drive F:
13:45:28 M: 37597184  NOTICE:   Local Source Drive G:
13:45:32 M: 36323328   ERROR: convert_checked failed
Previous line repeats 17 times.
13:47:13 M: 31358976   ERROR: -->Python Initialized<--
13:47:20 M: 31342592  NOTICE: -->Python Initialized<--
13:47:23 M: 31330304  NOTICE: -->Python Initialized<--
13:47:40 M: 36503552   ERROR: unable to load:Q:\skins\Manage Profiles Skin\720p\PlayerControls.xml, Line 0
                                            Failed to open file
13:47:54 M: 32616448  NOTICE: -->Python Initialized<--
13:47:54 M: 31780864  NOTICE: | Scripts\XBMC4Gamers\default.py loaded.
13:48:10 M: 36454400  NOTICE: stop fancontroller
13:48:10 M: 36454400  NOTICE: Unmapped drive P
13:48:10 M: 36454400  NOTICE: Mapping drive P to Harddisk0\Partition1\xbmc\system\UserData\profiles\User
13:48:10 M: 36454400  NOTICE: special://profile/ is mapped to: special://masterprofile/profiles/User
13:48:10 M: 36454400  NOTICE: loading special://profile/guisettings.xml
13:48:10 M: 36372480  NOTICE: Getting hardware information now...
13:48:10 M: 36372480  NOTICE: Checking resolution 10
13:48:10 M: 36372480  NOTICE: Setting autoresolution mode 1
13:48:10 M: 36372480  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
13:48:11 M: 36372480  NOTICE: Loaded playercorefactory configuration
13:48:11 M: 36352000  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
13:48:11 M: 36352000  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
13:48:11 M: 36352000  NOTICE: Loaded advancedsettings.xml from special://profile/advancedsettings.xml
13:48:11 M: 36352000  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <powersave>false</powersave>
                                              <nodvdrom>false</nodvdrom>
                                              <enableintro>false</enableintro>
                                              <splash>true</splash>
                                              <pictures>
                                                <screenshotpath>Q:\system\Screenshots\</screenshotpath>
                                              </pictures>
                                            </advancedsettings>
13:48:11 M: 36352000  NOTICE: Getting hardware information now...
13:48:11 M: 36352000  NOTICE: Checking resolution 10
13:48:11 M: 36352000  NOTICE: Setting autoresolution mode 1
13:48:11 M: 36352000  NOTICE: Default Video Player: dvdplayer
13:48:11 M: 36352000  NOTICE: Default Audio Player: paplayer
13:48:11 M: 36352000  NOTICE: Per AV pack settings are off
13:48:11 M: 36401152  NOTICE: special://masterprofile/profiles/User/sources.xml
13:48:11 M: 36433920   ERROR: Keymapping error: no such action '-' defined
13:48:12 M: 37691392   ERROR: Detection of DVD-ROM media failed.
13:48:12 M: 37691392  NOTICE: Network: Using DHCP IP settings
13:48:13 M: 32583680  NOTICE: -->Python Initialized<--
13:48:13 M: 31727616  NOTICE: | Scripts\XBMC4Gamers\default.py loaded.
13:48:13 M: 31649792  NOTICE: | UDATA folder present
13:48:13 M: 31559680  NOTICE: | Already removed XBMC save directory
13:48:14 M: 31506432  NOTICE: | UDATA backup created
13:48:14 M: 31727616   ERROR: Error Type: <type 'exceptions.OSError'>
13:48:14 M: 31744000   ERROR: Error Contents: (13, 'Permission denied')
13:48:14 M: 31731712   ERROR: Traceback (most recent call last):
                                              File "E:\xbmc\system\scripts\XBMC4Gamers\default.py", line 79, in <module>
                                                os.rename('E:/UDATA' , Previous_Profile_Save_Directory)
                                            OSError: (13, 'Permission denied')
13:48:14 M: 37199872  NOTICE: XBFileZilla: Starting...
13:53:11 M: 35512320   ERROR: unable to load:Q:\skins\Profile skin\720p\SlideShow.xml, Line 0
                                            Failed to open file

 

Share this post


Link to post
Share on other sites

Can you still load your profile?

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

Can you FTP to the Xbox?

Or are you able to use FATXplorer to access the HDD?

The info on F and G drives will still be intact and you maybe able to remove the new profile that was made by FTP or directly on a PC

The profiles are  located in  "profiles.xml" and thats in E:xbmc/system/UserData/

You can edit that with notepad.

I made a profile called remove me

Then as a test was able to remove it by editing the profiles.xml file and deleting the highlighted text

1482212682_xbmcprofiles.PNG.a2eb377c6af09a3953944fc6948a5374.PNG

If that doesn't work you can copy a new xbmc4gamers to E drive and then start again.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

 

Share this post


Link to post
Share on other sites

Just a thought - have you tried running XBPartitioner v1.3 and seeing if there is any ER (error) shown against the extended partitions? Its a 2TB HDD and my first thought when anyone has problems and they're using one is that it wasn't correctly formatted originally.

Would it not be a good idea just to check that, even if only to exclude that as a possible cause of the problem?  If it is nothing suggested here is going to be of any use.

Share this post


Link to post
Share on other sites

i can ftp in just fine, tryed that dave and it didnt fix it either but was worth a shot and it let me get rid of the extra BS accounts id made trying to bypass the issue

 

now heres the fun bit, so i was reading thru default.py to understand exactly the where/why of the problem, and ive not touched "code" since before the days of the internet..way before dialup was even a thing, so my understandings is rudimentary at best, and was something i learned on both a TI-994A as well as later a "lobo" home computer with 12inch floppys

anyway i noticed its pointing at an issue overwriting "udat" files or making new ones..not really sure but the "line 79" is udat stuff..so as an experiment i copied all the entire UDAT file to my pc then deleted it on the box, fired it up and problem gone..along with all my saves the problem was gone, ZERO issues everything functioning as it should....but my saves...so i ftp'ed back in again tossed all of the UDAT file in over top of what had newly been created and saves returned and issue still gone

 

so i fixed it, but i worry this isnt a permanent fix....and have no clue as to what "caused" the issue...so if anyones got some insight on what i did vs whats going on../..im all ears, but at the very least if it happens to someone else heres a quick fix that worked this time

 

Share this post


Link to post
Share on other sites

Good to see you have sorted it.

On all the setup's I use xbmc4gamers I set it to autoload the main and only profile, and the one I set up for a friends kids I locked it so they could not easily edit any settings.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

i was hoping i could get away with not locking it down just so i had unrestricted access to everything, but after this lil hicup im thinking i m just going to lock it down ...still curious as to what happened, the only thing i can think of is either a udat folder had a minor corruption or somehow managed to lose permissions, which would make more sense with the error it was spitting out

Share this post


Link to post
Share on other sites

It is hard to say why it became corrupt may be a power glitch

In the lock mode it limits it to selecting a user then what game or apps to play, where auto login loads a user as a default and then it's ready to select a game so everyone is on the one profile.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By enter name here
      hi all new here and new to thee xbox modding, i have a tosp modded og xbox i wont to check the heath of my drive as ive noiced sum saves are not loading i have a 500GB segate sata drive in it i wont to make sure the drive is ok and it's not just a curuped file ?
    • By Wingman
      Hello everyone, my name is Vitalij and I am from latvia ! 
      I have two xbox v1.1 and v1.6  in 1.1 dump of something (red-green light), but fully working power supply and 1.6 working, but the mosfet burned out in the power supply.
      Is it possible to make a 1.1 to 1.6 PSU, can there be a complete manual or something? I found a guide showing how to make from 1.1 to 1.2-1.5, but as I understand it, this does not work for me.
      Could you please help with this?
      Please login or register to see this code. Please login or register to see this attachment.
      Please login or register to see this attachment.
      Please login or register to see this attachment.
      Please login or register to see this attachment.
    • By Gerdo
      Picked up another xbox that was sold for parts and untested.  Noticed a switch hanging out of the bottom so took a chance.
      Please login or register to see this attachment.
      Please login or register to see this attachment.
      Xbox started up fine and booted up custom bios.
      Had to remove the motherboard to remove clock capacitor that has visibly failed.  Does not appear to be any damage to the traces (version 1.4 or 1.5).
      Will reinstall the chip after cleaning up the xbox to see what I have.
      Already downloaded the install instruction that were on another thread.
       

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.