Jump to content
Sign in to follow this  
Samuel

Getting Red and Green Dot Artifacts On All Games With My XBox

Recommended Posts

Hello,

I am currently getting red and green flickering artifacts on my screen with all games with my Xbox. Not sure what the problem is. I have tried multiple different AV cables, televisions, and games thinking thinking that might have been the problem. But, it seems there is some major graphical error wrong with my Xbox, and googling the problem has not been easy. Does anyone know if there is a fix

 

Thanks,

Sam

Edited by Samuel

Share this post


Link to post
Share on other sites

What version Xbox have you got and have you inspected the power filter caps next to the CPU heatsink?

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

I am quite new to the ogxbox game, but as for version I am not quite sure which one I have as to specifically check I think I need to crack it open which I have never done with this xbox. Date of MFG is 2003-06-16

SN: 4022445 32505

Product ID: 142 4022445 32505

Hopefully this is helpful information. Would you recommend me cracking my xbox to see the CPU heatsink?

Share this post


Link to post
Share on other sites

Been doing some research and figured out it could be the clock capacitors? Is that what you are talking about? Why would the clock capacitors affect the video quality of my xbox?

Share this post


Link to post
Share on other sites

Yes you really need to open it up and remove the clock capacitor even if it is not leaking as it will start to leak.

Please login or register to see this attachment.

The red arrow is pointing to the clock cap

The clock cap will mot cause the video problems but it can damage the circuit board.

The caps I am talking about are next to the power connector and CPU heatsink

Please login or register to see this attachment.

The red circled ones have failed and need to be replaced and the yellow ones look ok but I would replace all the ones in the green box.

To open the Xbox you will need a T20 torx and a T10 torx.

 

If you are not sure post a pic of the main board.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

 

 

Share this post


Link to post
Share on other sites

Ok I got my xbox cracked open, now I just need to replace the caps specified and just straight up remove the clock cap. Here is a pic of the inside of my xbox, looks like no serious damage has been done yet, but still not sure if this is going to fix my graphical issues in game. Also, what capacitors should I order?

Thanks for the help I will keep you posted when I get this step done.

0?ui=2&ik=05d4274f76&attid=0.1&permmsgid=msg-a:r-3011757655621331232&th=1726392895745abc&view=fimg&sz=s0-l75-ft&attbid=ANGjdJ-5ABPONYRukSsWCVPZ9i-iGoNhM9RFd8fqNSWZAZsYT9HVJwyx6_0pehCYGezIdpANOaEtm0RYS_SWP_LQ41DqSOtvT7rE-TKTlUZr6MtSe5HzezrSPqx0Buw&disp=emb&realattid=172639221b563e6a2601

 

Edited by Samuel

Share this post


Link to post
Share on other sites
51 minutes ago, Samuel said:

Ok I got my xbox cracked open, now I just need to replace the caps specified and just straight up remove the clock cap. Here is a pic of the inside of my xbox, looks like no serious damage has been done yet, but still not sure if this is going to fix my graphical issues in game. Also, what capacitors should I order?

Thanks for the help I will keep you posted when I get this step done.

0?ui=2&ik=05d4274f76&attid=0.1&permmsgid=msg-a:r-3011757655621331232&th=1726392895745abc&view=fimg&sz=s0-l75-ft&attbid=ANGjdJ-5ABPONYRukSsWCVPZ9i-iGoNhM9RFd8fqNSWZAZsYT9HVJwyx6_0pehCYGezIdpANOaEtm0RYS_SWP_LQ41DqSOtvT7rE-TKTlUZr6MtSe5HzezrSPqx0Buw&disp=emb&realattid=172639221b563e6a2601

 

If the cap is in the exact location as the one in the 1st pic you just remove it.

I can not see the image you posted 

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

Hi Sam

That is a very clean version 1.2-1.3 main board.

You need to remove the clock cap it the one in the red circle. You can replace it but it's not really needed.

The caps in the yellow circle need to be replaced, I can see the top of the cap's are starting to bulge  and have reached the end of their life.

 

Please login or register to see this attachment.

 

If you want to b pass the 4 post per day limit have a look in the store tab as for the cost of a cup of coffee in a cafe it removes some of the limits.

 

 

Share this post


Link to post
Share on other sites

Here is the update and I did everything you specified. I removed the clock capacitor and replaced the three bulging caps. Sadly I am still getting red and green dots on my screen. I have no idea where it is coming from. Here are update pics of my Xbox. 

Please login or register to see this attachment.

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

Are the AV lead genuine or aftermarket and composite (yellow and red/white) or component (red,green,blue and a red/white)?

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

What do you mean by AV lead? Is that the AV Cable? And as for cables I have 2 aftermarket cables one a cheap component and the other a s-video. I have recently ordered a nice psyclone component cable that should be here by Saturday, because I still think it could possibly be the cable. I wish I had a OEM cable to truly test it on or a second working xbox to truly prove if it is the cable. What other possibilities do you think it could be other than the cable?

 

Thanks,

Sam

Edited by Samuel

Share this post


Link to post
Share on other sites

The no name AV leads are junk I think the cable you have ordered should fix the problem.

The work you have done on the Xbox was not wasted as the clock cap can cause damage and I see heaps of caps like the ones near the heatsink that have failed.

 

Post back with your results when the new lead arrives ..

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

I hope you are right about the new cable coming in is going to fix my problem. I have tested it with 3 cables. 2 no names and a mad catz. All giving me the same artifacts.

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

The 2 on the left are real cheap and I have not had any experience with the madcatz brand.

Is your Xbox Pal or NTSC?

 

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

After further investigation of the problem, I really don't think it is the AV cables. Here are pictures of the artifacts coming up on my screen. They are as if it is in the game itself which is bringing me to the fact that it might be the CPU. If it was the cables the artifacts would look more like an overlay that is happening on the front of the screen, but these artifacts are in game. Here are the pics of my screen with two different games playing. I really don't want to replace the motherboard which is pretty much just replacing the xbox, but it is looking like that is the only way of fixing it.

Please login or register to see this link.

Please login or register to see this link.

Share this post


Link to post
Share on other sites

The pics you posted look like a poor video signal I would like to see the same shots with the lead you have orded.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Share this post


Link to post
Share on other sites

Those are big dots.  I was expecting simple pixels speckled all over the screen.  Looks like problems with the TV''s backlight regions/zones. 

Are there settings to adjust such on the TV?

Do you have another TV to try? 

You may have already said.

Share this post


Link to post
Share on other sites

To prove it’s not the tv. I have plugged in my Xbox to an LED display and it is still showing all the graphical errors as it does on my plasma. I really do think something is wrong with the CPU. If it was a cable or tv issue I think it would look more like an overlay with the dots. The dots/artifacts. It’s as if the dots are on the texture of the game itself... Really interesting to look at and the mystery continues. 
 

thank you all for the support you are giving me and I know we will root this problem out  

 

Thanks

 

Please login or register to see this attachment.

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

Got some good news and bad news. Bad news is I got the wrong component cable from ebay, so going to get a return on that shortly. Good news is I got a Original Xbox, OEM Compoenent Cable, and a Duke Controller all for around $75 on Ebay and it should be here sometime next week. Really lucked out on that score. Now with a system that is advertised as working now we can really trouble shoot my xbox and figure out what the problem is.

 

Thanks,

Sam

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By sh0rtlife
      so im working with an old 2.6 modded OG xbox, this one has some very good history and means alot to me, and was given to me by the owner of "gamer transit authority", initially we thought this wasnt the "gamer bus unit" but after cracking it open and checking some things ..IT IS!!!

      anyway im trying to breath life back into the unit it has some startup issues that ive seemingly mostly resolved, im trying to clone and backup the drive so i can toss a 2tb unit in and be done for life with it

      so heres the issue..im getting "bad block sector on hda(master) from logical block 316 though 338 on drive E:

      everything else clones over just fine, and i get a error 13 on bootup
      yes im on the 80 wire
      yes ive tryed multiple drives both IDE and sata
      yes ive googled for weeks

      my best guess is that due to the logical block issues pointing at a corruption of the original drive that i need to "replace" some of E:drives contents, what im looking for is any information on how to do that WITHOUT wiping out the history thats in this box, id like to just "patch" what i can....im just not sure of the best way to do it....im leaning tward FTP cloning out E drive if thats even possible since the new drive wont boot...
       
      looking for any help possible, even if it means building the new drive from scratch...tho i consider that a "last resort"
       
    • By nin1
      Hi,
      I just downloaded GTA San Andreas to Xbox and ftped it over to the xbox.
      When playing it the hd makes noise all the time? No problems in the game but it is usual with so much sound?
      I tried Call of Duty on the Xbox and it does not make any noise when playing.
    • By OtakuAnthony
      Hello to everyone on the forums.  Still somewhat new to the Xbox modding scene as I only started modding my consoles two years ago but I looking forwarding to learning more about modding the OG Xbox.

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.