Jump to content

Need Help With CXBX


Recommended Posts

So, basically, I have a .xbe for Brute Force, but every time I try to run it, I get the error message "Unable to determine default Xbox backbuffer." What does it mean?

Edit: Fixed, but I'm getting a new error saying "IDirect3D::CreateDevice failed"

Edit 2: I've decided it's not worth the trouble. Sorry for bothering you all.

Edited by Volcanic163
Apology.
Link to post
Share on other sites

The Intel graphics chip is not much of a Graphics Processing Unit (GPU), more like a simple frame buffer driver chip, when compared to a higher-end nVidia GeForce GPUs.

Quote

 

Gabriel Mchedlidze posted in a Quora forum:

...Intel HD graphics chips are mostly in office computers and laptops. They are not good in gaming and/or rendering. ...

I suspect a higher-end GPU  with dedicated memory is required to run CXBX-Reloaded well.  Check the system specifications recommended to run CXBX-Reloaded.  Update: Brute Force may not be compatible/supported yet!

From https://github.com/Cxbx-Reloaded/Cxbx-Reloaded:

Minimum

  • OS: Windows 7+ x64. 32-bit installations are not supported.
  • GPU: Anything that supports Direct3D 9 (HLE) and OpenGL 3.3 (LLE).

Check that the Intel HD 3000 supports the two graphics API requirements - Direct3D 9 or higher and OpenGL 3.3 or higher.

For Direct3D run DirectX Diagnostics program - Windows Key+R, in the pop-up run window in the Open box key-in dxdiag then click OK.

For OpenGL, you'll need to install a 3rd party application - OpenGL Extensions Viewer from realtech-vr.com and run it.

Link to post
Share on other sites

From what I read on the compatibility list section at github.com for Cxbx-Reloaded, Brute Force is not supported yet.

Not even really listed as a compatible game but one that has issues.

Other's have had it run further than you. However, it does not even get to a menu to be able to play it. 

https://github.com/Cxbx-Reloaded/game-compatibility/search?q=brute+force&type=Issues

Update: Other games are reported to have the same issue: IDirect3D::CreateDevice Failed

Conclusion

Cxbx-Reloaded is not ready to run Xbox games.  A few work but not every one.

 

Link to post
Share on other sites
  • 7 months later...

I read it, and Volcanic had my same problem.  But immediately afterwards he writes that he has fixed it but not the procedure he has carried out.  And then he continues with another error message, which, however, does not concern me at the moment.

Link to post
Share on other sites
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By hands_groober
      Hi again
      Following up on my previous post about mt ram upgrade. Ive ran into another issue.
      I have installed a 1tb HDD. Prior to upgrading my ram I had already formated the with F partition taking 120gb and G partition taking the rest of the space. I have filled F partition with xbox games which has taken quite some time. Ive now realised that IND-BIOS 5003.67 will not read G partition.
      M8 bios will read the G partition but then i wont be able to take advantage of my extra ram. From what Ive read it is to do with how my G patition table is written. If this is the issue, is there any way I re-write the partition table without disturbing the data?
       

    • By rando
      Hi.
      When I try to boot into the dashboard the screen hangs on the xbox logo for a while and then displays the 07 error code 1 out 10 times/tries. Once I'm able to load the dashboard there are no problems. This problem has gotten worse over time and I am wondering if this points to a HDD problem. But the fact that once it has booted properly I can use it for hours with no issues or HDD failures which has me wondering if there are other issues here. The DVD searching sounds are pretty loud when I boot up the xbox.
      I seem to have an Aladdin XT 4032 modchip and a 1.4 or 1.5 xbox with a Focus video encoder chip.

      Any ideas?
      Help appreciated,
      S

       

    • By sgtsaughter
      Hey everyone, I'm having a problem with an original xbox that will turn on, with a solid green light for a second, then turn itself off.  Then back on with an orange blinking light, then turn itself off and on again until finally staying on with a blinking orange light with it's fan running what I think is full power (haven't confirmed this).  I can open the disc tray when in this state, but I can't power the xbox off unless I unplug the power from the back. 
      I opened up the xbox.  I believe it's a v1.2 motherboard. It was in pretty good condition I thought considering the original owner said it sat in a closet for the past decade or so.  This xbox was not modded.  
      I read that an orange blinking light could mean the xbox was overheating, which would explain the high fan speed.  So I removed the old thermal paste, and added new thermal paste, put it back together, plugged it in, and the same issue is happening.  I have tried a brand new A/V cable and power cord that I bought on amazon and that didn't seem to make a difference. 
      Does anyone know what an orange blinking light and this sequence of powering on and off mean? I can't find good documentation on it anywhere.  I'm also looking to try anything else at this point if you have any recommendations.  
      Here is a link to a video of the symptoms described above and some pictures of the montherboard.  Thanks for any help in advance!
      https://imgur.com/a/7hMZWFn?

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.