Jump to content
OGXbox.com

XBMC & Iso Issue


Shxlx006
 Share

Recommended Posts

19 hours ago, Shxlx006 said:

i did use dvd2xbox and it still gave me the same results “script failed start med..” i could confirm if i’m using a soft mod or a hard mod but i’m not sure how, as i said earlier i brought this modded xbox. so i’m not sure how i could possibly tell, 

Change XBMC4Xbox's skin.  From the log files,  I see errors occur when the skin starts up.  It's trying to access an RSS feed that is no longer accessible.

...
19:51:38 M: 46243840   ERROR: invalid rss url set referenced in skin
19:51:40 M: 45592576   ERROR: XFILE::CDirectory::GetDirectory - Error getting Q:\skin\HDeeTV\colors
19:51:48 M: 45654016   ERROR: invalid rss url set referenced in skin
19:51:57 M: 37330944   ERROR: XFILE::CDirectory::GetDirectory - Error getting E:\User\Weather\
Previous line repeats 1 times.
19:52:11 M: 44380160   ERROR: invalid rss url set referenced in skin

And there's a script running medusa that's not working

...
02:55:49 M: 50032640  NOTICE: load default skin:[HDeeTV]
02:55:50 M: 46600192  NOTICE: initialize done
02:55:51 M: 46579712  NOTICE: Running the application...
02:55:56 M: 41148416  NOTICE: -->Python Initialized<--
02:55:58 M: 33718272  NOTICE: -->Python Initialized<--
02:55:59 M: 31334400   ERROR: Error Type: <type 'exceptions.ImportError'>
02:55:59 M: 31354880   ERROR: Error Contents: No module named regsub
02:55:59 M: 31354880   ERROR: Traceback (most recent call last):
                                              File "q:\scripts\medusa\start_medusa.py", line 18, in <module>
                                                import ftp_server
                                              File "q:\scripts\medusa\ftp_server.py", line 26, in <module>
                                                import regsub
                                            ImportError: No module named regsub
02:56:45 M: 39321600 WARNING: CNetwork::CheckNetwork - Network error. Trying re-setup
02:56:45 M: 39321600  NOTICE: Network: Using DHCP IP settings
02:56:46 M: 39006208  NOTICE: XBFileZilla: Starting...
02:56:46 M: 38940672  NOTICE: ES: Starting event server
02:56:46 M: 38400000  NOTICE: ES: Starting UDP Event server on 0.0.0.0:9777
02:56:46 M: 37777408  NOTICE: UDP: Listening on port 9777
02:56:46 M: 32350208  NOTICE: XBFileZilla: Started
02:56:50 M: 36712448   ERROR: WEATHER: Unable to get data - invalid XML

 

Link to comment
Share on other sites

2 hours ago, KaosEngineer said:

Hmm, XBMC4Xbox can also run scripts on startup.

See Running Scripts from within XBMC

Make sure there's no autoexec.py file trying to run the medusa script.  FTP to the Xbox and look in Q:\scripts\ for it.

ok i changed the skin. but it still says script failed start_medusa.py thats what its been saying this entire time. and i didnt see any autoexec.py

Edited by Shxlx006
Link to comment
Share on other sites

9 hours ago, Shxlx006 said:

how do i fix the medusa thats not working?

I really need to see an entire directory listing of your XBMC4Xbox installation folder's content - all files in all subfolders. Edit: Forget that, use Filezilla's file search feature to look for an autoexec.py file on the Xbox hard drive:

  • Server > Search Remote Files 
  • Remote Search radio button, fill in the path to search and the file to look for

Old info from here to the end of this post, forget this for now:

I know long and not so easy to obtain.

However, lets first start with Q:\scripts.

Link to comment
Share on other sites

8 hours ago, Shxlx006 said:

ok i changed the skin. but it still says script failed start_medusa.py thats what its been saying this entire time. and i didnt see any autoexec.py

Hmm, I'm not sure what is tryiing to run the medusa script on start up of XBMC4Xbox.

I thought it may be something in the HDeeTV skin; however, now that you've changed the skin and it still does so.  There must be some autoexec.py somewhere in your installation.  The documentation for XBMC4Xbox mentions Q:\scripts\autoexec.py but you don't see such a file.  

Some file somewhere is trying to run it.  More research required...bbl

 

Link to comment
Share on other sites

8 hours ago, KaosEngineer said:

Look in P:\scripts for an autoexec.py file.  Is there one there?

i removed it from the Q folder. now whenever i try to boot the def jam fight for ny game it says Script failed : RECENTLYADDED.PY And now my console itself is starting to freeze a bit, not that much though

Edited by Shxlx006
Link to comment
Share on other sites

1 hour ago, Shxlx006 said:

You pick all these old skins to use.  XBMC's Weather plugin no longer works and Alaska tries to run a script, RecentlyAdded.py, on startup that crashes.  XMBC runs out of memory.

Try to use the latest supported ones - Confluence, Confluence Lite, PM3.HD or Project Mayhem III.

16:01:15 M: 49688576  NOTICE: load default skin:[Alaska]
16:01:18 M: 28307456   ERROR: Error evaluating boolean expression [System.CanPowerdown] + [!Skin.HasSetting(hideshutdown)]
16:01:18 M: 28286976   ERROR: Error evaluating boolean expression [System.CanReboot] + [!Skin.HasSetting(hidereset)]
16:01:18 M: 28286976   ERROR: Error evaluating boolean expression [System.CanSuspend] + [!Skin.HasSetting(hidesuspend)]
16:01:18 M: 28282880   ERROR: Error evaluating boolean expression [System.CanHibernate] + [!Skin.HasSetting(hidehibernate)]
16:01:19 M: 24903680  NOTICE: initialize done
16:01:19 M: 24903680  NOTICE: Running the application...
16:01:20 M: 23674880  NOTICE: XBFileZilla: Starting...
16:01:20 M: 23609344  NOTICE: ES: Starting event server
16:01:20 M: 22999040  NOTICE: ES: Starting UDP Event server on 0.0.0.0:9777
16:01:20 M: 22962176  NOTICE: UDP: Listening on port 9777
16:01:20 M: 22093824  NOTICE: XBFileZilla: Started
16:01:22 M: 22093824   ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
16:01:22 M: 22093824   ERROR: CCurlFile::CReadState::Connect, didn't get any data from stream.
16:02:07 M: 12423168  NOTICE: -->Python Initialized<--
16:02:09 M:   192512   ERROR: Out of memory loading texture: backdrops\weather.jpg (need 921728 bytes, have 192512 bytes)
16:02:09 M:    73728   ERROR: Texture manager unable to load bundled file: backdrops/weather.jpg
16:02:09 M:    73728   ERROR: Out of memory loading texture: backdrops\weather.jpg (need 921728 bytes, have 73728 bytes)
16:02:09 M:    73728   ERROR: Texture manager unable to load bundled file: backdrops/weather.jpg
16:02:09 M:     8192   ERROR: Out of memory loading texture: backdrops\settings.jpg (need 641536 bytes, have 8192 bytes)
16:02:09 M:     8192   ERROR: Texture manager unable to load bundled file: backdrops/settings.jpg
16:02:09 M:     8192  SEVERE: DLL: Q:\system\python\python27.dll : malloc failed, crash imminent (Out of memory requesting 8208 bytes)
16:02:09 M:   118784   ERROR: Error Type: <type 'exceptions.MemoryError'>
16:02:09 M:   131072   ERROR: Error Contents:
16:02:09 M:   131072   ERROR: Traceback (most recent call last):
                                              File "Q:\skin\Alaska\scripts\RecentlyAdded.py", line 3, in <module>
                                                from urllib import quote_plus, unquote_plus
                                              File "Q:\system\python\python27.zlib\urllib.py", line 30, in <module>
                                            MemoryError
16:02:09 M:   655360   ERROR: Control 402 in window 10107 has been asked to focus, but it can't
16:02:15 M: 12464128   ERROR: WEATHER: Unable to get data - invalid XML
Link to comment
Share on other sites

1 hour ago, KaosEngineer said:

You pick all these old skins to use.  XBMC's Weather plugin no longer works and Alaska tries to run a script, RecentlyAdded.py, on startup that crashes.  XMBC runs out of memory.

Try to use the latest supported ones - Confluence, Confluence Lite, PM3.HD or Project Mayhem III.

16:01:15 M: 49688576  NOTICE: load default skin:[Alaska]
16:01:18 M: 28307456   ERROR: Error evaluating boolean expression [System.CanPowerdown] + [!Skin.HasSetting(hideshutdown)]
16:01:18 M: 28286976   ERROR: Error evaluating boolean expression [System.CanReboot] + [!Skin.HasSetting(hidereset)]
16:01:18 M: 28286976   ERROR: Error evaluating boolean expression [System.CanSuspend] + [!Skin.HasSetting(hidesuspend)]
16:01:18 M: 28282880   ERROR: Error evaluating boolean expression [System.CanHibernate] + [!Skin.HasSetting(hidehibernate)]
16:01:19 M: 24903680  NOTICE: initialize done
16:01:19 M: 24903680  NOTICE: Running the application...
16:01:20 M: 23674880  NOTICE: XBFileZilla: Starting...
16:01:20 M: 23609344  NOTICE: ES: Starting event server
16:01:20 M: 22999040  NOTICE: ES: Starting UDP Event server on 0.0.0.0:9777
16:01:20 M: 22962176  NOTICE: UDP: Listening on port 9777
16:01:20 M: 22093824  NOTICE: XBFileZilla: Started
16:01:22 M: 22093824   ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
16:01:22 M: 22093824   ERROR: CCurlFile::CReadState::Connect, didn't get any data from stream.
16:02:07 M: 12423168  NOTICE: -->Python Initialized<--
16:02:09 M:   192512   ERROR: Out of memory loading texture: backdrops\weather.jpg (need 921728 bytes, have 192512 bytes)
16:02:09 M:    73728   ERROR: Texture manager unable to load bundled file: backdrops/weather.jpg
16:02:09 M:    73728   ERROR: Out of memory loading texture: backdrops\weather.jpg (need 921728 bytes, have 73728 bytes)
16:02:09 M:    73728   ERROR: Texture manager unable to load bundled file: backdrops/weather.jpg
16:02:09 M:     8192   ERROR: Out of memory loading texture: backdrops\settings.jpg (need 641536 bytes, have 8192 bytes)
16:02:09 M:     8192   ERROR: Texture manager unable to load bundled file: backdrops/settings.jpg
16:02:09 M:     8192  SEVERE: DLL: Q:\system\python\python27.dll : malloc failed, crash imminent (Out of memory requesting 8208 bytes)
16:02:09 M:   118784   ERROR: Error Type: <type 'exceptions.MemoryError'>
16:02:09 M:   131072   ERROR: Error Contents:
16:02:09 M:   131072   ERROR: Traceback (most recent call last):
                                              File "Q:\skin\Alaska\scripts\RecentlyAdded.py", line 3, in <module>
                                                from urllib import quote_plus, unquote_plus
                                              File "Q:\system\python\python27.zlib\urllib.py", line 30, in <module>
                                            MemoryError
16:02:09 M:   655360   ERROR: Control 402 in window 10107 has been asked to focus, but it can't
16:02:15 M: 12464128   ERROR: WEATHER: Unable to get data - invalid XML

ok i changed the skin to confluence but its still not letting me boot the def jam fight for ny game

Link to comment
Share on other sites

There's something weird with the Def Jam FFNY files - as said both the HDD Ready ones work from DVD-RW discs on my primary Xbox (chipped) but DVD2Xbox just won't install them from the same discs. 

FTPing in a HDD Ready version and it works fine.

But I've just been testing DVD-R discs (XISOs created from those same HDD Ready files) with two softmods and the same chipped machine.

None of them worked!

I was suspicious of the DVD-R batch I was using (Maxell); the first disc gave a verification error with ImgBurn. Only time I've had that is with a bad batch.

But I tested two other disc from the batch with a XISO of Xbox game: Black (small size so ideal for a quick burn) and they booted fine on all three Xboxes I'm testing. The bad disc must have been a rogue.

I've also proved to my own satisfaction its not the burners (two different lightly used ones tested) or ImgBurn.  

Wasted five or six discs doing this but all the Def Jam FFNY DVD-Rs using the same XISO that works using DVD-RW on my chipped Xbox's Hitachi disc drive do much the same thing on all three machines (the two softmods use Samsung B and Philips).

They take an unusually long time to be recognised and that sometimes fails. But when they are and can be launched (both XBMC and UX  dashes tested) they immediately stick at the Def Jam FFNY loading screen and eventually give a dirty disc error.

I've never had any DVD-R burn fail to boot except when there was a disc media fault. I just can't explain why DVD-RW burns work from disc on my Hitachi disc drive but you can't install them using DVD2Xbox. It just doesn't make any sense.

With that and the other testing evidence I'd say don't try to install or play this game from burned disc. FTP it in only.

I'd also suggest that if Shxlx006 use DVD2Xbox at any point he uses a file manager and finds the DVD2Xbox UDATA/TDATA save entries there and deletes them. Delete E:\CACHE too and any temporary game content on X, Y and Z. I'd also remove any Def Jam FFNY game install that has been made and start again cleanly by FTPing in a HDD Ready version.

DVD2Xbox UDATA/TDATA ID is 0facfac0 but check that just to be sure they are the correct folders. The TDATA one should  contain metai.d2x and a settings.d2x files. If you're not using the default skin doing this will revert it to default but otherwise there's no problem. Both DVD2Xbox's default UDATA and TDATA folders will regenerate on next boot.     

Edited by HDShadow
  • Thanks 1
Link to comment
Share on other sites

15 hours ago, KaosEngineer said:

I'm at a loss as to why this game does not work on your console.  I had no problems running it.  

I'll have to sleep on it for a few days. Maybe I'll think of something else to try.

 

19 hours ago, HDShadow said:

There's something weird with the Def Jam FFNY files - as said both the HDD Ready ones work from DVD-RW discs on my primary Xbox (chipped) but DVD2Xbox just won't install them from the same discs. 

FTPing in a HDD Ready version and it works fine.

But I've just been testing DVD-R discs (XISOs created from those same HDD Ready files) with two softmods and the same chipped machine.

None of them worked!

I was suspicious of the DVD-R batch I was using (Maxell); the first disc gave a verification error with ImgBurn. Only time I've had that is with a bad batch.

But I tested two other disc from the batch with a XISO of Xbox game: Black (small size so ideal for a quick burn) and they booted fine on all three Xboxes I'm testing. The bad disc must have been a rogue.

I've also proved to my own satisfaction its not the burners (two different lightly used ones tested) or ImgBurn.  

Wasted five or six discs doing this but all the Def Jam FFNY DVD-Rs using the same XISO that works using DVD-RW on my chipped Xbox's Hitachi disc drive do much the same thing on all three machines (the two softmods use Samsung B and Philips).

They take an unusually long time to be recognised and that sometimes fails. But when they are and can be launched (both XBMC and UX  dashes tested) they immediately stick at the Def Jam FFNY loading screen and eventually give a dirty disc error.

I've never had any DVD-R burn fail to boot except when there was a disc media fault. I just can't explain why DVD-RW burns work from disc on my Hitachi disc drive but you can't install them using DVD2Xbox. It just doesn't make any sense.

With that and the other testing evidence I'd say don't try to install or play this game from burned disc. FTP it in only.

I'd also suggest that if Shxlx006 use DVD2Xbox at any point he uses a file manager and finds the DVD2Xbox UDATA/TDATA save entries there and deletes them. Delete E:\CACHE too and any temporary game content on X, Y and Z. I'd also remove any Def Jam FFNY game install that has been made and start again cleanly by FTPing in a HDD Ready version.

DVD2Xbox UDATA/TDATA ID is 0facfac0 but check that just to be sure they are the correct folders. The TDATA one should  contain metai.d2x and a settings.d2x files. If you're not using the default skin doing this will revert it to default but otherwise there's no problem. Both DVD2Xbox's default UDATA and TDATA folders will regenerate on next boot.     

yeah ill try that out and let u know how it goes

  • Like 1
Link to comment
Share on other sites

Please do because I'm out of ideas too.

All I can confirm is that the HDD Ready versions (both) that you can find at the same archive work fine if you FTP it to the Xbox rather than use a disc based installation via DVD2Xbox.

There's so much odd behaviour I've had with this game from disc - I've now managed to install the XISO disc created from the Redump files via DVD2Xbox using the same DVD-RW XISO disc that didn't work last Friday.

As said the DVD-R disc I made from the same XISO refused to boot on any of the three Xboxes I tested. Likewise those made from the HDD Ready files. Even the Black test burn I did refuses to boot properly now on any of those three Xboxes.

I'm thinking the confusing results are due to a bad Maxell DVD-R disc batch issue. I was hoping they were different manufacturers but no they're the same as other Maxwell discs I've burned that work without any problems: CMC MAG AM3.

Both burners would have to have been malfunctioning for it to be anything to do with that, highly unlikely as both have only had light use anyway.

In short I have no idea what the problem(s) have been with this game and in such circumstances all you can advise is to use the install method that you know does work: FTP.

Link to comment
Share on other sites

On 11/28/2021 at 10:50 AM, HDShadow said:

There's something weird with the Def Jam FFNY files - as said both the HDD Ready ones work from DVD-RW discs on my primary Xbox (chipped) but DVD2Xbox just won't install them from the same discs. 

FTPing in a HDD Ready version and it works fine.

But I've just been testing DVD-R discs (XISOs created from those same HDD Ready files) with two softmods and the same chipped machine.

None of them worked!

I was suspicious of the DVD-R batch I was using (Maxell); the first disc gave a verification error with ImgBurn. Only time I've had that is with a bad batch.

But I tested two other disc from the batch with a XISO of Xbox game: Black (small size so ideal for a quick burn) and they booted fine on all three Xboxes I'm testing. The bad disc must have been a rogue.

I've also proved to my own satisfaction its not the burners (two different lightly used ones tested) or ImgBurn.  

Wasted five or six discs doing this but all the Def Jam FFNY DVD-Rs using the same XISO that works using DVD-RW on my chipped Xbox's Hitachi disc drive do much the same thing on all three machines (the two softmods use Samsung B and Philips).

They take an unusually long time to be recognised and that sometimes fails. But when they are and can be launched (both XBMC and UX  dashes tested) they immediately stick at the Def Jam FFNY loading screen and eventually give a dirty disc error.

I've never had any DVD-R burn fail to boot except when there was a disc media fault. I just can't explain why DVD-RW burns work from disc on my Hitachi disc drive but you can't install them using DVD2Xbox. It just doesn't make any sense.

With that and the other testing evidence I'd say don't try to install or play this game from burned disc. FTP it in only.

I'd also suggest that if Shxlx006 use DVD2Xbox at any point he uses a file manager and finds the DVD2Xbox UDATA/TDATA save entries there and deletes them. Delete E:\CACHE too and any temporary game content on X, Y and Z. I'd also remove any Def Jam FFNY game install that has been made and start again cleanly by FTPing in a HDD Ready version.

DVD2Xbox UDATA/TDATA ID is 0facfac0 but check that just to be sure they are the correct folders. The TDATA one should  contain metai.d2x and a settings.d2x files. If you're not using the default skin doing this will revert it to default but otherwise there's no problem. Both DVD2Xbox's default UDATA and TDATA folders will regenerate on next boot.     

yeah i ftp'd the game to my xbox its still taking me back to the modded xbox homepage but no errors is showing up 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By MadMartigan
      I made a post a few weeks back about getting a 1.6 with a HDD that immediately died after booting. Couldn’t get eeprom in time. Looks like someone was trying to tinker around and really screwed some things up. Without the wires and chip, the Xbox will boot into HDD failure error which I’m fully aware of. I tried getting two Aladdin chips fitted and neither one of them will boot. They both flash green light for a second and then power off. One chip shows red light and the other shows yellow. I’ve reflowed solder points countless times and still the same result. I’ve tried D0 grounded to board and the chip and other various places I’ve seen and read about, but nothing works. As you can see from the board, there have been several trace lifts, but from what I’ve seen I have everything linked up properly accordingly to the lifted traces. Any help would be greatly appreciated. 
       
      I do not want to keep the chip inside so I have not cut the L-Frame. I just want to pull the eeprom and build a replacement drive. These Aladdin chips on 1.6 are proving to be a real pain in the ass. 


    • By TheSegaHolic
      Hi folks,
      A friend pointed me in your direction, and I hope you can shed some light of this issue.
      I picked up an immaculate Xbox today, boxed, sealed manual, still had the plastic over the eject and power buttons, not a mark on the case
      I played some OutRun2 and Dead or Alive 3, no issues. I then decided to “stress test” and run a game for half an hour, and chose Halo 2, letting it sit in its promo/demo loop.
      After around 35 mins, the game froze. I ejected the disc, returned to the dash, and reloaded the disc … nothing.
      The green light around eject just flashes, but there’s no action from the drive other than 3 whirs then nothing.
      Tonight I took the console apart, and it’s immaculate inside. No leaks, no dust, no bulging caps, not even a spec of dust on the fan … I doubt this console has seen much use, which is what makes this issue even harder to understand.
      When I had the lid off the drive, I tried to load a game, OutRun2 … but the behaviour is the same for any disc.
      The lens moves to the top of the track and back 3 times, and each time it returns to its “home” position next to the disc spindle, the spindle tries to turn and moves, if it’s lucky, a centimetre or two. It does this 3 times, then nothing.
      I don’t get any disc read errors, because the disc doesn’t seem to spin up. The drive, like the rest of the system, is very clean but it just stopped working so suddenly.
      Any and all advice will be greatly appreciated. I don’t want to return this to CEX for them to scrap it, especially given it’s condition, so I want to try and save it. If the drive is toast, as I suspect it may well be, what are my options in terms of modding without a working disc drive?
      Thanks all.
      Edit: I have uploaded a video of the drive in action, here:
       


    • By stroggaxis
      Hello,
      Been out of the xbox modding game for a while. Was checking out some posts here and there and I see people mentioning xiso files. I understand ISO and HDD ready games. But what exactly is xiso and is there any noticeable difference between that and iso games? Really all I want to do is transfer some of my backups via FTP to my modded console's HDD. Since the xiso files are much smaller, it seems to me that they might be the DVD rips of games without all the extra 'fluff' of making a 1-1 DVD image of a game. Would that be correct?

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.