Jump to content

Recommended Posts

Custom Red LED controller Ports with matching Red LED Power/Eject Board. Comes with lifetime warranty. If one ever fails I will replace it for free minus the shipping cost. These are very bright and match 100% although the picture kinda takes away from how deep red these really are.

$24.99 Shipped anywhere in the lower 48. Can ship worldwide.

Other colors available: Blue, Green, White, Purple, Orange, Red

Any questions, simply shoot me a message! Thanks guys!

 

IMG_2017-12-12_18-55-09.JPG

Edited by mkulrey13
  • Like 3
Link to post
Share on other sites
  • 6 months later...
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By karasu1981
      hello guys, i'm new and i'm really desperate to find a scheme for an xbox with 1.0 board...i only find scheme or videos for 1.6 ... i'm stuck
      i'm following this tutorial but ofc the board is different and i dunno which cable go where
      https://www.youtube.com/watch?v=RNZOVTKGeDk
    • By TWesten
      Hi all, sadly the Xecuter X3 BIOS User's Manual has been removed from http://x3.bustedchain.com/ and from the team executer site.
      Does anyone have it saved as a complete webpage that I could go get a copy of? Would be most obliged if so thanks!
      Or does anyone know of any mirror still hosting these pages?
      Cheers!
    • By bolofski
      Hi, i purchased a faulty 1.6 xbox which was modded with xecuter 3 and the front control panel, the xbox was powering up but no sign of life on the chip or front panel, upon inspection the lpc rebuild board wasnt installed straight, it seemed to be slightly skew, i didnt really have the proper kit to remove and reseat the lpc rebuild board so i desoldered everything else and re-installed it all into a 1.4 so no need for the lpc board, i now have signs of life on the chip (chip lights up blue) and the front control panel (logo lights red and hdd activity light blinks) however i cant get the chip to enable, ive tried the bank switches in various positions, short press, long press, if i try pressing eject and power together the xbox frags once then powers up normally but the logo light is always red, ive retried all my solder points on the lpc / d0 but to no avail, anyone have any ideas anything else i could try?  thanks

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.