Jump to content

Where To Put Roms On Emustation?

Recommended Posts


So, I am completely new to this and have watched hours of videos on YT and read many forum posts trying to figure this out. But, I am not succeeding in getting an emulator to run on my xbox.

So, here is what I have and what I've done. I purchased an already softmoded xbox a year ago that has UnleashX on it with all the Xbox games loaded and emulators running (Genesis, Nintendo, Super Nintendo, N64, Playstation). I FTP'd all the roms/games from that xbox to my computer . 

I have a second xbox that I have softmodded using Rocky5's method and I have installed Emustation because I prefer the way that looks and the way it is setup. I have a 2TB drive installed that seems to be working fine and I have a F and G partition that are about 960GB each that I want to put my games and roms on. I have transferred about 8 Xbox games to the F drive and they are working. I  have used the "other settings" menu to redirect Emustation to look for roms at F:/Games. I moved the emulator (and the emulator roms folder) and media folders to the G drive and redirected to those. No matter where I stick the Sega Genesis emulator roms, when I scan (either a complete scan or selected one), it doesn't see them.

What the heck am I doing wrong? I have tried the roms in what I thought was every logical folder with no luck. So here are some questions...

1) What should the folder structure look like? Where do the roms need to go and do I need to move my emulator folders back to the much smaller E drive?

2) I know some emulators like specific roms. Could it be that even though these roms work fine under UnleashX that they are not compatible with the emulator loaded on Emustation? If so, can I just install the emulator that is running on my UnleashX Xbox on my Emustation Xbox?

3) Can I utilize both the F and G drives for my games and roms? It seems that Emustation will only let me direct to one drive for roms, in this case I have it pointed to the F partition.

Please let me know if there is any other information that is needed. I assume I am just doing something boneheaded and stupid, I just can't figure it out.

Thank in advance!

Link to post
Share on other sites

OK, still, I am doing something wrong. I have installed all my genesis Roms in that folder...

So, Emustation can see them because I get the Sega Genesis logo on the carousel, but then zero games are available. So, what am I doing wrong? I did rescan the roms and restarted the xbox.




Edited by RCAerobat
added info
Link to post
Share on other sites

So I just uploaded some nes Roms and tried both the selected scan for Roms (nes) and then tried the auto scan. I restarted the Xbox after loading the Roms and then scanned. Still no luck and these did not even bring the nes logo on the carousel. I am doing the transfers with a MacBook Pro, but none of the files were created with a Mac. Not sure if that could be fighting me, but...


I just downloaded the most current build of Emustation again and installed it just in case I messed something up. Still no luck with emulators...

Edited by RCAerobat
Link to post
Share on other sites

Ok, I think I have figured out my mistake. I tried zipping as you suggested, but they wouldn’t load. My mistake was that I was confusing “games” (for Xbox) with Roms. I have the rom finder pointed towards my Xbox games. When I pointed it toward my emulator Roms, it found them and now I am able to play the nes games! I will see if I can get the other emulators up and running now. Thank you all for your suggestions. I knew I just had something not entered correctly.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By pumphill
      Hello all, I am new to xbox modding.  I am just trying to learn more about the software side of modding this console.  I have experience modding just about every other console and am now getting into the original xbox.  I've installed an openxenium mod chip, and have ordered a 2TB hdd, ide to sata converter, and 80 wire ribbon cable.  I'm just trying to get a feel for what the current methods people are using as a lot of information is outdated.  Thanks for reading this.
    • By Amigaz
      I am in the process of setting up Rocky5's excellent XBMC Emustation dashboard and am finishing it off with the C64 section at the moment.
      Is there a way to get the nice cover art like you can for the other emulators which I have had the luxary of fixing easily thru the downloads on XBMC Emustation?
    • By gehx
      My brother gave me his old xbox v1.4 halo edition (w/ the green case) that he tsop flashed many years ago....he didn't have a hard drive in it but I have an unmodded xbox here w/ a hard drive.  thought I'd put the hdd from the unmodded stock xbox in the the tsop flashed box and see if it'd boot....it comes up w/ error 16..so I burned a copy of hexen 2020 to see if I could get that to load.....it's stuck on the splash screen (the xbox logo; x on top of the word xbox) w/ the text linux under it and the purple evo x logo in the top left corner; i've attached a picture of it)....is this 'cause the hard drive is locked?  is there a way around this, i'd like to be able to use the xbox.
      Thank you.

Board Life Status

Board startup date: April 23, 2017 12:45:48
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.