Jump to content
OGXbox.com

1.6 power supply repair question


Cannondale
 Share

Recommended Posts

My Xbox has been sitting for ever and I tried plugging it in and no lights, no disc tray. You only hear a little sound coming from the power supply. I have pscd101301a power supply. This is my back up Xbox so I figured I’ll try to learn alittle about it and see if I could fix it. All my capacitors looks good both on the MB and PS. I’m getting the 120V into the PS and I checked the pins from the connector that go to the MB and on powok I’m getting 0.43v (should be 3.3v) and on my red wires I’m getting 0.95v (should be 5v). I checked the underside for obvious damage but can’t see anything. Is this a common issue? Anything to actually fix this or is it a paper weight.

Thank You!

Link to comment
Share on other sites

1 minute ago, Cannondale said:

My Xbox has been sitting for ever and I tried plugging it in and no lights, no disc tray. You only hear a little sound coming from the power supply. I have pscd101301a power supply. This is my back up Xbox so I figured I’ll try to learn alittle about it and see if I could fix it. All my capacitors looks good both on the MB and PS. I’m getting the 120V into the PS and I checked the pins from the connector that go to the MB and on powok I’m getting 0.43v (should be 3.3v) and on my red wires I’m getting 0.95v (should be 5v). I checked the underside for obvious damage but can’t see anything. Is this a common issue? Anything to actually fix this or is it a paper weight.

Thank You!

I know it says delta but I’m sure it should be similar for mine.

122E71ED-AF16-44C0-903F-CF19A534F904.jpeg

Edited by Cannondale
Link to comment
Share on other sites

I would check the 5 volt filter cap/caps next to the 20 pin connector on the main board.

Can you post a pic of the main board? If you use a file share site like postimages.com  and add the link here.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Link to comment
Share on other sites

6 hours ago, SS_Dave said:

I would check the 5 volt filter cap/caps next to the 20 pin connector on the main board.

Can you post a pic of the main board? If you use a file share site like postimages.com  and add the link here.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

I’ll see if I can get some pictures of the MB tonight. As for now I have photos of the power supply.

https://postimg.cc/gallery/pR258kd

Link to comment
Share on other sites

On 11/19/2022 at 5:37 AM, SS_Dave said:

I would check the 5 volt filter cap/caps next to the 20 pin connector on the main board.

Can you post a pic of the main board? If you use a file share site like postimages.com  and add the link here.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

MB picture

https://postimg.cc/gallery/TK44rPw

Link to comment
Share on other sites

On 11/17/2022 at 3:02 AM, Cannondale said:

My Xbox has been sitting for ever and I tried plugging it in and no lights, no disc tray. You only hear a little sound coming from the power supply. I have pscd101301a power supply. This is my back up Xbox so I figured I’ll try to learn alittle about it and see if I could fix it. All my capacitors looks good both on the MB and PS. I’m getting the 120V into the PS and I checked the pins from the connector that go to the MB and on powok I’m getting 0.43v (should be 3.3v) and on my red wires I’m getting 0.95v (should be 5v). I checked the underside for obvious damage but can’t see anything. Is this a common issue? Anything to actually fix this or is it a paper weight.

Thank You!

Can't help much, but I will say I had the exact same thing happen yesterday. 1.6/1.6b xbox, holding the power button I would hear a quiet electronic "click" sound like it was trying to boot (the sound came from near the plug of the PSU, not the HDD). PSU looked flawless, motherboard also flawless. Bought a dirty old 1.6 off ebay, snagged the PSU, put it in and the system works flawlessly.

1.6 Power supplies are really weird and can fail without any obvious damage.

Link to comment
Share on other sites

Never bothered myself but the chips are normally standard stuff cheap chips  in PC PSU’s

No reason to think the Xbox will be any different.  The only different thing is PC PSU’s PON from a +ve supply being pulled to ground, but IIRC Xbox pulls -ve up to PON.    Someone probably will chime-in with a more in depth reply a d hopefully give you a chip part no etc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.