Jump to content
OGXbox.com

4 specific games with verified good retail discs + Redump rips (self made and verified) and ISO loader won't load


IonBlade
 Share

Recommended Posts

I'm running into an issue where just the following 4 NTSC USA games won't load on original firmware from retail disc (get stuck at the Xbox logo + Microsoft text after putting in the disc), or from hard disk via ISO or extracted files (just go to a black screen where even IGR won't work):

  • Chicken Little
  • Shellshock: Nam '67
  • Without Warning
  • The Suffering: Ties That Bind

I'm positive that these are good discs (used for the tests I've run on original firmware) and ISOs that I've ripped / converted myself and validated against Redump hashes (for the ISO loading failures).

Full details on the setup and things I've tested follow:

I've got an NTSC 1.2 Xbox, upgraded to a 2TB drive, using the recommended ~937 GB F/G configuration with 64 KB clusters on those partitions, on a StarTech adapter. The drive has been locked, so I can still use stock firmware. Clock capacitor has been removed (and clock time set), and the 5 largest capacitors (3 for CPU / GPU and the two large ones on the lower left / right of the board) have been replaced. An original Xenium chip is installed on firmware 2.3.1, with banks flashed for both EvoX M8+ (modded with EvoTool to add LBA48 support), and iND 5003 (the recent modified version with re-enabled XBL and reboot fix). Using 480i composite video out. The Language is set correctly in the MS dashboard to English, which should work with these 4 games.

I've got the proper files in place to allow ISO mounting, and all my games are installed via this process:

  • Dump disc with a Kreon firmware SH-D163B drive to full ISO
  • Validate the CRC matches the Redump CRC (so I'm sure I have a known good dump and the disc isn't the problem)
  • Extract the files from the Redump format ISO with Xbox Image Browser 2.9 build 0350
  • Use Qwix to turn the extracted files back into an XISO compatible for hard drive loading
  • Split the XISO, if over 4GB, at 4292870144 bytes into two pieces, and name them gamename.1.iso / gamename.2.iso
  • Throw the ISO into F or G, and run the XBMC4Gamers ISO prep script to put them into a unique subfolder, as well as extract the thumbnail and game name and put them into the launcher XBE that actually mounts the disc files and plays them.

This gives me 2 ways to launch my games: I can either launch the ISO from XBMC4Gamers, or I can boot into the Xenium menu with the eject button, choose to launch the stock TSOP, boot into the original dashboard, then put the original disc in and play without any mods whatsoever.

I have hundreds of games working perfectly this way, but those 4 games won't boot on this Xbox, no matter what I do.

If I try to launch them through the ISO loading method from XBMC4Gamers the screen just goes black, then stays black indefinitely. IGR no longer works, and I have to hard power down the Xbox.  (The same thing is true if I extract the files to F:\games and try to run the default.xbe.)

If I try to launch them by booting into the original firmware on TSOP, waiting for the original dashboard to load, then putting the original disc in the tray, the Xbox changes to the Xbox logo screen, with "Microsoft" below the Xbox logo (aka "I've recognized a legit game and I'm loading it"), and then just stays on that screen forever, without actually starting the game. The only thing that will break out of that is ejecting the disc, which takes me back to the dashboard, or powering off.

I've tried clearing the cache drives before loading these. I've also tried deleting the TDATA and UDATA for those games (as well as backing up all of E and wiping it clean).

This has me stumped, because:

  • I know the discs are good (dumping with a Kreon matches 100% to the Redump ISO as validated by hashes, plus 3 of the 4 look factory new)
  • I know the disc drive can read games fine, as it can load any other original disc I throw at
  • This doesn't appear to be a copy protection thing, because it happens equally when running EvoX M8+ / iND 5003 and loading an ISO or with stock firmware and loading the original disc, and when loading the original disc, we don't even get past the point where the Xbox logo / Microsoft text beneath it leave the screen to hand control over to the game.
  • I know the Xbox is reading the disc, because if I boot into modded, rename E:\TDATA and E:\UDATA to E:\TDATAold and E:\UDATAold, clear cache drives, then shutdown, boot into stock firmware, put the disc in, let the system hang at the Xbox / Microsoft logo, eject the disc to return to the MS dashboard, and then check the Memory tab, the only entry there (as expected) is the one entry for the game I tried to boot, with its correct picture.

I can't find any reports on the restored xboxscene forums, here, or reddit claiming that those games had issues booting for anyone else (though they're niche titles, so maybe no one has tried and bothered to post they don't work?), or any sort of Wikipedia article or the like talking about the games with a section mentioning they have issues loading on certain versions of Xboxes, etc. So in lack of that, it makes me think they should work and there's something else I'm missing.

Any thoughts as to why these and just these 4 games don't work, either through ISO loading, extraction to hard disk, or known good retail disk on retail firmware would be really appreciated - I'm stumped!

Edited by IonBlade
small formatting fixes
Link to comment
Share on other sites

The only game I have from your list is Shellshock Nam 67 - original disk copy. It is working normally on my 1.6 xbox with xboxhdmi running evoxm8 plus, 500gb sata2ide, with F taking the remaining space.

My only guess is your hdd is going bad or corruption of files on the hdd. I do have a 1.0/1.1 xbox that is softmodded + 500gb hdd, if you want me to test it.

Link to comment
Share on other sites

Thanks for testing it on the 1.6 and confirming no issues there! 

Regarding it being potentially a dying hard drive, here are the things that seem to indicate that isn't the case that weren't in my original post, since I wasn't thinking about that as an option at the time:

  • Before I moved to the 2TB drive a couple weeks ago, I ran a CrystalDiskInfo check on the 2TB and checked the various SMART counters like failed seeks, reallocated sectors, etc. - everything was in order.  I ran a full 3-pass format on it via command prompt, and result screen showed no bad sectors were found in any pass.
  • I just pulled the XISO back off the Xbox over FTP, hashed it, and compared that hash to the original copy of the XISO I created from the Redump that I keep on my NAS.  The hashes still match, so the bits haven't changed on the Xbox HDD from the original file put on there, as would be expected if this was a hard drive issue. 
  • Just for kicks, in case somehow that XISO got corrupted at the time I had originally created it, before I ever even put it on the Xbox, I just extracted back out the files from the XISO I pulled off of the Xbox to one folder on my PC with Qwix, and extracted the files from the Redump-matching archival ISO using Xbox Image Browser into another folder.  I then ran a directory comparison tool that recursively checks all hashes in two directories to validate that the files inside the XISO I pulled back off the Xbox are exactly the same as the files within the Redump archival ISO, and they are.

So these together seem to would confirm that the hard drive isn't corrupting data, and the files being fine.

As a further test, I also tried putting back in the old 300GB IDE drive that I had in this Xbox before updating, and get the same behavior on that drive, whether stock firmware + original DVD, M8+ with ISO loading, or M8+ with DVD2Xbox dump of the disk on HDD.

Since these 4 games also don't work from original disc on original firmware, either on the 2TB drive or the 300GB drive, where the XISO doesn't come into play at all, and I've tried clearing E, X, Y, and Z entirely before booting into stock firmware to try to boot from disc, the only files I can think that could have corruption that might be preventing this from working are those on C itself (where I only have the stock files + 2 files for dashloader and the kernel patcher for XISO loading). 

To rule that out, I deleted all the files on C, and then used the Downloader in XBMC4Gamers to redownload MS Dashboard v5960, so I'd have a stock C drive.  I still get the same behavior in all the above tests with the new C drive files in place.

So at this point, I've been able to test on 2 different hard drives, one of which I'm pretty sure is good and is validated is not corrupting data / having trouble reading or writing, and have brand new files on C, and empty E / X / Y / Z, and still get the same behavior from original disc (validated via Redump dumping / hashing on Kreon) on validated good hard drive (via CrystalDiskMart SMART scans, Windows formatting stats, and pulling a file back off of it to revalidate the hash hasn't changed), on stock firmware.

Link to comment
Share on other sites

I tested all the 4 games on a 1.4 xbox with 128mb ram and the x2 5035 bios on an open xenium chip. All the games are booting here. Maybe you can try this bios? Here some games dont load with ind bios. 
The dash is xbox4gamers and the games are stored as files on the 2TB HDD. 

Link to comment
Share on other sites

Thanks for testing!  That's a good call - I didn't think about trying with ol' reliable X2, which is what I'd used back in the day before moving to the 2TB drive.  I just gave the Xbox back to my buddy who I've been fixing it up for yesterday evening, but I'll have him bring it back over next time I see him and will take a stab with X2.  (Iirc, I won't be able to test the ISO loading method with X2, since X2 doesn't support the live kernel patching to enable XISO loading, but I can at least test the ripped copies on X2.)

Since I get the same issue on stock firmware with disc, I don't expect it will make a difference, but it's a good data point to test, and at this point I'll try just about anything just to figure out why the heck I'm getting such weird differences from others on these 4, since he really wants to play the latter 3 games on the list. 🙂

Other thought I'd had was to try to pick up another 1.2-1.4 Xbox with a Samsung in it like this one has, refurb it, make sure it can read the 4, then swap the disc / hard drive from this one having issues over to it.  That would tell me if the problem lies with something unique to the drives / discs, or with something like the firmware on the TSOP  or the motherboard.  That particular test is a little down the road though - need to get some IRL projects done before I can afford the time or cash to pick up and refurb a second one.

Link to comment
Share on other sites

Another possibility that's a stretch - don't think this could be the issue, but I'm open to anyone that knows otherwise correcting me: my buddy's cables for this Xbox are those third party cables that have ends for Xbox, Gamecube, and PS2 at one end, and Composite at the other end (only the Xbox cable is plugged in). 

I can't imagine that that would matter, but did Xbox have any sort of cable sense for analog cables, and could it be refusing to boot those particular games on the lower quality 3P cables?  (Random thought there was that maybe the Xbox is trying to boot those games in 480p for whatever reason, even though I have it disabled, and is failing to set the video mode, thus hanging.  Though I thought if that was the case, the game would still start, I'd just get either a black screen with game audio, or that "side by side" type image sent when 480p is sent over a composite cable, when I'm just getting a refusal to finish booting the game at all.)

Anybody seen issues where some games will refuse to boot at all on third party analog video cables, but work on OEM cables?

Link to comment
Share on other sites

6 hours ago, IonBlade said:

(Iirc, I won't be able to test the ISO loading method with X2, since X2 doesn't support the live kernel patching to enable XISO loading, but I can at least test the ripped copies on X2.)

I believe X2 4981 and 5035 are supported by the CDROM modchip XISO mounting BIOS patcher/dashboard chainloader application.

From the CDROM modchip's xboxapp.asm source code file, the kernel version numbers (highlighted in bold) of all the supported Xbox retail and modified BIOSes:

kernel_info_table:
    kinfo_entry 3944, 8003BE58h, 8003bff0h, 80031656h
    kinfo_entry 4034, 8003BF18h, 8003c0b0h, 80031293h
    kinfo_entry 4817, 8003B198h, 8003b330h, 8002fd41h
    kinfo_entry 4981, 8004F5F8h, 8004F790h, 80034584h
    kinfo_entry 5003, 80042D48h, 80042EE0h, 80035902h
    kinfo_entry 5035, 8005D4F0h, 8005D680h, 8003BC5Dh
    kinfo_entry 5101, 8003B298h, 8003B430h, 8002FDD7h
    kinfo_entry 5530, 8003C118h, 8003c2c4h, 8002ff55h
    kinfo_entry 5713, 8003C138h, 8003c2e4h, 8002ff6fh
    kinfo_entry 5838, 8003C138h, 8003c2e4h, 8002ff6fh
    kinfo_entry_last

It looks like X2 BIOS versions 4981 and 5035 (underlined) are supported.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By alcatraz68
      I have an old Xbox that has an Xecuter 2 chip installed, it still has the stock HDD so i'd like to upgrade it to a 500GB SATA. Weirdly I cannot physically see any chip soldered to the board, I can see some yellow wires going out the front of the console so i'm not sure if this is where the chip is located? (see pic).
      In any case I have downloaded the HeXen 2018 installation disc, and I have the necessary parts required to convert from IDE to SATA. Is this disc capable of setting up a HDD with this chip? I took a couple of pics showing my kernel and the fact my current HDD is locked:
       



    • By boydscout
      I chip modded my Xbox 20 years ago when I was in college. Not sure the type of chip but I can find out if need be. Evolution X executor rox my box load screen. Fast forward and now I have 4 kids who have resurrected the Xbox, ages 4-11. I suspect one of the kids messed up the bios but I really don't know. One day, the kids can't get into system utilities anymore and load games. Here is the screen it boots to. Not sure where to go from here to get the machine working but I can follow directions and my 11YO is as nerdy as I used to be, so I'm hoping all is not lost.

      Any guidance appreciated.
    • By SamRohod
      Hello everyone,
      I want to store my game collection in the most authentic way possible (matching Redump) but that takes a lot of storage. So, I did a little bit of research and now I have few questions (and few requests) that I hope someone could help me with.
      It seems to me that there are three main formats for storing a retail OG Xbox disc: (1) Redump ISO   (2) XISO  (3) Extracted files/Game Folder
      I did some testing with:
      Halo - Combat Evolved (USA) (Rev 2) {crc="013986d0"}
      JSRF - Jet Set Radio Future (USA) {crc="b2a882df"}
      Mortal Kombat - Deception (USA) {crc="007bcbcc"}
       
      A
      -----------------
      In the Xemu documentation it is mentioned that you can create an emulator-compatible .iso file by using either of the commands:

      -with dd:
      dd.exe if={redump_game_name}.iso of={output_game_name}.iso skip=387 bs=1M

      -with extract-xiso:
      extract-xiso.exe -r {redump_game_name}.iso

      But these two methods produce different .iso files. The one created with dd.exe is much bigger.
      A1- Are these two different forms of XISO or is the .iso file created with dd.exe just a trimming hack and not a proper XISO?
      A2- Is what is trimmed with dd.exe the same for every retail disc (meaning we can just keep one copy to rebuild every disc with it)?
      A3- What is the effect of using the two commands together?
      A4- In this post JayFoxRox says that we can separate the video and game partitions and recombine them later. Also he says that the video partition is the same for most retail games. Is that true? What games have special video partition? How to separate the two partitions and recombine them to give the original Redump CRC?
      If the video partition is the same for all/most games, that would mean that we can keep one copy of that partition to recreate the Redump ISO from any XISO file (saving a lot of space). The exception being the random padding that we need to find a way to recreate.



      B
      -----------------

      Extracting the files from a Redump ISO with with extract-xiso
      extract-xiso.exe -x {redump_game_name}.iso
      then generating a .iso with them
      extract-xiso.exe -c {Folder_with_all_the_files}

      gives a .iso file with a different CRC32 to the .iso file that is created from
      extract-xiso.exe -r {redump_game_name}.iso
       
      I tried to use IsoBuster 4.8 (free) on a Redump ISO. It worked for listing the LBA for the files and for extracting the game files.

      IsoBuster always showed 4 partitions for the Redump ISOs:
      SEP13011042
      SEP13011042072
      VIDEO
      XBOX

      and two partitions for the XISO created with extract-xiso:
      -        {it's just a dash}
      XBOX

      The files didn't change (I extracted again and compared) but I noticed that the some LBA for the files is different. Maybe there is something else that is different as well?
      B1- Is there a program that can create/edit ISO files based on LBA information (maybe like PS3 ISO Rebuilder with IRD files)?
      B2- Does this mean that we need to create files like IRD files for the PS3 (Layout files?) to be able to recreate an XISO file from extracted files?
      B3- Anyone knows a program that can do that for XISO files? For Redump ISO files? (similar to Redump2IRD)

      Note: I tried IsoBuster 4.7 and didn't work for me. In their release notes for 4.8 they mention {better XISO support}.

      General Questions:
      1- Do you think we should start a database for the random blocks seeds using the tools in HERE? (even though we can't do it for all discs right now)
      2- Can anyone provide the attachments from this thread?
      3- Can anyone provide a compiled version of this program?

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.