Jump to content
Sign in to follow this  
Darkglobe1977

Error 21

Recommended Posts

Hi All 

My Softmod with larger Hard Drive installed could not find the original Xbox Dash to boot into.

 I tried a Slayers Disk to restore this  however now every time I boot I get an Error 21. 

Before I replace the original Drive back in and redo everything is there anything I can try to fix this? 

Many Thanks

 

 

Share this post


Link to post
Share on other sites

Can you still boot from the DVD?

If so you should use the Slayers disc to reinstall the dashboard again. Otherwise you may have to hotswap the drive to a pc and fix it from there using xplorer360 or similar and copying the dash files over again.

Do you have the ability to burn another dvd? If so maybe try burning the latest updated HeXen disc from here and boot from that.

Share this post


Link to post
Share on other sites

Install a good copy of the MS dashboard to the root of the C drive.

Rocky5's Xbox Softmodding Tool Extras disc has it.

Hexen 2018 disc has a copy of it - StockFiles/C folder.  Copy it to the C drive of the Xbox.

 

Share this post


Link to post
Share on other sites

Try booting a Hexen 2018 disc.

Oh wait, the console does not boot to a replacement dashboard anymore. Slayers installer disc messed up your softmod installation.

I think you'll have to hotswap connect the hard drive to a PC and use XboxHDM to fix the files stored on the hard drive.

Type in xbrowser, not xboxhd when prompted to do so after booting into Linux.

Have the MS Dashboard files in XboxHDM's hdm/C folder or HDD_files/C folder depending upon which version of XboxHDM you are using.  XboxHDM23USB runs under Windows 10 64-bit version.  The Xbox HDD connects to the PC using a compatible USB-to-HDD interface adapter.

Share this post


Link to post
Share on other sites

You need to use the F1-F10 keys, they correspond to the functions at the bottom of the xbrowser screen. Use the TAB key to move between the xboxhdm  files (left panel) and the hdd (right panel) and the cursor keys to move around.

Select the file you wish to copy in the left screen and the location you wish to copy to and then hit the copy button then select ok.

Share this post


Link to post
Share on other sites

That error means you have a dash issue. Did you have dash files in your xboxhdm c folder?? Did you unlock your drive before running xboxhdm? Did you lock it again afterwards?? 

If you think your drive has been correctly partitioned and formatted then you can run xbrowser again and this time make sure to copy over the dash files into a location your softmod is expecting to find them. If you don’t know where that is then put your original hdd back in your Xbox, boot it and go to file manager in your dash and see where the dash files are located.

Then mirror that on your new drive.

Share this post


Link to post
Share on other sites

Please let me know if this should be a separate thread but I have a pretty similar issue and trying to minimize search hits for all others who are looking for error 21 solutions.

I have a 120 GB setup running UnleashX installed via SID 5.11 that I was trying to manually upgrade to Rocky's softmod.  Somehow I buggered it up and now am getting error 21.  I've loaded several XBOX Live compatible game discs in several different DVD drives and none of them play nor effectively reinstall the MSDash.  I have the EEPROM file saved to a PC but don't have a PC with PATA IDE.  I do have another softmodded XBOX (JCRocky 5 mod).

I was wondering if I could hook up the buggered drive as a slave to my good xbox and use Chimp to clone the C (or C and E if necessary) drive from my good XBox to my buggered box so that I can access it again via MSDash or one of the other dashboards.  I read on another site that when Chimp copies the EEPROM, it draws it from Backups or Backup folder on the C or E: drive.  Is that true?  If so, could I just transfer the EEPROM I have saved from the buggered box into that folder so that it could be loaded onto the buggered box?  I assume the good xbox looks internally for EEPROM and not a backup folder when it is doing its initial boot so that having a different one in the E:/backup/ folder wouldn't be a problem.

Thanks in advance for any knowledge or advice.  I love that this scene is still vibrant!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By CnPx
      First of all im sorry if this is in the wrong place i couldnt find an Xbox support section on the forum and this seem like the most correct place. 
      I burnt Hexen to a DVD and then after there was nothing showing up on the disc so i double checked the iso by mounting it and then it said its corrupted. 

      I'm using the Hexen 2018 disc from this website. I also tried downloading from both Mega and mediafire and i'm getting the same problems. 
      When I try opening the disc when its mounted i get this. 

      This is what showed up on the disc after burning. 

       
      I didn't want to test it in my xbox incase something went wrong. I wanted to check with people that are more experienced then me as i only just got my Hard modded xbox. 
       
      Link i used to download Hexen 2018 
       
       
    • By HackDaBox!
      Xbox Error Codes
      1 - bootldr - Unknown exactly, something to do with checking the motherboard
      2 - bootldr - Eeprom check failed
      3 - bootldr - ??/not used
      4 - bootldr - Ram check failed
      5 - kernel - HDD not locked (retail bioses require the hd to be locked)
      6 - kernel - Cannot unlock HDD
      7 - kernel - HDD timeout
      8 - kernel - No HDD found
      9 - kernel - HDD parameters (PIO/DMA/or size {debug}, certain size minimum is required for debug)
      10 - kernel - DVD timeout
      11 - kernel - No DVD Founnd
      12 - kernel - DVD parameters (PIO/DMA)
      13 - kernel - Dashboard launch fail (due to missing/bad key, or anything else that would prevent it from running) and the dashboard didn't specify why it failed.
      14 - dashboard - Error loading dashboard (dashboard generic error)
      15 - ?? - not used
      16 - dashboard - Other files to do with dashboard / dashboard settings (specific dashboard error)
      17 - ?? - not used
      18 - ?? - not used
      19 - ?? - not used
      20 - kernel - The dashboard was attempted to load and failed; It was a cold boot, and the dashboard didn't specify why it failed, but it (for some reason) needed to be noted that the dvd passed the challenge/response authentication
      21 - anywhere - This error says that the machine was booted to display a error, basically someone told the machine to reboot (or launch a xbe) with this flag, and the error code just means its been rebooted by the flag
      The Most common errors are dashboard related ones and simply reinstalling the MS dashboard will fix these. Use Slayer's Evox Auto Installer to repair your dashboard. After installing a new large hard drive if you get an error just ftp the original (C:)  and (E:) folders from your computer's hard drive over to the xbox. Allways install hard drives as cable select for use in xbox's.
       
    • By HackDaBox!
      Original Xbox Error Codes
      Please login or register to see this attachment.

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.