Jump to content

Welcome to our site

Take a moment to join us. You can sign in with Facebook with a couple of clicks. No need for a lengthy registration. We also have Tapatalk support so you can use this forum on your phone the same way you use facebook. It will keep you notified.

wikati

A Tale of 4 Ram Chips. 128mb - Ape Vs Tech.

Recommended Posts

Friday night i got home excited to try a ram upgrade

have a perfect V1.1 in a crystal case, what could be better

soft modded, unlocked the TSOP, flashed x25035 using hexen, swapped in a big sata drive/80wire ide/ installed XBMC as dash, smooth sailing...

So i had purchased a set of chips from utsource about 4 weeks ago and when they got here i only had 3 chips... checked my invoice and realized i had ordered and paid for 3 chips... bummer

So in haste i ordered 5 more from an ebay seller in the states... i had ordered  K4D623238F-QC50

Got all 5

I installed 4 of them after the TSOP (in the same night) not realizing this is a 512K chip and the XBOX needs the 1M

all the way up to the 4th i was getting orange and red flashing.... good sign, diligent with continuity tester

on the 4th it was clear something was wrong... i went to bed frustrated with a few unknowns.

 

Got back at it and installed the 3 utsource chips in place of the 512's, when i had all 3 in with 4 still being installed i realized at flashing orange and red the eject button would boot the X2 bios??? what sorcery is this.

The ram wasnt being recognized but it prompted me to consider XBLAST (which i was vaguely aware of)  seeing as i had access to HDD/FTP from dash
Please login or register to see this link.

Found the xbe version, booted from XBMC and actually had a success on 1/4.. now im feeling ok.

Re-flow the other 3 (XBLAST has a diagram entailing which chip is which so you can refrence their test screen)
 

now i've got 3/4 testing positive. very excitedly I open up another xbox i use and harvest a chip (hell i can replace it another time!!!!)

Well, the removal goes spotty at best and by the time ive lined up the pins and got the soldering done one of the corner pins breaks off while im trying to make a small adjustment.... angry i take it off the board.... lift a pad.... now you've ruined a wonderful console, and have 3 chips to remove and not enough supplies to outfit anything with an upgrade. remove yourself from the situation, breathe deep and take a nap.

luck is funny.

Please login or register to see this link.

After examining the pinout of the chip i realized the center pins of the right and left side are named N.C..... what could that be? is it possible thats pin for the pad that lifted??
Ii find another datasheet that explains the definition of N.C as "reserved for future revisions" otherwise: This pin doesnt get used right now... WHAT!!?!?!?!

 

Sure enough the lifted pad is N.C on the pinout diagram

Just yonder a warm optimism drags me back into the basement.

 

Now focused, rested, and caffeinated i go to work at harvesting another IC from the 1.4. a fantastic removal, straight pins and all.

Get the chip down with no hiccups and wearily stare at that grey pin on a brown backdrop (lifted pad)

all back together XBLAST reports 4 success'

victory is sweet

XBMC sees it, Virtual Cop 3 boots....

YES!!!

 

Despite so many stupid mistakes it worked!
But its not all roses i wasted 30 bucks on 5 ic's i will never use and also the fact my 1.4 is now in limbo.

so i can either replace the 2 and call it a day..... or...... order 6 and spend another 12 hours hunched over a 17 year old game console..... i think i'll take the latter.

  • Like 2

Share this post


Link to post
Share on other sites
12 hours ago, cOrPsE said:

congrats man, im too much of a wimp to attempt ram upgrade

i think im more frightened now that i tried it.

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
21 minutes ago, Alpha Mendes said:

Ótimo trabalho amigo B|

thank you alpha mendes,

now that i've re-installed ram on the board i robbed the chips from i've found this procedure alot more straight forward.

with; new chips, lots of flux, some desoldering braid, a copy of xblast, and a couple hour i could likely have one complete. barring any surprises of course. and they are bound to happen.
 

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, big F said:

I have some chips waiting for me to get round to it at some point.

its a great feeling to get it working.

 

the experience is marginally better. but its still alot of fun.
i need to find more time to catalogue exactly everything the 128 can do that the 64 cannot.

 

id also like to do this with the 1.4ghz upgrade soon as well.
the information on that upgrade doesnt seem to be at all public and i dont have the level of commitment to get there on my own.

 

if reality wasnt real id already have a 1.4ghz console here, but reality is real and 400 dollars around my house does not get spent on an xbox with 2 miniature versions of me present. I earn a living that a college dropout should be damn thankful to be earning...... a long way of saying its not in the budget for the next little while. so i am praying to the xbox gods that the talent that produces these stays available and interested. N64 Freak, i see you.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Board Life Status


Board startup date: April 23, 2017 12:45:48
  • Similar Content

    • By Charles Michael Rondon
      Is there a place where I can get an upgrade for my old xbox? I was looking for one those freidmtech dream series, but to my bad luck their website is Offline?
      is there any possibility to get and upgrade console somwhere else?
      ebay doesn’t have any.
      Thanks for any possible replys. 
    • By wikati
      the method using a pin and a soldering iron that floats around the net is unsustainable.
      i recently acquired a couple dead boards and one of them has samsung ram which my 1.2 had stolen from the bottom when i upgraded my 1.1 and ran out of new parts.
      so i said screw it im gonna put the 2 i need on this board.
      this is a way better homebrew than the pin.
      i made a small 'puller' out of a very thin piece of wire (the type thats inside of cheap cheap twist ties you get for the garbage bags.

      twisting the loop over top adds a subtle tension to keep hold of the chip. lots of flux applied to pins (not applied in this pic)
      each end is bent over and tucked under the row of pins, use a small enough gauge wire you arent jamming it in.

      heated slowly on low setting with a cheap heat gun (the econo brand heat gun)
      then one good blast at high once warmed up and it pulled right off.

      lots of movement of the gun and very delicate pressure when pulling.
      beautiful.
      they laid down on the other board with ease
      tack the corner on X & Yaxis,
      then line up pins and do another x & y. then just apply slight pressure with finger on chip and hit each pin with the iron.

      the unit fired right up.
      this solution originally came from removing a botched install.... removing i didnt want to accidentally scrape one of those small caps/resistors off. and i had already made a decision that hot air had to be the solution to removing these.
      handling the chip becomes most important once the solder goes molten.
      20180318_183738.mp4

    • By wikati
      Curious question
      in a furious rush i harvested 2 ram chips off a working board, now id like to re-install these and get it working again because as far as i can remember this unit worked just fine prior.
      the replacement ram came from a friend with a broken console. one chip had 2 twisted pins which laid down pretty nice with gentle persuasion. 
      now that they are installed (2 on the bottom) the unit will not power on?
      power button does nothing, any ideas how ram affects the power process?
      could this be a separate issue? 
      very interested to hear thoughts/theories. 
      the extent of my troubleshooting was testing a working consoles psu on this board which yielded identical results (power button does nothing, i can 'hear' the psu working there is a subtle discharge sound).
      i have 1 more chip to try in place of the twisted one. 
      there are no bridges on the install and contact is made on each pad as far as continuity is concerned.
×

Important Information

By using this site, you agree to our Terms of Use.