Jump to content

OpenXEnium Chips for Sale


Recommended Posts

The Xenium (OpenXenium) has so many more features than the Aladdin modchip.

Biggest one being multiple banks so you can flash and boot different BIOSes. (Not that anyone needs to boot more than one BIOS but you can't try others without wiping the one 256KB bank that an Aladdin has to try another.)  Limited to using one 256KB BIOS with an Aladdin modchip.

The XeniumOS can format a new hard drive in the Xbox without any other software. Albeit, doesn't do G drive and I believe only supports 16KB clusters for a maximum size of 256GBs for the F drive.  Therefore, to properly format the extended partition(s) on hard drives larger than 250GBs, you'll have to re-format the extended partitions with XBPartitioner v1.3.

@KingLuxor's eBay listing contains a bullet list of features of the OpenXenium modchip:  (copied from there to here)

Supported XeniumOS features: (taken from project repository)
  • Software controlled BIOS bank switching (any BIOS combinations that fit into 1mbyte of flash memory (4x256k, 1x512+2x256k, 2x512k, 1x1mbyte).
  • Instant boot to a chosen BIOS using the power button.
  • Boot the XeniumOS with eject button.
  • Ability to boot from the onboard BIOS (colloquially known as TSOP booting). This will completely disable OpenXenium and release D0/LFRAME(1.6) to boot the Xbox as if stock.
  • All the standard features in Cromwell/XeniumOS. (EEPROM tools, Hard drive tools, FTP/SMB Server etc.).
  • Three general purpose outputs. These are normally bitbanged as a SPI master (MOSI,CLK,CS) with the most common use an LCD, however could support any SPI peripheral in theory.
  • Two general purpose inputs. On a Xenium, these are I believe intended to be MISO lines to complement the SPI interface but could be used for any 3.3V digital logic.
  • Three outputs are connected to an RGB led (Or an external user added RGB led).
  • Reserved memory on the flash chip for non-volatile storage of an EEPROM backup and XeniumOS settings.
  • If you bridge the two recovery pins on power up, it will attempt to boot the XeniumOS recovery BIOS if available. This functions the same as a genuine Xenium modchip.
  • LFRAME abort mechanism (Ref Intel LPC Interface Spec Rev 1.1 Section 4.3.1.13) for a v1.6 console to prevent the Xyclops responding to the MCPX LPC Memory Read requests during boot (and conflicting with an external LPC memory peripheral). This is generally accepted to be better than shorting LFRAME the ground constantly which some traditional LPC memory addons do.
  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Difio
      Hi, I'm having a really strange issue with some OpenXenium I've built that is driving me crazy. Basically, after flashing XeniumOS with Xenium Tool and hotswap method, on the first boot the modchip works fine: XeniumOS is loaded, I can flash other bios (and I can boot them!), so everything works as intended. However, if I reboot the Xbox the chip doesn't work anymore and the console FRAG. If I reflash XeniumOS it works again at first boot, but - as before - when rebooting xbox everything I get is a FRAG.
      I tried turning on with eject button or recovery switch, but nothing change. I tried different dump of XeniumOS and used also the official release of 2.3.1 XeniumOS. It simply acts as a modchip without any bios. It's really something strange because this is happening with all of the five chips I've assembled, with exactly the same behaviour. Thinking of a bad batch of Xilinx or flash I bought another set, but even with them I've the same issue. I really can't understand what's going on. It's like the flash get corrupted after every first boot of XeniumOS.

      The Xbox boots without any issues with Aladdin Xblast (which I use to do the hotswap method), so I don't think it's something related to the console. I've upgraded RAM to 128MB, but I don't think it's a problem for openxenium. I program the CPLD with a DIY Xilinx Parallel programmer and Impact (using .jed or .svf) without any error and CPLD works fine, it's recognised by xenium tools, I can change the colour of the LED etc.
      Any suggestions? I've searched on the internet, but could not find anything useful. Thanks 
       
    • By KpCollins
      I Tsop'd and de clock capped a 1.1 Last night after realizing I can't do my other Xbox because its 1.6b? Literally the last batch of Xbox's Produced must be with its Manufacter date 16/08/2005
      Ideally I'd like to have this hard modded rather that just Soft because my eyes have been opened.
      I'm looking for a reputable place to buy a Chip at a decent price and which chip would be the best?
       
      I could buy the Aladdin Chip now from here
      http://www.modchipcentral.com/store/home.php?cat=273
      Will this work with the above 1.6b xbox?
       
      Edit: Noticed this is an American store and might not deliver to the UK
    • By Cosmonaut Cartilag
      I'm an absolute cretin and have wanted to go for a paint job similar to the look of the official Mountaindew xbox but instead of neon green i'll have it as neon orange or something. What would you guys recommend? 

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.