Jump to content
Sign in to follow this  
BulletWasp

Ftp Issues

Recommended Posts

So I now have my cable to try and connect my Xbox to my PC. I have filezilla set up, I have gone into my adapter settings on my PC and changed the IPV4 settings to:

  • 192.168.0.1
  • 255.255.255.0
  • 192.168.0.1

My settings in my Xbox are:

  • STATIC
  • 192.168.0.2
  • 255.255.255.0
  • 192.168.0.1
  • my settings screen does not show me the Port or the Max No. of Users

In FileZilla I have typed in 

Host: 192.168.0.2 --- Username: xbox --- Password: xbox --- Port: 21

When I try to Quickconnect using FileZilla I get a Connection attempt failed with "ECONNREFUSED - Connection refused by server" error. Any ideas what I'm doing wrong? I have checked a lot of videos on Youtube, and it seems that I have entered everything correctly. Not being able to see the Port or the Max No. of Users doesn't help tho -_-

Share this post


Link to post
Share on other sites

With some FileZilla versions, the QuickConnect boxes require a secure encrypted login which the Xbox FTP server does not support.  

Use the Site Manager to create an entry for your Xbox connection and set the Encryption to:

Only use plain FTP (insecure)

5c5b73b60ac19_FileZilla-UseonlyplainFTP(insecure).jpg.05b3e2b609eefdfe8581dd704946de16.jpg

 

  • Like 1

Share this post


Link to post
Share on other sites

I tried what you have shown me and still get the ECONNREFUSED error.

I have PINGed it in CMD and it shows that it is receiving. I have also turned off the firewall.

Here are more of my settings since some have changed:

XBOX (in EvoX settings)

  • IP 0.0.0.0 (?)
  • Line Status 100/Full Duplex
  • Ethernet MAC Address 00:0D:3A:AF:68:4C
  • Setup Network --- YES
  • Use Static IP --- NO (changed by me according to a guide online)
  • IP --- 192.168.0.2
  • Subnet Mask --- 255.255.255.0
  • Default Gateway --- 192.168.0.1
  • DNS --- 203.12.156.12 (changed by me according to guide)
  • DNS --- 0.0.0.0 (have not changed)
  • DOES NOT SHOW PORT OR MAX NO. OF USERS

IPV4 SETTINGS

Use the Following IP Address:

  • IP Address --- 192.168.0.1
  • Subnet Mask --- 255.255.255.0
  • Default Gateway --- empty (need to fill in?)

Use the Following DNS server address:

  • Preferred DNS server --- 203.12.156.12 (changed by me according to guide)
  • Alternate DNS server --- empty (have not changed)

In FileZilla I created a New Site and named it xbox 192.168.0.2

  • Protocol --- FTP
  • Host --- 192.168.0.2
  • Port --- 21
  • Encryption --- Only use plain FTP (insecure)
  • Logon type --- Normal
  • User --- xbox
  • Password --- xbox

Share this post


Link to post
Share on other sites

If you want to have the IP manually assigned (STATIC), you need to have STATIC set to YES.  Otherwise, the Xbox will try to obtain an IP address from a DHCP server to dynamically have the address assigned.

The reason the IP address is 0.0.0.0.  It has not been assigned an address.

Update: If you pinged the IP address 192.168.0.2 and it's responding, you must have some other device on the network that is using that address.  Each device should have a unique IP address assigned to it.

Edited by KaosEngineer

Share this post


Link to post
Share on other sites
2 minutes ago, BulletWasp said:

Okay, that makes sense now. I will change that and see what happens. Do all the other settings look alright though?

You don't really need any DNS server or gateway - until you have the Xbox connected to the Internet, but they should work as is too.

What version of Evoxdash are you using?

Edited by KaosEngineer

Share this post


Link to post
Share on other sites

So I actually did connect for a short moment, but FileZilla gave me these statuses:

  • Status: Connecting to 192.168.0.2:21...
  • Status: Connection established, waiting for welcome message...
  • Status: Server does not support non-ASCII characters.
  • Status: Logged in
  • Status: Retrieving directory listing...
  • Command: PWD
  • Response: 257 "/" is current directory
  • Command: TYPE I
  • Response: 200 Type set to IMAGE.
  • Command: PASV
  • Response: 502 pasv is not implemented.
  • Command: PORT 192, 168, 0, 1, 14, 46
  • Error: Connection timed out after 20 seconds of inactivity
  • Error: Failed to retrieve directory listing

Share this post


Link to post
Share on other sites

Not sure why a guide told you to set the DNS server to 203.12.156.12

Resolves to be: b1-203-12-156-12.melbpc.org.au

Any actual DNS server, 1.1.1.1, or just leaving it 0.0.0.0 until DNS requests are being sent by the Xbox to the Internet to access sites.

 

Share this post


Link to post
Share on other sites

In the site manager. go to the Transfer Settings tab and change from PASV or default to Active and Limit the number of simultaneous connections to 1: 

5c5b8318264a5_FileZilla-specificsite-Transfersettings.JPG.3960967fd2b7544fe88265bb0a673888.JPG

Power off the Xbox and PING 192.168.0.2 again.  If you still receive a response, you have something else connected that's at the same IP address you are trying to use for the Xbox.  Change the Xbox's IP address to a different address and try connecting to the new address.  Each device needs to have a unique address.

Edited by KaosEngineer

Share this post


Link to post
Share on other sites

I've noticed when it gets to Command: PORT it always changes the last few numbers. The first time it said the number listed above, the 2nd time it said

Command: PORT 192, 168, 0, 1, 14, 126 

before timing out

and the 3rd time is said

Command: PORT 192, 168, 0, 1, 14, 133

before timing out

at least I am connecting for a few moments :7_sweat_smile:

Share this post


Link to post
Share on other sites

Okay, I will try that as well

EDIT: After powering off the Xbox I still am getting pings back, I'll change the IP and try again. Thanks a lot

Edited by BulletWasp

Share this post


Link to post
Share on other sites

I have changed the Xbox's IP to 192.168.0.200, and I am connecting but it keeps timing out trying to get the directory listing.

  • Status:    Connecting to 192.168.0.200:21...
  • Status:    Connection established, waiting for welcome message...
  • Status:    Server does not support non-ASCII characters.
  • Status:    Logged in
  • Status:    Retrieving directory listing...
  • Command:    PWD
  • Response:    257 "/" is current directory
  • Command:    TYPE I
  • Response:    200 Type set to IMAGE.
  • Command:    PORT 192,168,0,1,16,196 <--- Every time it tries to connect, this number changes
  • Error:    Connection timed out after 20 seconds of inactivity
  • Error:    Failed to retrieve directory listing

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Keith01
      Purchased a Xbox V 1.0 that has the Xecuter X3 mod chip, unit wouldn't even boot at time i received it ( sorry been otta this for like forever and just getting back into it ). After numerous trials and errors i finally got it to boot up, switch configuration on front. Anyways seems like its missing the backup that should be on the mod chip itself, doesn't seem to matter what i try cannot find it, other problem is it only stays on maybe 45 mins and shuts down, i think its a power supply issue, going to try another power supply this weekend since i do have a good replacement for this version. Other issues is cannot turn unit on with power button, only with the eject button, also another weird issue is when its first plugged in it comes on without touching any button on the front, lots of strange issues going on here, maybe someone may have a bit of insight to help resolve these problems. First thing i did was remove clock cap, had leaked a little but not bad at all, area around it got a very good cleaning and looks great
    • By Roxas
      Hello,
      I recently got two broken Xboxes and was able to build a working console from both.
      The Xbox has a softmod and I'm thinking about flashing the bios. How do I do that best?
      It is a XBOX version 1.4 (Winbond) and I would like to transfer everything via FTP, because I don't have a DVD burner. 
      I have read something about HeXEn and Tsop but I am now rather confused.
      Can I also bottle the Bios over FTP, if so how? 
      Do I have to remove the softmod and is it still possible via FTP after flashing?
      Thanks in advance. 
       
    • By kajar59
      i have a odd problem if i use unleashx to as my ftp i cant have over 4 connections with out it locking up or stalling has anyone ever had this issue 

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.