Jump to content

Welcome to our site

Take a moment to join us. You can sign in with Facebook with a couple of clicks. No need for a lengthy registration. We also have Tapatalk support so you can use this forum on your phone the same way you use facebook. It will keep you notified.

SneakyKreiger

Aladdin Advance V1.0-1.6

Recommended Posts

Anyone here have a Aladdin XT Plus 2 or Advance modchip? (Official one, not clone without traces,there's a difference) , i've got a official chip here and its got the traces to the pinouts but there's no Trimmer potentiometer , so i'm going to add one, but i don't know the resistance increment 5k-20k? I mean would it matter or what. My reason for doing such is i'm going to solder this trim pot to a chip without one. So i can get a contrast adjustment to my LCD.

IMG_0366.JPG

IMG_0367.JPG

trim pot.JPG

Share this post


Link to post
Share on other sites

It won't do any good as that modchip doesn't support an LCD.  The CPLD, a Lattice LC4032V, doesn't have enough macrocells to implement LCD support.  Thus, the reason clones left off traces to the pads for an LCD and had no pot installed.

Edited by KaosEngineer
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
11 hours ago, SneakyKreiger said:

If i where to solder on a LC4032v would this work ?

You have to have a properly programmed LC4064V.  From Lattice, the chips are not programmed.  The code to program an LCD supporting Aladdin modchip has not been released.

Edited by KaosEngineer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Board Life Status


Board startup date: April 23, 2017 12:45:48
  • Similar Content

    • By neighbor
      Looking for Aladdin XT 4064 with LCD support, if you are willing to sell one, let me know your price.

    • By shawly
      Hi,
      so I've used Please login or register to see this link. to install an Aladdin XT PLUS2 into my rev 1.4 Xbox.
      I soldered D0 to the chip and bridged BT so the chip is always on, but as soon as I power up the system, the screen stays black. If I unplug the chip it normally boots.
      At first I followed the guide and soldered D0 to the LAN LED's ground, but then the Xbox would just boot normally without the EvoX logo, after I soldered D0 to the chip, the black screen problem appeared. (FYI I took the pictures when I still had D0 soldered to the LAN LED's ground. Oh and Ignore the 4 pins at the top, I was too fast and placed the pin header wrong, so I had to solder on 3 other pins)
      I already checked the solder points three times and tried to reflow the solder points two times in hopes that I just messed up soldering the pins, but that didn't help either.
      Can somebody tell me what the cause for this to happen could be? The system doesn't FRAG, HDD spins up, but the TV just stays black.


    • By Flowlance
      Ok this is really frustrating. The xbox flashes green/red (restarts 3 times). And I can't figure out what I've done wrong here. I felt like the job went really smooth.
      I have also cut the trace near the xbox chip (so it cannot boot from the xbox's bios anymore, right?). 
      I tried desoldering everything, replacing the wires, removing unused pins, adding them back. Grounding D0 (Even though I cut the trace, I decided to try). 
      What else can I try? This was my precious crystal xbox too, and was excited to get the job done
       
      Edit: I tried the Aladdin modchip in a 1.4 Xbox, and it worked just fine there. I also checked continuity on the lpc rebuild, and it seems to be fine. No shorts. Did I get any of the wires wrong?





×

Important Information

By using this site, you agree to our Terms of Use.