Jump to content
  • Similar Content

    • By empyreal96
      *Disclaimer: No links to file will  be provided, this is for discussion only*
      Not sure if anyone has yet, but I have been running a diff between Barnabus Kernel Repack and the 4400 leak Kernel Tree..
      I've only just started looking through, and I have next to no C++, C and C# coding skills so bear with me lol
       
      They seem somewhat the same, but there are quite a few files with parts of code removed or added, on both branches. But Barnabus is reliant on precompiled objects (obviously as it's a smaller, almost stripped down and made 'easy' release of the full tree)
      There are some comments in Barnabus code that isn't in the full tree + CPXXUPD code, and some are recorded more 'formally'
      (i.e private\ntos\init\init.c line 244 - 254 in both branches)
      One other thing is the 4400 tree is set to have 'complex's' edits definable where possible, which there are a lot..
       
       
      One thing that really interests me, is Barnabus uses BIOSPack to pack: 2bl, remainder and kernel into a 'Working' rom (I use that word loosely).
      The 4400 tree uses rombld, which requires: preloaded, init table, bootloader, kernel and a rom decode file(I think).. this is a drastic difference to BIOSPack.. But the main issue with Rombld is it will not produce a full rom.. by default it will error on the 'preloader' being to big (9008 bytes not 1664 bytes)..
      To get around that, we can either build for XDK Systems.. 
      Or as I discovered today: modify 'private\sdktools\rombld\rombld.cpp' Line 879 from (2 * 1024) to (21 * 512), to allow rombld to accept the 9kb preloader file.. (I haven't tested a bios rom built with this edit yet)
       
      I will post here anything else I discover! 
    • By eustachy1973
      My modest modification.
       

       

       

       
      128MB Ram

       
      New Fan
       

       
       
      Open Xenium Chip with Ryzee119's XEnium Spi2par2019
       

       

       


       

       

       

      To be continued...
       
    • By Benedikt.m
      Hey guys,
      I just found this forum googling for an instruction for my modchip. Probably 14 years ago i installed this modchip and it worked fine for years. A few years ago after i moved i wanted to use my xbox again and it dind't work at all. So today I atemped another try. I reconed a loose cable which supposedly needed to be connectet to ground, which i did. Now the Xbox does boot the original bios. I can see my copied music and game saves. Trying to start it with pressing the power button for  2 seconds sometime leeds to atempt to start in whatever bios is installed on the modchip, but it restarts in the original bios. Nevertheless the LED on the modchip does light up on start. Do you have an idea how to get it to boot up with the modchip or a procedure to test if the modchip itself is actually working? Maybe you can point me to thread i missed.


Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.