Jump to content
Sign in to follow this  
GoTeamScotch

Modchip Hotswapping

Recommended Posts

I could use some guidance here as I'm feeling rather dumb. I see plenty of forum posts about how you can simply boot up an Xbox with a modchip (D0 grounded), swap modchips, and flash the 2nd modchip as a means of fixing a bad flash. I'm trying to do this with a Duo X2 Lite chip that has a bad bios flash on it and every time I go to flash it, the app I'm using says "flash write protected" or something similar. Basically, the end result is that it can't flash the Duo modchip that I swap in. I've tried several times using different timings and different flashing apps (chimp vs evolutionx). Is there some obvious step I'm missing here? Should I be booting from a disc (hexen)? Loading into a special/BFM bios first?

D0 is grounded to a screw mount. I'm sure it's booting from LPC.

I'm booting with an OpenXenium, then swapping in an X2 Duo Lite (bad bios flash). I flashed a debug BIOS onto it first to use on my DVT4 kit, then later I flashed Yoshihiro's debug bios (which I found out is not actually not meant for debug/dvt consoles). I then used the 5849_Recovery disc to try and flash the modchip back to the official debug bios, but that bios is 1MB in size (2 copies of the identical 512KB debug BIOS), whereas the Duo X2 Lite can only hold a 512KB BIOS. So I guess it failed part way through? I have other modchips, but they either aren't compatible with the MCPX2 found in dev/debug Xboxes or aren't big enough to hold the 512KB debug BIOS.

I'm basically booting with OpenXenium, then getting to my dashboard (XBMC), then loading Chimp. If I swap the chips prior to Chimp starting, Chimp just fails to start. The Xbox just freezes on a black screen. If I swap the chips after Chimp loads, it says "flash not writable" (or similar message). Same experience with evolutionx. The BT point is soldered on the Duo X2 if that matters (to enable always-on mode).

Any tips on what I'm doing wrong or steps to try? Is my X2 Duo just screwed? Should I be using a different modchip other than OpenXenium on first-boot for some reason?

By the way, the whole reason I want to flash this Duo X2 is to get my DVT4 kit back up and running. It has a bad TSOP flash (came to me like that). I might skip all this and focus on figuring out how to fix the TSOP, since using the Duo is just a bandaid fix anyways. I've already tried splitting the TSOP and that didn't help so I'm not sure what to do next other than desolder the tsop and program is externally... and I don't have a hot-air rework station anymore, nor a programmer.

Share this post


Link to post
Share on other sites

Update- I used a different Xbox and a different modchip during boot (an Aladdin instead of OpenXenium) and was able to hotswap and fix the flash on my Duo X2 chip. Problem resolved.

I also suspect that the Xbox I was using was being problematic because it apparently has a corrupt eeprom, probably from running 5849_Recovery on a retail console. I know it tries to flash the debug BIOS but I didn't know it also altered the eeprom. So I'll come back to fix that one later.

Anyways, DVT4 is back up and running.

Mods- feel free to delete my thread. Or keep it in case someone in the future stumbles upon it.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Similar Content

    • By meimar
      Hello all.
      I'm a new member of the forum and I have been playing around with the OG XBOx for a couple of years now. I never owned an XBOX before so my knowledge of the history is relatively limited. I do enjoy the versatility of the original XBOX, and I am amazed by the huge community and custom stuff that exists out there.
      Some of the machines I acquire (~40%) come with the modchip installed, but still have the original HDD. In the past, I removed the modchip because I could not find any info about it, and proceeded with a softmod, disk upgrade and so on.
      However, after I discovered this forum, I am having second thoughts and I am thinking maybe it is better to keep the modchip and follwo a differen approach.
      So, the question is, if there's an advanctage of the old modchips (probable Alladin II, I think) versus the more recent softmods. 
      thank you very much in advance! 
      Michalis
    • By madmon
      I have a xbox 1.0 here that fragged the day I got it. I thought "oh HDD probably died I'll just install a modchip". Well after installing said modchip I'm still met with 3 power cycles and the red and green lights with no error codes. Ive checked my soldering, checked that D0 is grounded, checked all caps, I cleaned the board after removing the clock cap, inspected traces for any signs of trace rot. Are there any caps that could go that just wouldn't show any sign of swelling or leaking that could cause issues?  
    • By k0mpresd
      gerber files for xblast lc4032 type modchip. program lattice with xladdin xblast svf. program 49lf080a with 512, 256, and xblast os = 1mb. tested, works. short s1 to boot 512kb bios, short s2 to gnd to boot 256kb bios. cheers, internet world. hope someone makes use of these files.   Please login or register to see this link.
       
      Moderator Note: zippyshare file has expired. The file is no longer available from there.  However, see attachment to post below for a backup copy of it:
      Please login or register to see this link.
       

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.