Jump to content

Welcome to our site

Take a moment to join us. You can sign in with Facebook with a couple of clicks. No need for a lengthy registration. We also have Tapatalk support so you can use this forum on your phone the same way you use facebook. It will keep you notified.

MarkS

Psu Dead? How To Test

Recommended Posts

Hi all,

My trusty old XBox has stopped powering up (no lights or drive activity, nothing). I have opened it up to check for leaking caps. It is a 1.0 or 1.1 version, so I checked the clock capacitor which had indeed leaked so I removed it and cleaned the pcb but still no joy. 

Then I started testing the FoxLink PSU. The socket soldering looks ok and I found that at least the 1st coil has tension, but when measuring the pins on the mobo connector there is nothing (I also measured the Power OK and Power ON pins). I can’t see any visual damage on the PSU. Can I conclude that this PSU is dead or is this normal? 

Share this post


Link to post
Share on other sites

The bottom side of the motherboard has 4 very thin traces along the outer edge of the board that the electrolyte can corrode thus break the continuity. 

2YESah9.jpg

The outer two carry the control signals from the power and eject buttons on the front panel to the System Management Controller (SMC - a PIC processor).  The other two traces carry signals from the SMC/PIC to the LED drivers (transistors) that power the RED and GREEN LEDs that light the eject ring.

See diy.sickmods.net's web page for information on how to test and repair: Please login or register to see this link.

Edited by KaosEngineer

Share this post


Link to post
Share on other sites

You should measure 3.3Vdc between the brown (+, Vstb) and black (-, GND) pins on the power supply connector.  The standby supply voltage level should be present when the console is plugged into the AC wall outlet.  If not, something is wrong with the AC power connection to the power supply or the power supply unit (PSU) itself.

First Test - Verify that Vstb is Present

The Xbox's standby power supply section is always on when plugged in.  It's the voltage supply that keeps the real-time clock (RTC) running and charges the 1F 2.5Vdc SuperCap (clock cap).  When AC is unplugged, the SuperCap continues to power the RTC for a couple hours when it's functional - not leaked electrolyte onto the motherboard. 

Short Intro into the Xbox's Power-On Operation

The front panel (FP) power switch grounds a specific pin on the PIC processor (System Management Controller - SMC) through a long thin trace that travels around the edge of the motherboard. There are 4 traces each with a different purpose routed in parallel along the edge of the printed circuit board (PCB) from the FP connector to the SMC. When the user presses the power button (similar 4 eject), the power control line to the SMC is grounded.  In turn, the SMC sends a signal to the power supply telling it to turn on the remainder of the voltage supplies to power the entire console.  

However if the clock cap has taken a leak on the motherboard, the electrolyte can corrode these trace(s) on the bottom side of the motherboard til they lose continuity. Button closure state no long reaches the SMC. Thus, the SMC may no longer know when to power on the console or eject the DVD tray.  The front panel LED control lines are part of these 4 traces too.  As they are further from the edge of the PCB, they generally do not lose continuity due to corrosion but they can.  If so, no front panel LEDs will light up.  Enough... :)

Share this post


Link to post
Share on other sites

That’s a great and detailed explanation! I think there was no tension between the black lines and any of the other lines, but I will measure again. I suppose the description above also applies when the psu is unplugged from the motherboard?

Share this post


Link to post
Share on other sites

I would think so but I've never tried, as the 3.3V standby supply is always on when AC power is connected (however it may not without a load attached).  The remainder of the supply levels will not come on without a load present. A switching power supply requires a load be connected for the power supply to operate.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Board Life Status


Board startup date: April 23, 2017 12:45:48
  • Similar Content

    • By XboxMon
      I successfully cloned my 100GB Maxtor to a Seagate 1TB drive using CHIMP.  All my data, games, skins, etc were intact on the new drive.  Then I went to use CHIMP to extend my partitions on my master drive (the Seagate) so it would recognize all 1TB but much to my chagrin when I rebooted I seemed to lose everything, including my skins, my emulators, and my Xbox games (there were about 100GB worth).  The menu shows the categories and a barebones UnleashX skin but nothing inside them.  How do I extend my partitions on my cloned drive so I get the full 1TB without losing my current UnleashX setup?
    • By twiztiddreamz
      I've seen several UnleashX skins show the game picture/icon next to the name of the game.  But they don't show up with any of the games i've put on the hdd.  Am I missing something in the game folder itself or a setting I need to modify in UnleashX?  Any help would be appreciated.
    • By jhark
      Works with modding other systems too...

×

Important Information

By using this site, you agree to our Terms of Use.