Jump to content
Sign in to follow this  
LeonMcFly

Trouble With Arcade Stick

Recommended Posts

I recently received an original modded Xbox. I bought a Pelican brand arcade stick to use with the 1000+ arcade games that were included. The trouble I’m having is that the system freaks out when I plug the arcade stick in. Things either freeze or games/emulators don’t load at all. It will work for a little while with the Xbox games loaded on there before freezing and it will work perfectly fine on a non modded Xbox. My only guess is that it’s because it can’t do the same control actions like on a regular controller, so maybe the system gets confused. That’s kind of a wild guess though. Anyone have this problem or any idea on what’s causing it?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By nabilrezki
      Hi,
      I just acquired a 1.0 xbox for 10€ , the guy told me that the console wasn't able to read discs, so i try to put a disc on it, it works but painfully , sometime it does (the loading time takes a long time, and the boot aswell), sometime it just don't (it goes to the ms dash like there is no disc on it), but i decided to hardmod it anyway since i'm not planing to use the dvd drive (already have all of my backups on my other xboxes).
      I first softmoded it with the splinter cell exploit, then i solder the bridges to flash a 256bits EVOX M8+ (F and G) bios with the hexen disc ( i wasn't sure if the 512bits was the one to choose or not), i installed an 250gb HDD from another xbox that was hardmoded aswell, but didn't bother to format it, since it has the same configuration. I made  i backup of the eeprom just in case, installed XBMC4gamers, tried some games and emulators, and so far so good.
      BUT, once i'm in a game and want to go back to my main dash (XBMC4gamers), the console has this weird behavior, the led are blikning green, i can hear the dvd drive spin two times, while the console reboot, it has the microsoft logo, then it restart again to finally come to my main dash. Basically it's take just a little bit longer, so it's not like she didn't reboot at all, but still, it's quite annoying..
      And it only does that with XBMC4gamers, as for Unleashx it's just reboot the console like she normally would.
      I tried to clean the hdd, by removing the xbmc folders to avoid any conflict, but that didn't change anything
      Any ideas why it does that?
      Cheers
    • By Guilleack
      Hello i have a xbox with a almost dead hard drive and a dvd drive that works barely. The previous owner performed a tsop very long ago and that's why i believe that i can boot to hexen without the hard drive, also i saw some solder residue on the pads to unlock the bios protection. (Cleaned the old solder and bridged the points again)
      I have a 1.4 with a Windbond and focus chip, the main problem that i have is that i can't move the options in the Gentoox because my only working controller seems to be a fake controller or at least the original pcb was replaced with a generic one, someone told me on the Xbox-hq forums that i can just drop the bios file on C:/Bios . Can i boot HEXEN and ftp the bios file from there? Also what bios do you recommend? I can't decide beetween evo m8 or iND-BiOS.5004.67
      Thanks for your time.
    • By supercharged_82@yahoo.ca
      Hey I am having an issue with emustation and adding Sega games. I have SNES and NES all setup. When I go and add my Sega ROMs they cut off the last letter of most of my ROMs names. Which then it won't allow me to link my artwork. I can't seem to get around this. Any one else experience this. Could it be my rom set? The games all work as they should just the art work and names being cut off. They are .Md. Designation. I have tried it under both genesis and mega drive

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.