Jump to content
psnap777

Pound Hd Link Cable

Recommended Posts

Hi Guys.  Have any of you tried the Pound HD Link Cable? Here is a link to their site: Please login or register to see this link.

I have watched YouTube reviews from Metal Jesus Rocks and the Immortal John Hancock and they seem to like it. I have heard it has issues with a v1.0 XBOX. Just wondering if you guys have any experience with these cables and if you would recommend them or not. Thanks.

Share this post


Link to post
Share on other sites

The issues were with 1.4/1.5 Xboxes, and Xboxes that have had their shielding removed.

 

I've used it. They're servicable, if you have no way to use component, but if you can, I'd definitely recommend the official Microsoft component cables (or making your own) over the Pound HDMI. Or if you really need HDMI, maybe look into the N64Freak HDMI cable.

Edited by Forlorn Penguin

Share this post


Link to post
Share on other sites

Thanks Forlorn Penguin. I was hoping the Pound cable would work because they are a lot less expensive than the official component cables. I guess I'll try to find an official Microsoft component cable.

Share this post


Link to post
Share on other sites

I bought a Pound HD Link cable that recently became available on Amazon and wanted to you let everyone know my experience with it just in case anyone else was thinking about getting one. I have three xboxes: a v1.0, a v1.1 and a v1.4.  The v1.0 is tsop modded, the v1.1 is softmoded (sharp) and the v1.4 is stock. I felt the cable worked very well with the v1.0 and v1.1 models, but not so well with the v1.4.  With the v1.0 and v1.1, I tested the pound cable on an older 50 inch Panasonic plasma tv and a fairly new 60 inch Vizio tv. I couldn't really see any difference between the pound cable and the monster component cable I use primarily. With the v1.4 there was some interference on the screen that wasn't present with my other two xboxes. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By puntja
      Hey Guys!
      I have 2 Xbox consoles and I try to play Chaos Theory in System Link Mode. Both Xboxes are connected to my router. I can find the other console, I can join a game. I can start the game but as soon as I move one player the game instantly disconnects
      Does anyone know why?
    • By bulkchart32
      i just got my alladin chip w/ pin header and want to install it on a coma 1.0 xbox. can anyone give me a youtube link for the installation? all the vids i have found are for the 1.6 and it is different. what's a DO btw?
    • By corona2222
      I'm getting a shimmer/interference and a line slowly moving vertically on screen, using component cable. What are the thoughts on cause & fix?
      I read the best visual out for xbox original is component, so I ebayed a component cable, plugged in. (Please login or register to see this link. )
      I checked TV supports YPbPr. (manual Please login or register to see this link. )
      I've wiggled the connections, and tried green only - the same shimmer&line. 
      Also the TV says 576i@50hz, I thought component would do 480p?
      The composite cable it came with works ok, but looking to improve on quality.
      Thanks
      Please login or register to see this attachment.

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.