Jump to content
OGXbox.com

[rel] Gta San Super Modded V2 for XBox


Sifaw99
 Share

Recommended Posts

hey ogxbox community. i have finished the gta modded for xbox original. Now its Beta realese.  
(Tested in my PAL stock xbox).

for information,screenshots,download,and more. Visit this siteweb:

https://gtaforums.com/topic/922852-gta-san-andreas-super-modded-for-xbox-original/

List complete of change:

Quote

-Replaced most cars of game. like 80% of car replaced.
-Replaced default hud icons with yoyo2 gtav hq icons.
-Replaced default radar with gtav radar.
-Replaced all roads textures.
-Replaced default light with led xenon light.
-Replaced vegetation texture.
-Replaced default red marker with animated red marker.
-Replace textures of building with better ones.
-Replace loadscreen pictures.
-Replace floppy disk save icon to sd card icon.
-Replaced grass.
-Replaced weapons.
-Improved crash physique.
-changed default main.scm to modded main.scm "Spaceinsteins all in one".
-replaced the all old animation with better animation. inside gta3.img.
-added a tatos on CJ's body.
-Downgrade the default.xbe from version 2.0 to 1.0 to use mods.
-Edited effect.fxd to reduce some particles. 
-Edited surface.dat to improve crash physique. 
-Fixed  map texture. (edited .IDE files). repair a lot of textures like chinagate has now texture. And more..https://imgur.com/a/6q3XrMu 
-edited timecyc.dat to add draw distance. now is x4

And what is new, I create a blogspot for gta sa mods specialy to xbox. So you can find cars mods, weapons,maps and hud, tutorial how to modify the gta sa xbox without using img tool. Feel free to use those mods.
 
please take a look at this site:

https://gtasamods4xbox.blogspot.com/

finnally, if you find some slowdown in fps, or glitch, or bug. Please let me know.

Thanks...

Edited by Sifaw99
  • Like 2
Link to comment
Share on other sites

oh god, watched the screenshots and wanted to play it right here, right now. Gotta clean the MadCatz Wheel and go through woods with 1st person view inside the car. Hope to find time and somebody to help me add some improvements in GTA SA for Xbox with 1ghz and 128mb, if that's possible.

Edited by neighbor
  • Like 1
Link to comment
Share on other sites

13 hours ago, neighbor said:

oh god, watched the screenshots and wanted to play it right here, right now. Gotta clean the MadCatz Wheel and go through woods with 1st person view inside the car. Hope to find time and somebody to help me add some improvements in GTA SA for Xbox with 1ghz and 128mb, if that's possible.

big THX for your support!!!! what  improvements do you mean about gta sa ???

11 hours ago, skideric said:

Thanks for this!

You welcome:!!!!

  • Like 1
Link to comment
Share on other sites

21 hours ago, neighbor said:

maybe increase the draw distance, and add slightly better textures. As I know GTA is one of those games with heavy amount of modding tweaks.

Yes, you're right, with upgraded xbox; the game will use 64 MB of extra RAM and the higher processor will give more and stable FPS. Gta sa uses only 13 MB of streaming memory (loading textures and buildings dffs), the rest being used to load vehicles, animations, peds. so imagine what  a xbox of 128mb ram that can do.

  • Like 1
Link to comment
Share on other sites

15 hours ago, Sifaw99 said:

so imagine what  a xbox of 128mb ram that can do.

I have one with 128mb RAM, also it has CPU upgrade. Maybe you have some time to edit the draw distance and maybe other stuff and upload the file here, or let me know on how to do that. So I can test if it works. Also, my Xbox restarts everytime GTA SA is launched, the Xbox is PAL (but settings are set to NTSC) and if it's turned back to PAL the HD 720P resolution is not available. So what I have in mind is:
- patch GTA SA for 720p output

- edit draw distance and see what is the best result which will balance between performance/visuals

 

Any ideas?

ps. the idea that came a few days ago which possibly will fix the GTA SA reboot loop, is to edit the eeprom settings on Xbox, so it will be "native" NTSC

Edited by neighbor
Link to comment
Share on other sites

19 hours ago, neighbor said:

I have one with 128mb RAM, also it has CPU upgrade. Maybe you have some time to edit the draw distance and maybe other stuff and upload the file here, or let me know on how to do that. So I can test if it works. Also, my Xbox restarts everytime GTA SA is launched, the Xbox is PAL (but settings are set to NTSC) and if it's turned back to PAL the HD 720P resolution is not available. So what I have in mind is:
- patch GTA SA for 720p output

- edit draw distance and see what is the best result which will balance between performance/visuals

 

Any ideas?

ps. the idea that came a few days ago which possibly will fix the GTA SA reboot loop, is to edit the eeprom settings on Xbox, so it will be "native" NTSC

For the reboot of xbox when your run gta sa, the problem is version of default is NTSC  and the xbox is PAL. Here the fix

 https://www.mediafire.com/file/90pq3ram3vm7oha/GTA_San_Andreas_FIX_Pal.rar/file

there is two version of default.xbe inside the archive one output 480i (work ONLY with composite cable), and the other output 480p (work ONLY with component  cable).

Then if you want to use custom draw distace, first your need to patch the fixed default.xbe to use extra ram and new CPU, then use the modded stream.ini

for draw distance i edit three timecyc.dat; x4,x7,x10.

https://www.mediafire.com/file/j54h5df4c32uhxu/Draw_Distance.rar/file 

I hope this will help.

18 hours ago, tempnooby said:

thanks a lot man love you

your welcome man!!!

stream.ini

  • Like 2
Link to comment
Share on other sites

On 12.01.2019 at 1:07 PM, Sifaw99 said:

 

I hope this will help.

 

thank you, now GTA SA boots on my PAL Xbox

did you succeed to patch the xbe for 720p resolution?

because it still displays 480p even after OgXHD patching, the list:

https://docs.google.com/spreadsheets/d/1HpxKGQ6wVTRevUdQ6_4rkuyF_ZugOgc2C4tXnZxBZCk/edit#gid=0

says GTA SA works, but no idea what settings should be used

Edited by neighbor
Link to comment
Share on other sites

On 19/01/2019 at 11:46 PM, neighbor said:

thank you, now GTA SA boots on my PAL Xbox

did you succeed to patch the xbe for 720p resolution?

because it still displays 480p even after OgXHD patching, the list:

https://docs.google.com/spreadsheets/d/1HpxKGQ6wVTRevUdQ6_4rkuyF_ZugOgc2C4tXnZxBZCk/edit#gid=0

says GTA SA works, but no idea what settings should be used

I just saw the video about gta sa in 720p, but it just a upscal from 480p to 720p, not a true 720p. if you want to know what resolution of game output , watch this video : 

 

Edited by Sifaw99
Link to comment
Share on other sites

6 hours ago, Sifaw99 said:

I just saw the video about gta sa in 720p, but it just a upscal from 480p to 720p, not a true 720p. if you want to know what resolution of game output , watch this video : 

yes, I've noticed the same, probably the guy who was editing the list, just picked a video from youtube which has "720p san andreas" in its name and just pasted the link to the list. As I understand everything in that list is information gathered after patching with OgXHD. Did you ever succeed to patch GTA SA for 720p output?

  • Like 1
Link to comment
Share on other sites

18 hours ago, neighbor said:

yes, I've noticed the same, probably the guy who was editing the list, just picked a video from youtube which has "720p san andreas" in its name and just pasted the link to the list. As I understand everything in that list is information gathered after patching with OgXHD. Did you ever succeed to patch GTA SA for 720p output?

I never succes to run gta sa in 720p, i have patched pal version of default.xbe using OgXHD but it run back to 480p.

Link to comment
Share on other sites

3 hours ago, Sifaw99 said:

I never succes to run gta sa in 720p, i have patched pal version of default.xbe using OgXHD but it run back to 480p.

will investigate maybe the changes for GTA 3 720p patch, will work for GTA SA, when Ill have time for that.

That's what Esppiral states on assembler forum:

Gta III Title ID: 5454000e
Xbox Cristal 1.6 64mb.
Auto 720p-
Scan Range Normal.
Xbox dashboard set to 720p.
IMPORTANT,480p disabled on the Xbox Dash, only the 720p option.
Default XHD.be renamed as Default.xbe
Launch the game through XMBc as NTSC-M.

Any other Xbox dashboard configuration, will make the game glitchy ( at least on my console.)
I will test more games with this kind of problem, I am pretty sure they will run fine after
disabling the 480p option on the (original)Xbox Dashboard.

Also GTA III uses 2x MSAA, if we could disable the AA the game would run smother.

 

Edited by neighbor
Link to comment
Share on other sites

So after using the mods you uploaded, can say:
- because of increased  "memory" and "devkit_memory" in the *.ini file - up to 128 - after 100meters game started to stutter very much, even after changing to 64, it was still doing that, so I've changed it back to 38000
memory        64000
devkit_memory    64000

- the draw distance x10 is not really improving anything, at least I can't see any changes, but I know GTA SA and how it usually looks. Will experiment later and maybe find anything interesting.

Edited by neighbor
  • Like 1
Link to comment
Share on other sites

On 23/01/2019 at 1:13 AM, neighbor said:

So after using the mods you uploaded, can say:
- because of increased  "memory" and "devkit_memory" in the *.ini file - up to 128 - after 100meters game started to stutter very much, even after changing to 64, it was still doing that, so I've changed it back to 38000
memory        64000
devkit_memory    64000

- the draw distance x10 is not really improving anything, at least I can't see any changes, but I know GTA SA and how it usually looks. Will experiment later and maybe find anything interesting.

As you konw i don't own a upgrade xbox, so i can't test this mods. 

Link to comment
Share on other sites

2 hours ago, neighbor said:

wow, looks cool. Seems like it only needs 720p resolution to be perfect :D

Yeah, i edited timecyc to make color more clear. as you say its only needs 720p.:D

 

1 hour ago, Infamous Ob said:

Yeah, this is sick. I've been trying to run my modded GTASA on my modded Xbox recently. Overall, I like the things you've done so far.

Thank you for this positive reply.:)

  • Like 1
Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Johny white
      I've got a 1.1 XBOX, made October 2002. I soft modded it using Rocky5 files and then did a TSOP flash with EVO X with F & G. All went well and I next tried to upgrade the HDD from the stock one to a Segate 2TB after upgrading the IDE cable to 80 wire one. I tried the first adapter from the top of the picture you see below but the XBOX didn't see the HDD, so then I tried the second adapter (middle one). The XBOX saw the HDD and HeXen 2018 loaded up from disc, it installed all the dash/app files, then usex XB Partioner to split F & G into equal sizes 926GB (approx if I recall from memory).
      At this point everything was going well and the XBOX would boot fine into dash, I even managed to transfer some games and then started installing XBMC and some emulators, during this the XBOX seemed to freeze and not respond. I rebooted the XBOX but it kept giving me error 7 and sometimes error 9. I tried everything possible including formatting the hard drive on the PC and reconnecting, tried other hard drives but all gave the same result. I then tried the first adapter from the top and the XBOX would boot but won't run anything from the DVD drive.
      Finally I bought the third IDE to SATA adapter, third one at the bottom of the picture and this arrived today This sadly has not changed the outcome and I continued now to get error 7 with all 3 different adapters
      With all this mentioned, the XBOX boots fine into dashboard with the original hard drive and current EVO X BIOS flash. I've also tried all jumper settings on both second and third adapter that has jumper pins.
      At this point I'm lost to what is the problem, could I just possibily ended up with 3 bad Chinese IDE to SATA adapters? I've ordered StarTech.com 40-Pin IDE PATA to SATA Adapter Converter and this will land in the next day or two for me to test.
      Any input on this would be appreciated.
       



    • By ironspyder1734
      As it says in the title my Xbox is flashing orange for quite a while now like about 10 mins or so. Is this normal?
    • By willis
      Does xbox have some sort of pdf reader available or converter to view pdf files? Some way to convert them to be viewed on xbox?

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.