Jump to content



Recommended Posts

Hey everyone,

So, I set up a Raspberry Pi 2 to read eeprom from a 1.1 board.  After more than a few attempts I realized my problems were due to operator error (ie. me).  Nonetheless I got it to work and now I can recover eeprom from some boards I have.  Excellent.  New life skill.

I also have some Seagate and WD drives from original xbox that I attempted to use XboxHDM.  Hooked everything up through USB adapter (see photo).  Here's the issue.  I could identify both drives when I connected them.  However I could not unlock them.  To troubleshoot, I tried a 500GB WD Sata through the same USB adapter and proceeded to setup that drive.  I now have the eeprom transferred and a working softmodded 1.1.  Great!

After more reading, I tried to access the old Seagate and WD drives again.  Now I can't identify the drives through XboxHDM even though I did before.  I've tried multiple times.  Tried every jumper setting on both drives, but no luck. I even tried other versions of XboxHDM.

Quite possibly I just ran out of talent and this is more "operator error".  Does anyone have any suggestions?


Link to comment
Share on other sites

XboxHDM23USB Beta 2 ,3, and 4 all can only access the first 6 drives that Windows recognizes attached to the PC.  

Determine which physical device number Windows has assigned to your Xbox's hard drive (actually all drives attached to your PC).

  1. Start/open a cmd.exe Window.
  2. Keyin the command wmic diskdrive get model,name then press Enter to run it.

Example Output

Model                 Name

Which \\.\PHYSICALDRIVEN is the Xbox hard drive assigned?


If N > 5, you will need to disable / disconnect some of the other drives listed before it.  I had a computer with a multi-device card reader that had 6 PHYSICALDRIVEs assigned to it even though they were not in use.  After disabling several of those drives in Windows Device Manager, the Xbox drive was finally assigned a low enough device ID (less than or equal to 5) that XboxHDM23USB could find it.

Link to comment
Share on other sites

5 hours ago, Gerdo said:

I also have some Seagate and WD drives from original xbox that I attempted to use XboxHDM.  Hooked everything up through USB adapter (see photo).  Here's the issue.  I could identify both drives when I connected them.  However I could not unlock them. 

Unless you have changed the HDDKey on the Xboxes, each one has a different value assigned.  Each time you unlock a different Xbox's hard drive, you will have to copy the correct eeprom.bin file to the root directory where XboxHDM23USB is located on your PC to unlock it.  You cannot use the application to easily unlock multiple Xbox hard drives unless the HDDKey stored in the configuration EEPROM of them all are changed to the same value. (NOTE: Keep a backup copy of each Xbox's original eeprom.bin file.)

Link to comment
Share on other sites


Thanks for the info.

After wasting too much time, I pulled my USB adapter apart (which I typically only use for SATA) and found a botched trace.  With a jumper installed it finally started working again.



Model                                 Name

ST310211 A USB Device   \\.\PHYSICALDRIVE2

This drive was from a previously unmodified Original Xbox.


I'm using  using XboxHDM-2.3-Beta4.  I have my eeprom.bin file from the version 1.1 board loaded into the XboxHDM-2.3-Beta4 directory.



I've installed the Clean C and E files you provided in another thread on XboxHDM.  C content as shown.


I unlocked the drive (Option 6) that doesn't disable the lock.

Started XboxHDM.

All partitions created ok.

Program activated the FatX Partition Table ok.

Program said xbox-partition table found on /dev/hda

Proceeded to format the partitions and build xbox-drive however I got the following errors.



From another thread you provided advice, I checked my Disk Manager.





Regardless, thanks for the help.

Link to comment
Share on other sites

Try the beta 3 release of XboxHDM23USB.  Although, I'm afraid it will do the same thing.

Or, try low-level formatting the hard drive with HDDGuru's HDD LLF Low Level Format Tool then re-run XboxHDM.

Edit: Another thing to try, test the hard drive with Seagate's SeaTools for Windows application to make sure it is working properly. 

SeaTools (Windows) | Seagate (oops, that's an older version  

The latest release is available on this page - Software and Firmware Downloads | Seagate Support US

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Board Life Status

Board startup date: April 23, 2017 12:45:48
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.