Jump to content
OGXbox.com

Aladdin LCD help


dirtykash
 Share

Recommended Posts

I'm planning to use Ryzee119's Aladdin LCD driver but want to use the Xblast modchips I have as they are essentially the same thing.

I'm just looking for some help to identify the LCD connection points for the Xblast as I don't have an Aladdin chip to compare to right now.

 

Looking for points RS, E, Vo and RW on the Xblast

 

 

Capture1.PNG

Capture.PNG

Edited by dirtykash
Link to comment
Share on other sites

6 hours ago, sweetdarkdestiny said:

Why not buying a simple XBlast Lite for 20-25 bucks instead of a Aladdin for ~10 and a Spi2Par for ~10-15 bucks ect.?

 

Btw the XBLast would offer way more as just a display.

I already have a screen and xblast that I made and would like to try get it working with stuff I already have and buying mod chips in the uk isn’t easy these days and eBay are all Chinese sellers which takes a while to get here.

Link to comment
Share on other sites

Ok, so I have this working with an Aladdin modchip now.

Problem is after I enable settings in XBMC4GAMERS the display works fine until reset console then doesn’t display anything ? Even though settings are saved when I go back to them?

Am I missing something simple here? Sorry this is my first dabble with LCD’s 😬

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By rmcelwee
      So, I'm an old man and I can't remember how I flashed this XBox years ago. I have an Aladdin XT Plus2 with Evox +3935 and M8plus_16 fan 40.06 (not sure what size bios that is). I wrote a 2TB image to a drive and get an error telling me to upgrade to LBA48 ver 2. Can someone point me in the right direction. I do have FTP access to the box.
    • By DönerSüssSauer
      Hi guys,
      My problem is that i can connect to ftp via filezilla and i can also download games from my hard drive but if i want to upload games it always says connection to  server lost... and then retries. What i have is a Alladin XT plus  and evolution x. Maybe someone knows the problem.
    • By xboxn00b
      Good afternoon team,
       
      I recently found my OG XBOX which I can't remember the last time I actually powered it on (possibly up to 10 years). I originally bought it to play emulators on back in the day and after watching some youtube clips on how the emulators have kept being updated, thought I would try to get it working again for the lols.
       
      I didn't have any cables anymore so orders some cheap 3rd party ones and a controller off of eBay.
       
      I held my breath and pressed the power button for the first time in forever... and to my surprise it tried to boot up, but then gave me the reboot x 3 and started to display the FRAG.
       
      From what I can tell the chip is an Xecutor Pro 2.x
      I tried various switch combinations but to no avail. I have also disconnected and reseated all the cables I could see, but to no avail.
      I have no way of determining if the HDD has failed (it is IDE and I no longer have any IDE tools/plugs), but if I remove the drive and try to power the xbox on without it, it still follows the same process (reboot x3, then FRAG), so I do not think that is the problem. I can only assume there is something wrong with the bios or the board itself.
       
      My question is: is this salvagable? Am I able to get it working again? I got a friend to mod the xbox back in the day so my technical skills with it are lacking. From the googling I did, apparently a XeniumICE mod chip might be able to bring it back to life, but I am not sure if that is compatible with the mod chip I already have (could they be swapped out?) and I am a noob at best at soldering (and I recall the Xecuter being difficult to solder).
       
      I have attached some photos of the machine and can give more information if needed. The searching on here seems to mention that the bios might need to be reflashed etc but this was one of the chips that needed a printer cable to connect ot it and reflash, so that might be an obsolete option now.
       
      Thanks in advance.


Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.