Jump to content
OGXbox.com

Flash Duox2 Lite


Hnrix
 Share

Recommended Posts

Hi.

I just got an 1.6 Xbox with a DuoX2 Lite modchip.

Can someone tell me how i can identify the bios flashed to the chip?

And can i flash any bios to the chip with Hexen 2017?

I bought the Xbox 10 yrs ago, so i am wondered if there would be any advantages for updating the bios to a newer one than the one thats on there now?

 

 

Link to comment
Share on other sites

9 minutes ago, Hnrix said:

In the Hexen Flash menu it says Unknown. Could you tell me if my installed games disappears if i flash the bios and format the c: drive to install unleash x dash?

IMG_1632.jpg

interesting. 
i wont advise you do anything until we dissect this a little further. at work. will follow-up if noone has later on. 

Link to comment
Share on other sites

Ok. I wont do anything for now.

I am newb to xbox modding, so i only want to flash and reinstall to learn something. But the only thing i figured out for myself is that i have a duox2 lite chip installed :P

Thank you for your help wikati.

  • Like 1
Link to comment
Share on other sites

The BIOS is unknown as there's NO MD5 hash in the config file to ID it (one has to know which BIOS they were working with and keep track of the MD5 hash and add it after making changes to the official BIOS release).  But, as the Kernel is 1.00.5838.01 then it's an M8plus BIOS [update: or M8] (or stock MS BIOS - but as it's running unsigned code can't be so M8plus it must be).  The latest BIOS available for a v1.6 Xbox.  There have not been any newer BIOS releases.

Evox M8plus based on MS 5838 Kernel.  They should have changed the version number a bit but no. 

Update: May be Evox M8 as it too is based on MS kernel 5838.

Only other BIOS that will work on a v1.6 is the X2 5035 16 version (512KB in size). If the Duox2 Lite has a 512k Bank you could try it. It's configuration is read from a file e:\x2config.ini.  Edit the file and you can change flubber and logo colors without needing to reflash the BIOS.

Edited by KaosEngineer
  • Like 1
Link to comment
Share on other sites

so if you're gonna use m8plus (easiest way to get started with your next step)
installing unleash x,
im assuming you dont have an absolute requirement to format C?

I recently changed dash boards and this is what i did
figure out which shortcut on C is booting the dash.
i actually made a mistake on my first shortcut and used hexen to get the ftp back so i could swap back the good shortcut

XBE MAKER http://www.theisozone.com/downloads/xbox/tools/xbe-shortcut-maker/
i put my unleashx folder in root of E: (just a preference)
then I......
IN XBE MAKER
Target Path: your path would be "E:\unleashx\default.xbe

then touch nothing else. if you change other stuff it doesnt work. i dont know why, this program may be outdated.... I DONT KNOW
save the XBE file as the same name as the shortcut in C: thats booting your current dash.....

(reccomended you back up the original shortcut in C: before doing this next step.... just copy your whole C: to a safe spot)

So, for instance. my last one was named evoxdash.xbe
i renamed the new shortcut built with shortcut maker evoxdash.xbe and ftp'd it to the xbox replacing the old one in C:...

the way i understand it is; once you've told the shortcut what to point to (the executable file of unleashx)
then it is able to show the xbox on boot which executable to boot

the old one was pointing to your old dash, and the new one points to unleashx


just be careful about backing things up and dont panic if you make a mistake.
with the chip and the hexen disc you are usually in good shape.

 

  • Like 1
Link to comment
Share on other sites

No need to format C:\ to install UnleashX dashboard.

What size is the evoxdash.xbe file in C:\?

~64KB it's a short cut as Wikati mentioned above.

>1MB it's the actual Evox dashboard executable.

Most modified BIOS's have a boot order for the dashboards they try to run at startup.

Evox M8plus official release boot order:

1. evoxdash.xbe
2. avaDash.xbe
3. nexGen.xbe

If the first doesn't exist the next is tried, IIRC if all fail, xboxdash.xbe (stock MS dashboard) runs.

Edited by KaosEngineer
  • Like 2
Link to comment
Share on other sites

Thanks to the both of you for all your help.

I was lokking at my hdd when i cleaned the xbox earlier today and i dropped it so it died, So i popped in a new (old) 200gb ide drive and did a full hdd rebuild with hexen. Worked perfectly. As for the bios, i came to the conclusion i should not mess with something that is working..

 Again, thank you for your help.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By joublogs
      Hi all,
      I've been out of the scene for ages, but recently saved a few xboxen from clock cap death and bought some aladdin chips to mod them with.
      Also got some SATA to PATA converters, which I haven't gotten working: proper 2 cap version with the master / slave jumper and an 80-pin cable, seems to cause a conflict with the DVD drive in every config I can think of - OGXBOX DVD shows "linux" and then DVD keep seeking back and forth forever. I thought I'd update the bios to see if that helped.
      I've gone through as many threads related to this topic as I can e.g. https://www.ogxbox.com/forums/index.php?/topic/3866-aladdin-flash-not-writable/ and tried the suggested solutions, but I am unable to flash a new bios to my modchip.
      I' going to try and provide as much information as possible as well as the things I've tried, in the hope that someone can assist.
      Top side of the board (this is one I haven't installed, installed one is identical with BT and D0 connected correctly, chip boots fine):

      Bottom side of the board:

      Stuck on erasing (and bios ID):

      Bios hashes:

       
      I'm using OGXBOX Installer 2021 DVD.
      Xbox is reported as 1.4.
      So I've tried the following:
      xflash for sst49fl020: seems to be able to dump the flash, but fails on flash with an "Flash check id failed, are you sure you have flash enabled?" XBlast 0.56: select evoxm8_67. when I press both triggers, start and white, the xbox reboots (wtf?) OGXBOX menu flash: gets stuck on erase as per the image above Tried the short and long power button presses, doesn't seem to change anything. "Chip: Protected" appears on the OGXBOX screen Any suggestions? I do have a minipro programmer somewhere with (I think) the correct adapter so could try that as last resort.
      Thanks
      -j
    • By Vendest
      Hi,
       
      I recently damaged my xbox while installing MakeMHz HDMI, I shorted the video encoder chip and killed the motherboard.
      I swapped the motherboard since then with a 1.4/1.5 (FOCUS), salvaged the xblast lite modchip but the xbox does not boot once D0 is wired. Xbox does auto on/off twice then turns on with fast flashing light. This is the same pattern I usually get when I have a short during 128mb ram install. Also I thoroughly followed the instructions https://bitbucket.org/psyko_chewbacca/lpcmod_os/wiki/xblast_lite_manual/Installation
      Long story short, the on board tsop is flashed with xblast OS and I can see the available banks of the modchip when D0 is not connected.
      Is there way to test the modchip separately and eventually fix it? it is the best modchip I ever used till now and would hope to make it work again.
       
      Thanks,
    • By KpCollins
      Hello, I'm looking to Recover a bad Tsop Flash on a 1.4 board. I have an Aladdin XT on the way which will be my 3rd chip install. Been looking around and have a few questions.
       
      First, I understand being able to disconnect the D0 wire once booted with the chip would give me the option to tsop using Xblastos. My question comes from something else I'm looking into
       
      Eeprom recovery using a raspberry Pi, It accesses the I2C connection and pulls the Eeprom. Could I use the Pi and an LPC pinheader to reflash the original bios via tsop in a similar method?

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.