Jump to content

Power Suppy Caps


Recommended Posts

As mentioned the power supply caps don't seem to fail as often as the mainboard ones

I have seen a couple of version 1.6 PSU with bulging caps but not any of the 1.0 - 1.4 PSU's

There is no harm in changing them if you want.

 

Cheers

SS Dave


Soft modding is like masturbating, It gets the job done but it's nothing like the real thing.

Link to post
Share on other sites
  • 1 month later...

I have a 1.6 Xbox that I picked up at a Salvo's a couple of years ago for cheap, I soft modded it at the time of getting it then put it away in the cupboard up until today.  Seeing I've decided I'd start tinkering with Xbox's again I took the 1.6 out and fired it up today as I was thinking of putting a 2TB Drive it in like I've just done to one of my other boxes.

Well, as soon as I fired it up what appeared to be a small cloud of either dust or smoke came out of the power supply side of the box.  Nothing major but enough to get me worried, it didn't have the magic smoke smell of burning electronics but there was a bit of a smell, maybe it was dust but it seemed strange as I've never had it happen before on other Xbox's.

I haven't popped it open yet for a look as I can't find my screw driver kit with the right bits, lost it the other day somewhere around the house :)

Is there a common thing on a 1.6 Xbox that'd cause this symptom? It's a clear case crystal special edition 1.6 box.  

Xbox_Crystal_Edition.thumb.jpg.930c1e3fe89219d40cb09689d002b60f.jpg

 

Link to post
Share on other sites
  • 2 months later...
On 11/4/2020 at 1:18 AM, phrunt said:

I have a 1.6 Xbox that I picked up at a Salvo's a couple of years ago for cheap, I soft modded it at the time of getting it then put it away in the cupboard up until today.  Seeing I've decided I'd start tinkering with Xbox's again I took the 1.6 out and fired it up today as I was thinking of putting a 2TB Drive it in like I've just done to one of my other boxes.

Well, as soon as I fired it up what appeared to be a small cloud of either dust or smoke came out of the power supply side of the box.  Nothing major but enough to get me worried, it didn't have the magic smoke smell of burning electronics but there was a bit of a smell, maybe it was dust but it seemed strange as I've never had it happen before on other Xbox's.

I haven't popped it open yet for a look as I can't find my screw driver kit with the right bits, lost it the other day somewhere around the house :)

Is there a common thing on a 1.6 Xbox that'd cause this symptom? It's a clear case crystal special edition 1.6 box.  

Xbox_Crystal_Edition.thumb.jpg.930c1e3fe89219d40cb09689d002b60f.jpg

 

 

did u ever get this fixed?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By pumphill
      Hello all, I am new to xbox modding.  I am just trying to learn more about the software side of modding this console.  I have experience modding just about every other console and am now getting into the original xbox.  I've installed an openxenium mod chip, and have ordered a 2TB hdd, ide to sata converter, and 80 wire ribbon cable.  I'm just trying to get a feel for what the current methods people are using as a lot of information is outdated.  Thanks for reading this.
    • By teamxbox
      I am repairing xbox 1.4 for a friend. His box is having power supply issue. There is not enough volt to run the hard drive. I used external 12v/ 5v source to power the hard drive and the system boots up fine. The dvd disk drive is also working fine as it is connected to the xbox power supply. I took the xbox power supply out and didn't notice any bad caps or bad solder joints. With everything connected and powered up ,except for the power to the hard drive I get the following voltage values.

      Orange = 3.3V, Blue = 3.3V, Brown =3.3V, Red = 4.48V, and Yellow = 10.5V.
      I tried adjust the pot and that is max i can get for red and yellow wires. Which caps do I need replace for these two voltages ? or is there something else i can check?
       
      Thanks.
    • By Paolo
      I've 3 xbox with the soldering pads are destroyed there is just the hole...so there is a chance to solder the leg of the caps to another place? Thanks...

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.