Jump to content
Sign in to follow this  
Swirlygiver

XBmc4gamers Locked Up After Downloader Update

Recommended Posts

I updated urldownloader last night, and I don’t know if it hung up on the install or what, but now I’m locked up.  When I boot up, I get the same message saying it was updated, with an OK button.  I click the button and it goes away but I’m locked up.  Not sure what to do.  

Share this post


Link to post
Share on other sites

When it boots and you get the ok dialog, press A and it will hang, (it’s not hung it’s the uilock) FTP in and send me the xbmc.log from the system folder please. When I get that I will tell you how to fix it 😂

Share this post


Link to post
Share on other sites

I had tried that.  It wouldn’t even let me FTP in.  I ended up putting in a HEXEN disc, and going back to another dash to FTP in.  Then I did a fresh install of XBMC4GAMERS.  I’m running again, but not sure what happened.  
 

i still need to figure out if this is the same version of XBMC4gamers though.  I was running the version that you had told me about, when you made artwork installer an Application. I’m not sure if the copy I had saved is the same one or the one before that.  How do I find that out?

And is there a config file or something I can backup, when everything is set the way I like, so if I need to do a fresh install again I can save my settings?

Share this post


Link to post
Share on other sites

Did you remove the other install? as the logs will still be there if you haven’t. 
 

also P:\guisettings.xml

 

i will make a script to backup your install so it’s easy to backup/restore settings. 

Share this post


Link to post
Share on other sites

I already removed it.  This is the previous install version though, it’s 1.2.122. I haven’t been on your github since.  I’ll have go to find it.  I still have artwork installer as an app, but I don’t know if I should use it in this version.

Share this post


Link to post
Share on other sites

Please forgive my dumb questions, but I’m on github now, and it appears that there’s only one link for a prebuilt version.  What version is that?   When I downloaded the one I was using, it wasn’t the current stable release.   

Share this post


Link to post
Share on other sites

😕 you’re the third person that has had this issue and posted about it, but before I can get any logs to see why. It’s been reinstalled and works fine. 
 

The one on hexen I don’t know what version it is, but you can update via the dashboard to the latest stable or latest test build. 
 

If you do go to the test build again and it gives you an issue with the downloader, I need the logs or I can’t fix it. I have zero issues at my end as I test the shite out of it before I upload it. (So it maybe something that’s left over from something that causes it, but without the log I won’t know)

 

also you can use the artwork installer app on any version or dashboard for that matter as it’s just an app now. 

Share this post


Link to post
Share on other sites

I’m sorry man.  I didn’t think about that. Patience isn’t my strong suit.  I kinda freaked when I couldn’t ftp in.   It wouldn’t reset or anything. 

Share this post


Link to post
Share on other sites

I’ve tried to ask in another three, with no success: if I wanted to put my games into subdirectories to cut down on load time and search time, how do I do it?

Share this post


Link to post
Share on other sites

Enable fast game parsing in the Programs > Other settings and you won’t need to worry about loading/seeking times. 
 

if you want sub directories you will need to add new sources with the folders you want added to said source. (You can't have fast game parsing enabled for this)

 

also if you ever can’t FTP or its crashing to the point you can’t do anything. Hold White+Y on boot and it will go into a recovery menu and give you FTP access. 

Share this post


Link to post
Share on other sites

I can confirm this issue with the latest update when applied through the downloader. Fortunately the FTP still works, i was able to recover by deleting the App (as i was booting into xbmc4gamers through a shortcut xbe) and replacing it with the latest Version from Rockys GitHub. So it only seems to have issues with the Version from the downloader.

Share this post


Link to post
Share on other sites

This happened to me too. I believe it happened because I updated the URL Downloader while running an older beta, something like 1.3.11? I always do it in this order, URL Downloader, then new beta. But perhaps I should do it the other way around.

It was definitely the system/scripts/autoexec.py script that locked the system up (no IGR, no FTP, etc). Deleting it prevented further lock-ups (but I had permanently broken URL Downloader).

After a clean install of latest stable, I downloaded the latest beta and updating the URL downloader worked fine. It was completely redesigned though (very nice!).

I'll try later if I can reproduce the issue with my broken copy of XBMC4Gamers, I have a backup of autoexec.py so if I didn't mess around too much, maybe.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By mmmonkey
      I’m still getting to grips with using the og Xbox in 2020, well setting it up.
      I’ve got a USB powered WiFi bridge that plugs into the Ethernet port, and is powered directly from the console.
      But the console starts up quicker than the the bridge can connect.
      Is there an option I’m missing that will force XBMC4Gamers to check the network again and then it’ll get an IP address?
      Ta
      Pete
    • By Yanimo
      So I was just going to format my hdd for other use then suddenly BAM! xboxhdm hotswapped the drive wiped partition forgot to unlock what now.
    • By janders
      I would like to remove the play count in XBMC4Gamers. If it's possible, info please. 

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.