Jump to content
Sign in to follow this  
Keith01

Issues With XBox 1.0

Recommended Posts

19 minutes ago, Keith01 said:

i,ll get a pic uploaded of what it shows when booting up into the Flash Bios screen which for this one is the 3.0.0

I was going to ask if it is 3.0.0.  As I've only seen versions 3.0.1 and 3.0.3.  

I was hoping there would be an easy way to make a backup of the backup BIOS before updating/flashing over it.  There doesn't seem to be.  At least, as far as I've checked so far. :(

Nothing in the X3CL and FlashBIOS menus or on the FlashBIOS Network flashing web page (which on my FlashBIOS 3.0.1 still says I've connected to the web page  of FlashBIOS 3.0.0). 

 

 

Share this post


Link to post
Share on other sites
4 minutes ago, Keith01 said:

When i took these pics 1 and 2 switch's are On, 3 4 5 Off, even if 1 and 2 are off with the rest it boots the same. setting switch's differently it won't even boot at all. Go figure

It should also boot with the switches set for Bank 12: on on on off [top to bottom bank select switches]

The position of the Bottom switch - flash protection doesn't matter, on or off, unless you are trying to flash a BIOS to the modchip.

Share this post


Link to post
Share on other sites

Try all 4 of the 512KB bank selection settings I posted earlier. Which of these 4 settings does the console boot and on which does it FRAG?

Update: Added a copy of those 4 512KB bank selection settings:

512k Bank
Bank 12: on on on off
Bank 34: off on on off
Bank 56: on off on off
Bank 78: off off on off

Share this post


Link to post
Share on other sites

Here's a small run down, Switch 1 On, 2 3 4 5 Off, Boots to the Flash Bios screen,  1 and 2 On, boots to UnleashX dash, 1 2 3 On, same as 1 and 2 On, 1 2 3 4 On, it does not like that, won't boot, panel lights go crazy (Got a sorta cute light setup on my panel) with blank screen. Just a bit of a run down there

Share this post


Link to post
Share on other sites

Yeah, 1-4 on will try to boot from the first 256KB bank.  However, the X2 5035 BIOS is a 512KB BIOS. It needs all 512KB, not just the first 256KB of it, to run.

I was wondering if any other 512KB bank boots.  The previous owner may have flashed a 1MB (2x512KB) file to the first 1MB bank of the modchip.  So bank12 and bank34 may both work.  Or, maybe they only flashed a single 512KB BIOS to the chip.  

Please, try all of the 512KB bank selections and report your findings.

Share this post


Link to post
Share on other sites
12 minutes ago, Keith01 said:

Switch 1 On, 2 3 4 5 Off, Boots to the Flash Bios screen

That's the only bank selection configuration not listed in the bank selection settings.

It must force loading the backup BIOS.

Share this post


Link to post
Share on other sites

Tried your suggestion on Bank switch's

Bank 12 Booted to Dash

Band 34 Same to Dash

 Bank 56 Flash Bios screen

 Bank 78 Same,  Flash Bios screen

Share this post


Link to post
Share on other sites

On Off Off Off for me booted bank 8 even though that's listed as switch settings off off off on.  Strange, I need to flash different BIOSes to all the banks and try every switch setting to double check the bank selection info I'd posted.

Update: However, it may be booting bank 8 with two different switch settings.  You have the FlashBIOS in your bank 8.  Sure would be nice if one could download the BIOS stored in a bank.  I'd like to compare the FlashBIOS 3.0.0 binary file to the other two releases.

 

Share this post


Link to post
Share on other sites

I'd suggest flashing the X3 3294 version of the BIOS with the switches set to On On Off Off Off from top to bottom. 

Boot into the FlashBIOS 3.0.0 by powering on the console with both the Power and Eject buttons.  The logo should look purplish (as the red and blue LEDs two above and two beside the logo are turned on.

Enable network flashing and use the web address listed to connect to the Xbox with your web browser.  Follow the onscreen instructions to select and flash the extracted  X3 BIOS's dot bin file (x3 3294.bin).

Share this post


Link to post
Share on other sites
1 hour ago, Keith01 said:

Tried your suggestion on Bank switch's

Bank 12 Booted to Dash

Band 34 Same to Dash

 Bank 56 Flash Bios screen

 Bank 78 Same,  Flash Bios screen

so the first two 512KB banks have X2 5035 and the last two 512KB banks have FlashBIOS 3.0.0.  Setting the switches to boot from 256KB banks 5-8 in the switch table should work too.  FlashBIOS is a 256KB BIOS.  And, booting a 512KB bank just has it stored 2 times in a row.  Selecting the 1MB Bank 5678 should also boot to FlashBIOS.

Share this post


Link to post
Share on other sites

Did as you suggested with Bank switchs set , entered Flash Bios, enabled network. pic is of as far as it would let me go. Been way to many years since i did any of this one.

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

That's as far as you get on the Xbox side of things.  

Now, you have to connect to that IP address with your computer's web browser.

In the address bar type in 192.168.1.114, the FlashBIOS web page should appear:

1074477513_NetworkFlashingWebPage.jpg.7367a0c35f061a198485098145d7fbe2.jpg

Click on Choose File and browse to the x3 3294.bin file on your computer.  Double-click on it. The No file chosen text will change to x3 3294.bin. Next, click on Upload and Flash.

 

Unimportant ramblings below here

Note: The top paragraph of instructions is a bit wrong as the X3 modchip. It's BIOS is 1MB not 512KB.  Most X2 modchips have 512KB banks some like the X2pro had 256KB or 512KB available in it's 1MB flash.  The X3 has 2MB's of flash that can be used for 8 - 256KB, 4 - 512KB, 2 - 1MB or 1 - 2MB bank(s).  You can't reuse an already occupied 256KB bank for a different sized BIOS.

Update: From the (For X2 mods... paren'd text, FlashBIOS flashes from the start of the selected 1MB bank of their modchips.  I'm not sure what would happen on an X2 modchip if you had the switches set to bank 2.  I think it should flash from the start of the second bank - 512KB into the 1MB flash chip but it may not.  Not that any of that matters. You have an X3 modchip.

Share this post


Link to post
Share on other sites

Update, i did exactly as you had said to do step for step, Xbox is now been corrected with the Bios and got into the X3 Config Live. Thanks for your help on getting this part straightened out. Now i can move on the it's next bugs which are not as important as getting the Bios corrected

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By HDShadow
      As I mentioned in another thread here I recently bought a 'for parts' Xbox which is giving error 16 but the seller also included another retail HDD, almost certainly not softmodded, which is giving error 6.
      Pretty sure it did not come from the same Xbox so obviously locked with an unknown eeprom on another Xbox which again, obviously, I do not have. Not likely being softmodded means no master password use possible either.
      I've looked into methods of unlocking it and either here or on another forum somebody mentioned there are Windows programs that can do this. I'm not bothered about the content just interested in finding out if it can be unlocked preferably, via a USB connection.
      Any recommendations/suggestions welcome.  
    • By jhark
      Will this work? or is the 50/60hz going to still be an issue?
      Please login or register to see this link.
    • By ttsgeb
      Decided I would tear down my dev kit because there was a rattling noise inside of it and I wanted to see its guts.  The rattling turned out to be the GPU fan, and I decided I should film its guts for everyone to see.  Now if you don't have one, or don't want to open the one you've got, you can see inside, too!  Pictures will come if I ever get a decent camera.

      If anyone has a Raptor card I can pair with it, please send me a PM.  I don't actually know anything about developing games for the xbox, but I'd like to have a full kit in case I ever do start developing.  I also might be willing to sell this to someone that wants to use it for its intended purpose.  It's pretty worthless as a collectors item because it has no code on it, has a prominent cosmetic defect, and has been opened.

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.