Jump to content
Sign in to follow this  
iRuinLunches

Aussiechip Dual Mod and Cheapmod Build Files

Recommended Posts

Hey all this is my first post on this forum. Thought I should share the schematics for the old AussieChip Dual Mod and Cheapmod mod chips.
From what I understand this company went under in 2003 when the Australian government started to try and outlaw mod chips; the same time when many other governments were trying to do the same. AussieChip decided to give back to the community and release the build entirely for free.

The files are for an old program called Protel though it is now called Altium Designer. Altium is very very VERY expensive (7k+ a year) though they have a free trial if you want to take a gander at the design files.

I was trying to convert it for use in KiCad and Eagle though I'm not very familiar with these programs yet and the implications exports cause on schematic data.

I started to do some research into seeing if any major developers such as Team Exodus released their schematics. (I really wish they would) That's how I came across this.

Do you have schematics for mod chips? I encourage you to share them. In today's age we should be open sourcing old technology such as this instead of letting it die into a forgotten history.

Happy modding, nerds.

-iRuinLunches


The contents of the zip:

image.png.927b82c4f2ca8b769704297b50be23ed.png

 

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By johnyept
      I'm trying all methods of XBOX modding: softmodding with exploit is learned and understood, later steps will be TSOP (v1.2) and modchip (v1.2/v1.6) but for now I decided to replace the original 10GB Seagate HDD with a 80GB 7200rpm Seagate HDD because the original is reporting below 50% health with Acronis Drive Monitor. I went with XBOXHDM 2.2a because I already had a FAT32 flash drive for booting ISOs, so I just extracted the content, added the entries from menu.lst to my menu.lst,  copied eeprom.bin to \eeprom folder and extracted v5960 dashboard files from Clean_C_and_E_Files_for_Xbox.7z to \hdm\C.
       
      It couldn't be simpler: Boot Slax, run xboxhd2 from command window (phase 2), run xboxhdm to create C/E/F partitions and autocopy the dashboard, lock the HDD with xboxhd2 again, insert HDD in the XBOX. All was OK until I booted the XBOX and was greeted with error 21. A quick Google search indicated it might be related to missing dashboard files, so I checked the C partition content with a quick hotswap, Windows XP and Xplorer360 beta6, and discovered that the files were copied in the 8.3 DOS naming scheme. For example, the "xboxdashdata.185ead00" folder was copied as "xboxda~1.185", the "XBox Book.xtf" file was copied as "xboxbo~1.xtf" and so on. Deleting all files and dropping them into Xplorer360 again solved the naming problem and the XBOX booted correctly.
       
      (EDIT: for some strange reason, partition E had duplicated folders: tdata, udata, TDATA and UDATA)
       
      So the question is: Why did Slax/QEMU copied the files in 8.3 format?
    • By abazz009
      Hey everyone, Iv been been dealing with my modchip LCD basicly spazzing/glitching/messing up displaying its content all wrong since always.here are some picture examples. the XBMC im using is 3.5 beta 
      .Please login or register to see this attachment.
      Please login or register to see this attachment.
      Please login or register to see this attachment.
      now this doesnt happen at first, it also wont occur in the smarttXX OS,nor will it occur if im browsing through the menus of XBMC, it takes about 2-5 minutes of idle beofore it starts. then it progressivly gets worse, eventually it just blanks out completely. which for it to work again i either need to restart XBMC or turn it off and on in the settings before it just does it again..

      now i've troubleshooted this issue quite a bit on multiple seperate occasions, i can confirm its not just a faulty modchip, unless by some crazy coincidence, both my chips are faulty, they are both smartXX chips one is a V2 the other is an LT OPX, 
      Ive also ruled out it being the LCD screen,iv hooked both chips up to different LCD's, im gonna rule out a faulty Xbox motherboard aswell considering both modchips are installed on different boards, both are v1.4's not sure that really matters though, and the soldering is all good, 
      Iv updated both Chips to the latest smarttXX OS which happens to be 3403, i came from a 33somthing this was actually my most recent attemp at fixing this issue. no luck,

      Now i remember reading that XBMC at some point stopped caring about the LCD support (they didnt remove it but possibly broke it, and never fixed it), obviously it was pretty niche then, making it even more niche now, but i know people out there have this mod, and hopefully at least a few of you are here..

      so this set me on a journey, to modify the "lcd.xlm" file, now i played around with it, basicly just removing/duplicating code into different areas, removing lines ect,i really didnt have any luck in making it not glitch out, there doesnt seem to be a way to leave lines blank, i copied the whole "navigation" layout into all the others, it seems to make it glitch out a little less which is somewhat of an improvement but at the same time not really because if left idle for to long it just crashes and displays nothing. 

      it seems like "unknown" and XBMC are fightting for the first 2 lines of the LCD when idle, or maybe XBMC is fighting with itself for the first 2 lines, it switchs back and fourth from what the the LCD.XLM wants it to display and what "Unknown" wants it to display. for example.

      XBMC wants
      GPU TEMP-CPU TEMP
      FREE RAM-HDD TEMP

      Unkown wants
      GPU TEMP-CPU TEMP- FAN SPEED
      FREE RAM-HDD TEMP  (though this is completely unreadable its usually just  "[.........]"

      right as XBMC boots it displays the "Unknown"(see picture below)  before the screen fills up normally , then the 2 lines fight, back and fourth, being readable before they start to jumble
      Please login or register to see this attachment.

       to help rule out the modchip fighting with the XBMC over what the LCD displays, i turn off the LCD in the SmarttXX OS (which should disable it alltogether) but it still comes on after it boots into XBMC (if i have it enabled), If i turn it off in XBMC and leave it on in the smarttXX OS, after a it boots into XBMC i get
      GPU TEMP-CPU TEMP- FAN SPEED
      Please login or register to see this attachment.
      which is how i leave it because at least it works properly, but its nice have the whole screen full rather then just 1 line
      it will also do this while playing games. whether the LCD is off or on in either location. for what thats worth.

      I decided to dig into the source code of XBMC, but since i know nothing about C++ or python, i didnt find anything that pointed twords LCD but im not to sure what im looking at to begin with, but i did find "NoseFartXBMC" which is an app of some kind

      anyways has anyone had any trouble with their modchip LCD's? if so did you ever fix it? if not what are you using? (chip,Dash,Dash version)  any thoughts or ideas would be much appreciated, 
       
    • By vacatedboat
      This is my xbox 1.4v. I have 3 other boxes. I got very cavalier and loaded up truhexen 2019 disc to update the modchip bios. Of course I flashed the wrong bios. What i think may of been m8 for v1.6 boxes. It now turns on to ms dashboard but wont recognise the hexen disc anymore. As the chip is soldered to modchip guessing the hotswap or external re programming are out of the question. Is there any way to salvage this modchip? Is my only option is too remove modchip and softmod/tsop flash the xbox?
      Also to remove the modchip is it just the bt and do wires that need to be desoldered. Thanks for all help
      Please login or register to see this attachment.

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.