Jump to content

Surreal64 Problems, Please Help a Noob Out.


Recommended Posts

So I have finally gotten a grasp of everything but the N64 emulator.  I downloaded EWJ ROM pack, copied over the surreal64 folder into the emulators/n64 folder, copied some ROMs over in the roms/n64 folder.  It scans and actually shows my files scanned but always comes up with a script error saying it cannot make a list.  What am I doing wrong exactly?  I've read how frustrated rocky5 is over people asking about this same issue but I followed his instructions as he laid them out on a Reddit thread.  I'm stumped.  Any help is greatly appreciated.  Thanks. 

Link to post
Share on other sites

Just download the emulator from the downloader. It’s the latest version and it works. (Tested it with a good few games)

Your roms can stay where they are. Just scan in N64 now. 

 

Alternatively send me the log file from the system folder after getting the error and I can tell you exactly why it’s failing. (Did you copy the media folder that’s inside the surreal folder over as it’s needed for the artwork and synopsis info)

Edited by Rocky5
Link to post
Share on other sites
7 hours ago, Rocky5 said:

Just download the emulator from the downloader. It’s the latest version and it works. (Tested it with a good few games)

Your roms can stay where they are. Just scan in N64 now. 

 

Alternatively send me the log file from the system folder after getting the error and I can tell you exactly why it’s failing. (Did you copy the media folder that’s inside the surreal folder over as it’s needed for the artwork and synopsis info)

I just downloaded the emulator from the downloader.  I copied over the media file, but maybe this is where I am confused?  The media folder is within the n64 emulator folder.  Do I need to move that folder somewhere else?

 

Here is the log error.

 

20:41:08 M: 30416896   ERROR: msvcrt.dll: dll_fstati64 called, TODO: add 'int64 <-> long' type checking
20:41:08 M: 30756864   ERROR: Error Type: <type 'exceptions.UnboundLocalError'>
20:41:08 M: 30756864   ERROR: Error Contents: local variable 'N64_Rom_Name' referenced before assignment
20:41:08 M: 30756864   ERROR: Traceback (most recent call last):
                                              File "Q:\.emustation\scripts\create_rom_lists.py", line 1170, in <module>
                                                Main_Code()
                                              File "Q:\.emustation\scripts\create_rom_lists.py", line 911, in Main_Code
                                                pDialog.update((CountList * 100) / len(os.listdir( Roms_Folder )),'Creating [UPPERCASE]' + Emu_Name + '[/UPPERCASE] Rom list and copying media files',N64_Rom_Name,'This can take some time, please be patient.' )
                                            UnboundLocalError: local variable 'N64_Rom_Name' referenced before assignment
 

Link to post
Share on other sites
  • 4 weeks later...
  • 4 weeks later...

i dont know what i do wrong

I downloaded the latest surreal64 emulator. I FTP'd the extracted folder directly to the emustation/emulator/n64 onto the xbox + roms on the emustation/roms/n64. i did the same for sega genesis and snes. it works fine but why is it not working for N64?? I always get the message "Surreal.ini is corrupt or not formatted correctly. PLease recopy/download Earthworms Jim ..."  

 

what do i do wrong where is the issue??

Link to post
Share on other sites
  • 1 month later...
  • 1 month later...
  • 3 months later...

Hi, 
I am facing similar issue with Surreal64 and XMBC Emustation. When trying to update N64 in Emustation I receive message "Error script failed! : create_rom_lists.py". 

  • I have XBMC Emustation version 1.2.123
  • I downloaded Surreal64 using the Emustation Downloader. 
  • I FTP'd two roms in zip format to emustation\roms\n64\
  • I can launch Surreal64 using the File Explorer and choosing Surreal64 emulator folder and default.xbe. I see both of those two game roms and can play both. 

What check my setup is failing and how could I get N64 updated to Emustation? :)

Link to post
Share on other sites
  • 1 month later...

As far as I know, you should use Earthworm James Rom Pack. But I have uploaded my own romset and ran into the same problem. To generate the list with the script you have to modify it a little.

Open create_rom_lists.py and insert a new line at position 911 before "pDialog.update(..." :

N64_Rom_Name = Rom_Name_noext

Now at least the script runs thru and generates the gamelist with your romnames from the filenames.

create_rom_lists.py

Edited by MortalCrow
  • Like 2
Link to post
Share on other sites
  • 2 weeks later...
On 23/2/2020 at 7:07, MortalCrow said:

Hasta donde yo sé, deberías usar Earthworm James Rom Pack. Pero he subido mi propio romset y me encontré con el mismo problema. Para generar la lista con el script, debe modificarlo un poco.

Abra create_rom_lists.py e inserte una nueva línea en la posición 911 antes de "pDialog.update (...":


Ahora al menos el script se ejecuta y genera la lista de juegos con sus nombres de rom a partir de los nombres de archivo.

create_rom_lists.py Obteniendo 76.12 kB · 3 downloads

Gracias gracias mister

Link to post
Share on other sites
  • 1 month later...
1 hour ago, crushingyourhead said:

Yep, delete your old Surreal, kill the game save, then transfer the entire lot over. If you leave out the preview videos, it will take about half the time.

Okay. so just delete everything sureal and transfer the whole 5.gb EWJ file over? I just don't want to mess this up. Thanks

Link to post
Share on other sites

I have a different issue. I have installed the Earthworm James 212 version of Surreal and FTPd over a number of roms. Using Emustation I am able to properly update the carousel and generate the rom list. However, upon running ANY rom it just black screen's and I have to restart the XBox. I have read from some this is a problem with the bios on the XBox being too old. I have a 1.0 XBox with 4034 kernel, but the latest version of Dash I believe. How can I fix this issue? I cannot find a way to update the bios itself without soldering pins in the XBox. I would think if this was a common issue there would be a disclaimer about it that is just doesn't work with old kernels. Any help would be appreciated.

 

Edited by Brent F
Link to post
Share on other sites
  • 2 weeks later...

Hello everybody.
Sorry for my English.
Fantastic Rocky5 work, original reborn xbox, I love it.
I loaded the roms with boxart and video, I updated the system and loaded Artworch.
I still have 2 problems:
1) Rom N64 from the list error, first I solved by modifying "create_rom_lists.py" as indicated in a post in the forum, then I updated to the latest version of EMUSTATION and I can no longer find the folder to replace "create_rom_lists. py "? Can you tell me where it is?
2) ROM information is not displayed, I checked in the folder E: / Players / XBMC / emustation / synopsis /.../ are there but they do not load them; while videos and boxart are displayed.
Thanks again for the help.

Alleyway.txt

Link to post
Share on other sites
  • 3 months later...
On 2/23/2020 at 3:07 PM, MortalCrow said:

As far as I know, you should use Earthworm James Rom Pack. But I have uploaded my own romset and ran into the same problem. To generate the list with the script you have to modify it a little.

Open create_rom_lists.py and insert a new line at position 911 before "pDialog.update(..." :


N64_Rom_Name = Rom_Name_noext

Now at least the script runs thru and generates the gamelist with your romnames from the filenames.

create_rom_lists.py 76.12 kB · 50 downloads

Thank you! This makes so much sense

Link to post
Share on other sites
  • 1 month later...

I'm having a weird issue:

Downloaded the emulator and supplied my own EWJ 212 roms. Scanned them in. The list works great and the emulator starts with my game. But its not using the EWJ settings. For instance, Mario Kart 64 isn't playing in HLE and running at 720p.  Looks like just the stock core in 480p.  Do I need to copy over my Surreal settings into Emustation to get the roms to run on the EWJ settings? Or is this dashboard stuck at stock Surreal64 settings?

Thanks

Link to post
Share on other sites
24 minutes ago, crushingyourhead said:

I'm having a weird issue:

Downloaded the emulator and supplied my own EWJ 212 roms. Scanned them in. The list works great and the emulator starts with my game. But its not using the EWJ settings. For instance, Mario Kart 64 isn't playing in HLE and running at 720p.  Looks like just the stock core in 480p.  Do I need to copy over my Surreal settings into Emustation to get the roms to run on the EWJ settings? Or is this dashboard stuck at stock Surreal64 settings?

Thanks

Coping the Surreal.ini from EWJ 212 pack to the n64 emulator folder in Emustation fixed this issue. You can also still change the individual rom settings in Emustation Surreal to toggle items like '720p on' if needed. And select your core. But its alot of work for 212 games...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Tingle64
      Hello, I am stuck in a pickle and hope someone can help.
      I just TSOP flashed in my Xbox and it is now stuck in a boot loop. The Xbox logo appears along with the Microsoft logo and then the system resets to do it again. I first installed the rocky 5 softmod, used the bios checker disc to make sure it was ready to flash (it displayed "TSOP?") and then used the TSOP flash mode of the extras disc to flash the system. everything went like normal and then after the BIOS was flashed and the system rebooted it just kept rebooting itself. It is at the 3:56 mark in the attached video
      . I'm new at this and out of my element here, please help. 
    • By C64MidRezzie
      I have tried to copy an iso from my windows 10 pc using both Filezilla and FlashFXP but to no avail.  It stops during the transer.
      On my computer it shows a single iso file but in both filezilla and flahsfxp it shows the samefile name with 2 isos.  I always go with the larger one wrhich is over 7.2gb but once it reaches 4gb exactly it fails to transfer the file - what is going on?  It's years since I transferred a single iso - any help greatly appreciated.
    • By Joelma
      Hello,
      I am new to Xbox. I recently bought a Xbox v.1.6 and when I opened it I saw a modchip Duo X2 AMD. My problem is as follow: when I turn it on pressing the power button sometimes it boots to a blue screen (Linux Cromwell) and sometimes it boots to to xbox dashboard with a Evo M8 on the top left corner. How to control this boot process? How to know whrn to boot to each of the screens?
      There is a switch on the modchip and when I turn it tl the other bank it boot to FlashBios 3.0.3.
      My real problem is that I dont want to boot the blue Cromwell screen. Can somebody help me?
       
      Regards

Board Life Status


Board startup date: April 23, 2017 12:45:48
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.