Jump to content
  • Similar Content

    • By alerdr
      Hello everybody, I have a problem with my old xbox with amd duox2 modchip.. i would be happy if anyone could help..
      (sorry my english, i'm not a native speaker)
      I stopped using this xbox years ago because the DVD tray open and close casually, with no input from me (-> MAIN PROBLEM).
      Yesterday I decided to fix it: since every weld looked ok but the motherboard was very dusty, I tried to clean it up gently with compressed air and remove welding dirt from motherboard with the help of a cotton stick and alcohol.
      BEFORE the cleaning:
      - xbox powered up booting customer bios every time i plug it to the power, I could switch off by pushing the eject button;
      - xbox powered up with original bios if I switch off (pushing eject button) and then again switch on by pushing the eject button;
      - the power on/off button (smaller one) never worked as I can remember;
      - DVD tray open and close casually (and continuosly), with no input from me, with both bios.
      AFTER the cleaning:
      - xbox no more power up when I plug it to the power (no blinking led light on the modchip);
      - xbox powered up with original bios if I switch on by pushing the eject button;
      - xbox power on/off button (smaller one) still doesn't work;
      - DVD tray still open and close casually (and continuosly), with no input from me.
      Since I didn't mod the xbox by myself at the time, I looked some tutorial but I didn't find anyone using my setup. I don't know why I have BT point welded to the front panel..
      When the xbox was modded everything worked fine for a while, then I remember I got some problems and a friend did something at the weld on the motherboard.. I can't remember exactly (>15 years ago). I'm not an expert but it seems to me that there is a bad connection somewhere..
      Are there anything I can try to find the problem? Can I simply remove/unweld the modchip and get the xbox work like when it was original?
      Please login or register to see this attachment.
      Please login or register to see this attachment.

    • By DanielL99
      Hi there,
      I'm new to the og XBox world
      I bought a XBox half year ago and took it apart.
      I found out that it has an "Aladdin 2" modchip and as far as I understand is also TSOP modded.
      It's a NTSC XBox v1.0.
      My questions for you are:
      Do I really need the modchip?
      As far as I understand the v1.0 has a big TSOP Chip, which can be splitted into banks, if I really need different bioses.
      So does this modchip anything different/special?
      And why do I need different Bioses?
      I just want to use this Xbox as (region free) Gaming console and maybe for XBMC.
      And is there a cheap (and easy) way to get digital output?
      I only got a VGA adapter with this XBox and it doesn't really work with my TV.Please login or register to see this attachment.
      Please login or register to see this attachment.
    • By Mountaindew117
      Hello all I was just wondering what modchip I would need to get for my xbox console. I've heard of really only the aladdin xt plus 2 and was wondering where I can get my hands on them because amazon doesn't sell them & ebay doesn't sell them. I even looked on aliexpress and alibaba and no one has these things in stock.
      Background on why I'm needing some is simply I was doing a mod for a friends xbox. The process was going great, I had the softmod installed and ready for a tsop mod which went fine, I flashed my windbond bios over to the 1.4 xbox with a windbond chip inside, went to go do my hard drive upgrade and thats where everything went wrong. How did it go wrong??? Well I plugged in my new hard drive, startech ide to sata adapter, and 80 wire ide cable and turned on the xbox booted up but error coded out because there was nothing on the hard drive and I needed to load the hexen 2019 disc, loaded the disc and shut down and restarted the console. Blob animation ran its course and the xbox logo appeared on screen with linux underneath and evox badge in the top left corner and hung up there. I said ok it might take it a minute so I went outside and took out my trash and recycling, let the dog out, made and ate my breakfast and went to check on it after about 30 minutes or so have passed, I actually forgot about it, and it was still on that screen. I thought that unleashed x would have seen the new drive by now but nothing. So I went back and reflashed my bios for f & g, xbox turned off after it was flashed. Pushed the power button and nothing but power cycling and red and yellow led lights. Was told that the flash failed for some reason and now my only hope was a modchip.
      I seem to never be able to do these mods in one shot without problems its always something.
      But any and all help would greatly be appreciated, Thanks everyone!! 

Board Life Status

Board startup date: April 23, 2017 12:45:48
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.