Jump to content

Welcome to our site

Take a moment to join us. You can sign in with Facebook with a couple of clicks. No need for a lengthy registration. We also have Tapatalk support so you can use this forum on your phone the same way you use facebook. It will keep you notified.

XPeter

Possible? Use Tsop_m7 Bios To Recover Modchip

Recommended Posts

Dear, all Xbox fellow

I had a spiderchip since 14 years ago for my xbox, which is still working.

ABout 2 weeks ago, I wrongly flash 512kb bios into my xbox (1.1) TSOP (1mb), causing it unbootable.  I was trying to find a way to recover the TSOP, and one way was to use a modchip with special bios "tsop_m7.bin" for recovery.  So I did flash the spiderchip with tsop_m7.bin.  But I forgot my DVDROM is not working, so this method is not workable.  And eventually the TSOP issue was resolved with "3-wire trick". 

Now, the spiderchip is left useless without normal bios, and it seems the guaranty way for recovery is to use external programmer, which I don't have and don't know how to use.   There are some forums discussed quite good success of using modchip hotswap, and even Softmod to flash modchip (NOT TSOP).

So I decided to use most cheapest way - softmod - to recover my spiderchip.    But as my Xbox 1.1 mobo is soldered for TSOP flash,  I don't want to revert back to stock status.  I remember my cousin has a Xbox 1.5 (softmoded) which has not been used for long time.  Borrowed from him,  still can turn on,  BUT ERROR 07,   reconnect/changing IDE cable didn't work.   Changed to another HDD,  Error 06, obviously it should be the HDD issue.       My cousin doesn't have eeprom backup in PC, but he is quite sure it was backed up inside the 8G xbox HDD (WDC).   So I tried many times to do HDD hotswap connected to my laptop through USB-IDE cable and XboxHDM (Windows version),   no luck,   the Xbox HDD lock status is alwasy enabled.   NOT sure it is because of wrong timing or USB-IDE problem which may trigger the HDD to relock.

In actual fact, the easiest way to access locked xbox hdd is to use modchip,   but the spiderchip is useless with tsop_m7.bin bios inside.  Out of sudden, I was wondering,  Can this special bios be used to re-flash the modchip?

According to the steps in Please login or register to see this link.   ,     A15 & D0 need to be removed in sequence in order to activate TSOP,  but I am not aiming at TSOP,  so I don't remove the A15 & D0,   Should it work to re-flash the spiderchip?

 

Anyway, I have already tried last night,  and I am facing the problem to boot to the Orange Xbox logo (tsop_m7) on this Xbox v1.5.     Previously i had nearly no issue to get the orange xbox logo on my xbox v1.1. when chip-in with this spiderchip.      The v1.5 Xbox remains with black screen for 1-2min,  then shutdown and reboot automatically,   However, there about 3-4 instances, when I can see the orange logo, ONLY BY slightly lifting the spiderchip off the board (then re-seat?).  But that is not always working.    Out of this 3-4 instances of seeing orange logo,  only one instance could move to a new blue screen saying the xbox hdd need to be formatted,  do you want to proceed?     Surprisingly, it is not HeXEn DVD main menu, which I am expecting.

I understand the spiderchip is solderless, which is not stable in terms of contact with LPC,   But I am quite sure that,  as long as using my finger to press the chip into the LPC, the spiderchip is working perfectly,    But why is so for xbox v1.5 ,   do I need to shortcircuit or ground some points

 

Peter

Share this post


Link to post
Share on other sites

I remember Spiderchip and its elegant metallic case.

One thing to note is that a 1.5 Xbox (if it would exist) would require an LPC rebuild to get the required 3.3v and gnd. So basically two additional wires vs 1.4.

 

Edited by lapa988

Share this post


Link to post
Share on other sites
On 10/10/2018 at 6:47 PM, lapa988 said:

One thing to note is that a 1.5 Xbox (if it would exist) would require an LPC rebuild to get the required 3.3v and gnd. So basically two additional wires vs 1.4

I also read something about this.   However, According to spiderchip manual, only D0 wire is needed for Xbox 1.0 - 1.5,  other spring-wire can be cut off.     And this Spiderchip had been used for this Xbox (1.5)  10 years ago for softmod purpose, so it should work for this xbox. ;).  

Here is link to the online Spiderchip manual

Please login or register to see this link.

 

D0 wire.JPG

 

Peter

Edited by XPeter

Share this post


Link to post
Share on other sites
8 hours ago, lapa988 said:

I was kindly trying to hint that the Xbox you have is 1.4 and not 1.5.

Thanks for reminding me, Lapa988

I looked at its series number, the last 5 digits is 31605, and manufacture date is 2003-04-16.  So according to 

Serial Number Revision
LNNNNNN 20WFF 1.0
LNNNNNN 21WFF 1.0
LNNNNNN 23WFF 1.0 or 1.1
LNNNNNN 24WFF 1.1
LNNNNNN 25WFF 1.1
LNNNNNN 30WFF 1.2
LNNNNNN 31WFF 1.3
LNNNNNN 32WFF 1.3
LNNNNNN 33WFF 1.4 or 1.5
LNNNNNN 42WFF 1.6
LNNNNNN 43WFF 1.6b

 

It is highly likely  v 1.3

The reason I call it v1.5,  because I had an impression (of 14 years) that I ever got the version number from XBMC after I managed to softmod my cousin's xbox. 

:22_stuck_out_tongue_winking_eye:

I will try to play around the modchip again see whether can be re-flash.   Meanwhile I also ordered Arduino Uno R3 kit (expensive than a 2nd-hand xbox ^_^), see whether I can retrieve the eeprom or reflash the modchip as well. 

May the force be with me !  :1311_thumbsup_tone2:

 

Peter

Edited by XPeter

Share this post


Link to post
Share on other sites

Does the TSOP_M7 BIOS boot to a dashboard?

Which one?

Can you upload and run evoxdash from the booting dashboard?

If it runs, evoxdash should be able to re-flash the modchip.

 

Share this post


Link to post
Share on other sites
1 hour ago, KaosEngineer said:

Does the TSOP_M7 BIOS boot to a dashboard?

Which one?

Can you upload and run evoxdash from the booting dashboard?

If it runs, evoxdash should be able to re-flash the modchip.

 

NO,  the TSOP_M7 BIOS didn't boot to dashboard,  and I think it is expected to boot DVDROM (e.g. HeXEN DVD) for modchip recovery according to its "official" instruction:    Please login or register to see this link.

** BTW,  the 8GB WD HDD should be spoiled (very slow in response),  that is why got ERROR 07

In short,  for TSOP recovery by TSOP_M7 BIOS in modchip,  it requires A15 / D0 grounded,  then off-ground during booting, so Installation-DVD can re-flash TSOP

My intention /hypothesis is opposite,  Keep A15/ D0 grounded,  wish xbox boots to installation-DVD, and re-flash the modchip.     

PS:   1.  For modchip booting in this case,     is A15 grounding necessary?       2. If yes, I need to change my A15 point, which was wrong early,  (I noticed this mistake during another post by AlaskaCC)

 

 

Peter

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Board Life Status


Board startup date: April 23, 2017 12:45:48
  • Similar Content

    • By BloodbathG
      hi,
      i have got my xbit 1.5 to work after 5 days messing with it i have loaded the iND-BiOS.Beta.Feb-11-05.67.bin (256k) and when i start the xbox i see a screen saying ind bios. but then it load to the standart dashboard with no new options. do i need now a hexen dvd and make a softmod to unlock everything? i thought when you dissable the modchip the xbox will start up in stock config, but when i softmod it this will still be active.
       
      what should i do next after booting the new bios: make a softmod or get another dashboard? i think it goes only like this: softmod and then the installation of a dashboard.
      thanks for your advice
    • By keebord
      I have an xbox v1.6 that i had modded with the white X2 duo GS probably 12 years ago that worked flawlessly.  Well i put it in storage and took it out maybe a year ago and the HDD died and i could not get it to boot from either of the banks on the chip, both just make it turn on and off.  The xbox is softmodded now with a new HDD but i really want to get this chip working again.  does anyone have any ideas to get a bios back on it or why it might have just died from not being used?  i also have two other xbox systems, one of them v1.4 that i just did the tsop flash for the first time using this page and that worked great and i have another that is either 1.2-1.5 that is softmodded but not yet tsop flashed.  can i use them to flash it?   Any help would be greatly appreciated. 

    • By pjhcast
      Hi friends I came.
      Today, 128Mod and 1Mega BIOS
      Split Dual Boot ...
      ind bios 5004 67 and evox m8 plus 137
      I'll be back

×

Important Information

By using this site, you agree to our Terms of Use.