Jump to content

Welcome to our site

Take a moment to join us. You can sign in with Facebook with a couple of clicks. No need for a lengthy registration. We also have Tapatalk support so you can use this forum on your phone the same way you use facebook. It will keep you notified.

psnap777

Dvd Drive Replacement Laser Availability

Recommended Posts

Hi Guys. Does anyone know where to buy a replacement laser for a Thompson drive and a Phillips drive? I have two XBOXs with bad drives. I have tried cleaning the laser with alcohol and adjusting the laser but they went from reading some games to reading no games. I have looked on Amazon and eBay but have not been able to find any. Are replacement lasers no longer available for these drives? What are you guys doing with these failed drives? Are you running your XBOX without a DVD drive? My concern with doing this is how would you reload with a disk like Hexen 2017 without a working DVD drive if you ever needed to?

Share this post


Link to post
Share on other sites

i couldn't find the eyes but i would try a whole new CD drive 

i just stack them up in the garage with any other scrap  but i keep my best CD drives off unless i am going to use it

Share this post


Link to post
Share on other sites

psnap, i've got a slim box with no drive in it. the scrap drive that was in there i harvested the board from in order to run it with softmod only (v1.6)
it worked just fine. i have since installed a cheap modchip in case what you're describing happens and i lose a drive (you can null with rocky softmod i am unfamiliar and will leave it for another poster)

What im getting at if, a pc dvd drive (i happened to have an ide dvd drive kicking around) will work. you need to have the power hooked to the stock drive and then ide hooked to pc drive while powering it with an outside source (or splitter but 3 drives is pushing it and likely wouldnt work on xbox PSU)

The question is "do i really have to go through all this hassle to set up a new drive with hexen" the answer is you likely wont be doing many times if you are just using this for standard homebrew application.

The PC drive will not play the xbox games because they are read in reverse or soemthing like that. I looked into dedicating a new pc drive to the box but for what its worth DVD is a media i do not support... the only dvd i use is hexen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Board Life Status


Board startup date: April 23, 2017 12:45:48
  • Similar Content

    • By AlaskaCC
      A friend gave me a v1.0 board that was causing problems for him.  I put it in a standard early case, attached everything and proceeded to test it.  I wanted to update the BIOS (TSOP) so I attempted to run the Hexen DVD.  The DVD tray would open, I placed the disk in the tray and pushed the button to close.  The Unleash X menu continued to show "Open".  I tried this with two known good working DVD drives - one a Samsung and the other a Hitachi..  I changed cables and PSU with no difference.  I also checked to see if there were any bent pins for the DVD power cable.  All good.  I switched-out the power button/DVD drive button harness.  No difference.  Then I tried a good Thomson DVD drive.  Everything worked flawlessly..  What is that all about?  Is there a different command structure for the early v1.0 boards that limits which DVD drives will correctly operate with them?
       
    • By psnap777
      I've got a v1.4 XBOX with an issue with the DVD drive not opening. I have already taken it apart and replaced the belt in the Phillips dvd drive. Then decided to swap drives with another working XBOX that also has a Phillips drive. After the swap, the issue remains with the original XBOX I was working on. In other words, the working drive from another XBOX now won't open. Meanwhile, the drive that I swapped into the working XBOX now opens. This leads me to believe that both DVD drives are good and maybe something is up with the motherboard in the original v1.4 I am working on. Do you guys have any ideas what could be causing this? Is my v1.4 motherboard bad? It seems to open if there is no disc in the tray. Once I put a disc in the tray it will read it and start the game. When I try to eject the game the screen goes black and the disc will not eject. It behaves the same way with both dvd drives I have tried it with and I have verified that both dvd drives are working.
×

Important Information

By using this site, you agree to our Terms of Use.